Adding New WVD RemoteApp has issues with the ts allow list

Copper Contributor

I've been running WVD Multi-session using RemoteApp groups/apps for about a month now.


Initially when I used the powershell commandlets for New-RdsRemoteApp I had no issues, but recently I've been having to manually add in the registry keys for the TSAppAllowList.  Suffice to say this makes things quite laborious.


I tried setting the fdisabledallowlist and haven't had any luck.  I'm a single host in a pool using service principal creds, I have a mix of apps that are created via app "aliases" and some that are created manually.  New apps of both types now will show up in the RDC client and start menu, but when launching will show the classic error related to TSAppAllowList registry keys missing and is resolved by me manually creating the keys. 

5 Replies
best response confirmed by mattplan8 (Copper Contributor)

@mattplan8 : Thanks for posting. Typically, the app allow list for a user refreshes when you initiate a new connection (not re-connection). Are you able to test that? If this still doesn't work, then we have a larger issue, as you shouldn't have to manually add to the allow list yourself.



Thanks for the reply Christian!


Just to clarify, when you say new connection are you referring to log off/on the host or subscribe/unsubscribe within the RDC app?


I can definitely try it out.


Not sure if you saw my other post regarding recent files/jump lists + remote apps, but if you had a moment to review that I would also be very grateful (  I was going to engage premium support but I don't even see WVD listed in the ticket options for Azure.





Confirmed the next day 2 I had not manually fixed were working.


I didn't get a chance to test if it's a log off/on or a unsubscribe/subscribe, but one of those fixed it.  I'll post back when I have a bit more time to test specifically.

I have the same issue, I need to reboot the host before the list gets updated.
You'll find that if you fully log off and on it will have the same effect. A disconnect/reconnect will not work.