Microsoft Remote Desktop for Mac - Copy and paste doesn't work

Microsoft Remote Desktop for Mac - Copy and paste doesn't work
10

Upvotes

Upvote

 Aug 29 2023
14 Comments (14 New)
New

Hello,

 

The copy and paste functionality doesn't work anymore. It used to work; i have the feeling it stopped working since the last update of Microsoft Remote Desktop.

 

EDIT for clarification: Copy and Paste from remote machine to local machine does not work.

 

I tried:

Setting (Edit PC > Devices & Audio) Clipboard mode to disabled, reconnected a machine and disconnected from the machine.

Setting (Edit PC > Devices & Audio) Clipboard mode to Bidirectional, reconnected a machine.

Setting (Edit PC > Devices & Audio) Clipboard mode to Remove to local only.

Remove Microsoft Remote Desktop and reinstalled it.

Deleted the running proces on target host named rdpclip.exe and restarted rdpclip.exe

 

Machine:

iMac Retina 5k, 27 inch, 2017

 

Software:

macOS Monterey version 12.1

Microsoft Remote Desktop for Mac, version 10.9.0.

Comments
Brass Contributor

I reinstalled 10.5.2 and copy and paste from remote to local works.

Copper Contributor

Thanks for posting this...I have the very same issue on macOS Big Sur version 11.7.8. I use this functionality very regularly and the issue only started happening with the 10.9.0 update that was applied on my system last week.

 

Installing the older version does work, but means having to re-create all of the machine connections (export does not retain passwords). The older version also installs the "Microsoft Auto Updater" or MAU2 since it is not managed by the app store versioning process.

Brass Contributor

Good day gmitche1,

 

Thank you for your comment.

 

My machines/connections (and saved accounts) were still available after deleting the new version and installing the older Microsoft Remote Desktop application.

 

My machines/connections were saved in my library folder i guess.

Copper Contributor

HI we have had the same problem with version 10.9.0 on Big Sur version 11.7.4 and 11.7.9, but on other Mac OS version monterey 12.6.1 and newer where we are able to test it works correctly
Regards

Copper Contributor

Hi, same here.

Big Sur 11.7.2. 

Copy and paste to and from remote desktops used to work fine before Version 10.9.0 (2140).

 

How can I revert to an older version ? I have no applications backed-up on my TimeMachine.

 

Thanks.

Brass Contributor

Hello Pathandfield,

 

I downloaded an older version from the internet; search for Microsoft Remote Desktop older version or something ;)

Copper Contributor

Same here as well. Downloaded 10.5.2 from here https://www.macupdate.com/app/mac/8431/microsoft-remote-desktop/old-versions
It fixed the copy/past from local to remote. 

Microsoft, please fix. 

Copper Contributor

Same problem here with Mac OS 11.7.9 and MS RD 10.9.0. (2140)

Copper Contributor

same problem, i reinstalled the 10.5.2 and it works now. It was a horror with 10.9.0

Copper Contributor

You must shut down and restart the Remote Desktop computer. After the restart it should work again. It worked for me.

Best wishes guys!

Copper Contributor

Version 10.9.5 (build 2179) appears to have fixed this.

Copper Contributor

Actually, I am currently running Microsoft Remote Desktop client version 10.9.5 (2179) on a MacBook Pro M1 Pro, on Sonoma 4.2.1, and I can't copy & paste between MacBook and remote desktop session, neither way.
Folder sharing works though, so it's not completely "cut off"...

 

Edit: I actually discovered that it's not ALL Remote Desktop connections that aren't working.
I noticed it on a remote Windows 7 machine (I know, it should have been replaced EONS ago, but you know... :)
I tried on another remote machine, Windows 11, and there it actually works... Very strange...

Copper Contributor

I struggle with this every day, many times pr day. It has been the same in multiple versions of Remote Desktop. Now I am using 10.9.6 (2188). The versions seem to make little difference.

Copy and paste works, for a while, not more than 10 minutes. Then I have to shut down the Remote Desktop app and start it again. I probably do this 50 times pr day. very annoying. 

Copper Contributor

The same issue is occurring in Jump Desktop as well. I think there might be a problem between Mac OS and the RDP protocol.