10.7.4 slow compared to 10.7.3

10.7.4 slow compared to 10.7.3
0

Upvotes

Upvote

 Jan 18 2022
9 Comments (9 New)
Tell us more

After upgrading to 10.7.4 on the Mac App Store, my remote desktop connection is very slow - clicks take several seconds to respond etc. I am using a gateway and a wired ethernet connection (getting 200Mbps down, 25Mbps up with the data center that hosts the machine I remote into).

 

I am certain the issue is with 10.7.4 build on the App Store because I uninstalled and I manually downgraded to 10.7.3 client (https://install.appcenter.ms/orgs/rdmacios-k2vy/apps/microsoft-remote-desktop-for-mac/distribution_groups/all-users-of-microsoft-remote-desktop-for-mac) and the rdp connection is fast again. All the settings are identical between the 2 clients.

 

I can also confirm if I run Parallels Desktop and use my Windows 10 VM and then use the native windows remote desktop client, it also runs fast.

 

I've seen this before with previous builds though I don't recall which ones were fast/slow.

 

I noticed in the release notes on the App Store that some changes were made with gateway load balancing but those seem to be detrimental in my case?

Comments
Microsoft
Status changed to: Tell us more

Hi @ChrisGrasp ,

 

Apologies for this inconvenience. Can you please provide more detail on how this error occurred? The most informative method would be providing a video, footage from a phone camera or screen capture works perfectly fine, that demonstrates your experience in the app and reproduces the lag you are experiencing (if the video file is too large to email please upload it to this Dropbox and specify this in your email). An alternative if you cannot take a video would be providing detailed steps on how the error occurs and how it can be reproduced.

 

Furthermore, please provide as much additional detail as possible in the email to help our engineers reproduce the error including:

  • If relevant, the number of users within your organization experiencing this issue
  • What hardware are you (for example: MacBook Pro 13-inch, M1, 2020)
  • What type of operating system you are running (for example: macOS Monterey (version 12)
  • What type of resource are you remotely connecting to (for example: a Workspace in Azure Virtual Desktop, a PC running Windows Server 2016)
  • If relevant, how your Remote Desktop client is configured (for example: Is Drive redirection enabled, are you using external keyboard)

Thanks!

 

This will help us provide support as quickly as possible. Thanks!

Senior Member

Hi @JS , thanks for responding. Sorry for the delay I did not get the notification.

 

  • iMac 2017, Big Sur 11.6.2 (which is intel), 32GB ram
  • Running main iMac monitor + 2 external monitors (connected over USB-C to DVI adapters
  • 2048x1152 resolution on iMac monitor and 1920x1080 on the 2 externals
  • External keyboard and mouse connected to the machine over USB
  • Remoting into a windows 10 Pro workstation

 

  • Delete all MS remote desktops installed on your machine using Apple menu > about this mac > storage > manage > application > highlight and delete any MS remote desktop (I only ever have 1 version installed)
  • Install the 10.7.4 from the app store; edit connection > general, bypass local addresses=true; display > use all monitors=true, fit session=true, 32bit color; devices and audio > clipboard=true; folder > redirect folder=true but nothing setup for redirection. Every other setting is off under the VM edit screen/tabs. Under Preferences have the following Screen Shot 2022-02-08 at 9.00.42 AM.png
  • Using AD authentication (domain\...) and a gateway
  • Connect to my VM - slow, slow, slow
  • Now delete 10.7.4 using method described above.
  • install 10.7.3 from https://install.appcenter.ms/orgs/rdmacios-k2vy/apps/microsoft-remote-desktop-for-mac/distribution_g...
  • Use the exact same setting and preferences as described above > connect to my VM > its fast!
Microsoft

Hi @ChrisGrasp ,

Are you still experiencing this issue on the latest version for macOS 10.7.6?

Occasional Visitor

@js351Hey yes, still experiencing the problem. I have downloaded and installed every version and build since 10.7.3 and every one, including the latest 10.7.7 is experiencing this issue.

 

I did notice there is a setting under the (MacOS menu bar) Connections > Show Connection Info and I have pasted the stats below. I see the bandwidth is 50% LESS on 10.7.7 vs. 10.7.3, which may be the root cause. When testing both versions I am using an identical Mac, Ethernet connection (wifi disabled), remoting into the same machine and using the exact same gateway as well.

 

I noticed in the release notes for 10.7.4 there is a comment of "...In this release we addressed full screen display issues with the new 2021 MacBook Pro 14" and 16" models.

In addition, we updated the client to better handle load-balanced RD gateway configurations." which maybe this load balance change negatively effected my situation (I don't know if our gateway is loaded balanced or not) since every build from 10.7.4 onward is slow.

 

Under 10.7.3 this is what it says:

Timestamp (UTC): 2022-04-19 16:22:47 +0000
Activity ID: 8bd7c89c-4c02-4561-9002-db958d060000

CLIENT DETAILS
Client version: 10.7.3 (1966)
Local OS: macOS Big Sur 11.6.4

NETWORK DETAILS
Transport protocol: TCP
Round-trip time (RTT): 100 ms
Available bandwidth: 102.40 Mbps

SERVER DETAILS
Remote session type: Remote desktop
Gateway name: remote.mygateway.com
Remote computer: mymachine

 

Under 10.7.7

Timestamp (UTC): 2022-04-19 16:29:39 +0000
Activity ID: 6bc80483-afb4-45c0-baca-e612c5b70000

CLIENT DETAILS
Client version: 10.7.7 (1987)
Local OS: macOS Big Sur 11.6.4

NETWORK DETAILS
Transport protocol: TCP
Round-trip time (RTT): 91 ms
Available bandwidth: 53.64 Mbps

SERVER DETAILS
Remote session type: Remote desktop
Gateway name: remote.mygateway.com
Remote computer: mymachine

 

I left these rdp sessions open with this Connection Info screen just to see if the bandwidth fluctuated but they both remained similar - 10.7.3 had a ~100 Mbps while 10.7.7 stayed around ~50 Mbps.

 

Let me know please.

Senior Member

@js351 This is still a problem with the new 10.8.0 release (MacOS Monterey 12.6) where within the RDP session/window every mouse click is super delayed like closing windows, dragging windows, switching applications, clicking the start menu etc. is super slow. Again reverting back to the old 10.7.3 makes all these interactions responsive again.

 

I've even upgraded my internet recently to fiber (1Gbit up and down) so it cannot be my internet connection (I am using wired ethernet to my router, not wifi).

 

I cannot pin point from the release notes what changed after 10.7.3 to cause this poor responsiveness within the rdp window.

 

Could this be a misconfigured setting in the gateway conflicting with releases after 10.7.3?

Microsoft

Hi @ChrisGrasp,

Let me connect with the development team and get back to you. 

Thanks,

John 

Microsoft

Hi @ChrisGrasp @smittycodes ,

Regarding any differences on gateway functionality between version 10.7.4 and 10.7.3: a toggle was added to disable WebSocket for onprem gateways, because we had received feedback that WebSocket gateway was slow. If that applies to your scenario, I'd recommend disabling it to see if it makes a difference.

 

To disable WebSocket onprem gateway:

 

1) On a terminal run this command: defaults write com.microsoft.rdc.macos ClientSettings.DisableOnPremWebSocketGateway 1

 

2) Quit and restart the ap

 

Please let us know if that makes a difference. 

Senior Member

@js351 Still not working.

 

Steps I took:

  1. Updated from 10.7.3 to 10.8.0
  2. Closed 10.8.0
  3. On my local MacOS machine, opened terminal and ran: defaults write com.microsoft.rdc.macos ClientSettings.DisableOnPremWebSocketGateway 1
  4. Launched 10.8.0, connected and still have the 3-5 second delay on every mouse click event vs. the nearly instant mouse clicks under 10.7.3.

I also tried the opposite command "defaults write com.microsoft.rdc.macos ClientSettings.DisableOnPremWebSocketGateway 0" restarted the app and still slowness.

 

Very weird. Ended up reverting back to 10.7.3.

 

Could using multiple monitors have an impact? I noticed under 10.8 that it seems to be redrawing all the windows, as if a resolution change occurred although I did not change any settings when updating.

 

Would a video help?

Microsoft

I think a video would be helpful @ChrisGrasp could you please send a video demoing the issue to rdios@microsoft.com and cc johnspencer@microsoft.com.

 

Adding the description of the issue in the mail will be helpful too!

 

Thank you!