SOLVED

ADLS g2 storage accounts not showing up as a source

%3CLINGO-SUB%20id%3D%22lingo-sub-1984187%22%20slang%3D%22en-US%22%3EADLS%20g2%20storage%20accounts%20not%20showing%20up%20as%20a%20source%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1984187%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20a%20storage%20account%20(StorageV2).%20When%20adding%20a%20new%20source%20in%20Purview%20using%20the%20ADLS%20Gen%202%20connector%2C%20this%20account%20does%20not%20show%20up%20in%20the%20dropdown.%20However%2C%20if%20I%20try%20to%20add%20using%20the%20%22Azure%20Blob%20Storage%22%20connector%2C%20this%20account%20does%20show%20up.%3C%2FP%3E%0A%3CP%3EPlease%20advise%20what%20could%20be%20causing%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1985767%22%20slang%3D%22en-US%22%3ERe%3A%20ADLS%20g2%20storage%20accounts%20not%20showing%20up%20as%20a%20source%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1985767%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F69906%22%20target%3D%22_blank%22%3E%40Craig%20Bryden%3C%2FA%3E%26nbsp%3BCan%20you%20ensure%20your%20Storage%20V2%20account%20as%20the%20data%20lake%20storage%20gen2%20namespace%20enabled%20(done%20through%20the%20Azure%20Portal)%3F%20If%20it%20does%2C%20it%20will%20show%20up%20in%20the%20ADLS%20Gen2%20resources%20page.%20If%20not%2C%20it%20must%20be%20scanned%20as%20a%20blob.%20I%20actually%20had%20the%20same%20issue%20as%20my%20storage%20accounts%20were%20identical%20other%20than%20this%20property.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22DanielPerlovsky_0-1607960758682.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F240190i79EF1808A2625793%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22DanielPerlovsky_0-1607960758682.png%22%20alt%3D%22DanielPerlovsky_0-1607960758682.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
MVP

We have a storage account (StorageV2). When adding a new source in Purview using the ADLS Gen 2 connector, this account does not show up in the dropdown. However, if I try to add using the "Azure Blob Storage" connector, this account does show up.

Please advise what could be causing this?

1 Reply
best response confirmed by Craig Bryden (MVP)
Solution

@Craig Bryden Can you ensure your Storage V2 account as the data lake storage gen2 namespace enabled (done through the Azure Portal)? If it does, it will show up in the ADLS Gen2 resources page. If not, it must be scanned as a blob. I actually had the same issue as my storage accounts were identical other than this property.

 

DanielPerlovsky_0-1607960758682.png