Home

Cannot Change Adapter settings

%3CLINGO-SUB%20id%3D%22lingo-sub-218718%22%20slang%3D%22en-US%22%3ECannot%20Change%20Adapter%20settings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-218718%22%20slang%3D%22en-US%22%3E%3CP%3EWindows%20Server%202019%20TP%20build%2017713%20and%20earlier%20build%2017650.%3C%2FP%3E%3CP%3EI%20cannot%20change%20the%20network%20adapter%20settings%20when%20the%20server%20is%20a%20domain%20controller%20and%20logged%20in%20as%20a%20Domain%20Administrator.%20The%20following%20error%20will%20show%20up%3A%3C%2FP%3E%3CP%3E%3CSPAN%3EWindows%20cannot%20access%20the%20specified%20device%2C%20path%2C%20or%20file.%20You%20may%20not%20have%20the%20appropriate%20permission%20to%20access%20the%20item.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20able%20to%20change%20the%20network%20adapter%20settings%20on%20standalone%20server%20Windows%202019%20TP%20logged%20in%20as%20local%20Administrator.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20tips%20to%20be%20able%20to%20change%20the%20network%20settings%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-218718%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EGeneral%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ENetworking%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-387395%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20Change%20Adapter%20settings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-387395%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F296358%22%20target%3D%22_blank%22%3E%40Jack-Herow%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3EThis%20was%20the%20fix%20for%20me.%20Just%20spun%20up%20a%20VM%20on%206.7%2C%20Server%202019%20Standard.%3CBR%20%2F%3E%3CBR%20%2F%3EAfter%20adding%20AD%20and%20elevating%20to%20a%20DC%20the%20local%20admin%20no%20longer%20functions%20as%20an%20elevated%20admin%20within%20the%20domain.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3ECopy%20local%20administrator%20account%2C%20rename%20to%20what%20you%20need%20and%20reboot.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EProblem%20staying%20solved%2C%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-361203%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20Change%20Adapter%20settings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-361203%22%20slang%3D%22en-US%22%3E%3CP%3EThe%20problem%20is%20happened%20on%202019%2C%20if%20you%20use%20the%20%22administrator%22%20Account%20as%20primary%20Admin-Account%20(after%20Domain%20Join).%20Create%20a%20new%20user%20and%20apply%20the%20admin-groups%20and%20you%20will%20have%20no%20error.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-342203%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20Change%20Adapter%20settings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-342203%22%20slang%3D%22en-US%22%3E%3CP%3ELook%20at%20this%2C%20it%20was%20a%20server%20policy%20that%20needs%20to%20be%20modified.%20Resolved%20for%20me%20..%20(%3CA%20href%3D%22https%3A%2F%2Fsocial.technet.microsoft.com%2FForums%2Fen-US%2Ffb3bad72-82fb-4d74-9777-ddff71692707%2Fdomain-administrator-no-permissions-local-admin-has-permissions%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fsocial.technet.microsoft.com%2FForums%2Fen-US%2Ffb3bad72-82fb-4d74-9777-ddff71692707%2Fdomain-administrator-no-permissions-local-admin-has-permissions%3C%2FA%3E%3F%20forum%20%3D%20win10itprogeneral)%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-342125%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20Change%20Adapter%20settings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-342125%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20the%20same%20problem%2C%20it%20must%20be%20a%20bug%2C%20because%20if%20you%20go%20to%20the%20domain%20and%20%22copy%22%20the%20%22administrator%22%20account%20to%20a%20new%20account%2C%20and%20log%20in%20to%20the%20server%2C%20you%20have%20been%20able%20to%20open%20the%20network%20card%20settings.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-325854%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20Change%20Adapter%20settings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-325854%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20currently%20experiencing%20the%20same%20issue.%26nbsp%3B%20Did%20you%20ever%20get%20a%20resolution%20to%20this%20issue%3F%26nbsp%3B%20I%20installed%20my%20first%20two%20Windows%202019%20Servers%20as%20DC's.%26nbsp%3B%20One%20worked%20perfectly%20the%20other%20did%20not.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20I%20recall%20correctly%2C%20on%20one%20server%20I%20installed%20Windows%202019%20and%20then%20went%20straight%20to%20Add%20Roles%2FFeatures%20to%20make%20it%20a%20DC%20without%20joining%20the%20domain%20first.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EOn%20the%20second%20server%2C%20I%20joined%20the%20domain%20and%20then%20promoted%20it%20to%20a%20DC.%26nbsp%3B%20This%20was%20the%20one%20that%20didn't%20work.%26nbsp%3B%20I've%20even%20demoted%20the%20server%20and%20checked%20the%20local%20Administrators%20group.%26nbsp%3B%20It's%20showing%20Domain%20Admins%20(which%20is%20how%20am%20I%20am%20logged%20in)%20in%20the%20Local%20Administrators%20group.%26nbsp%3B%20%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20thoughts%20on%20what%20is%20going%20on%20or%20what%20I%20may%20have%20done%20incorrectly%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks!%3C%2FP%3E%3CP%3EJohn%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-219287%22%20slang%3D%22en-US%22%3ERE%3A%20Cannot%20Change%20Adapter%20settings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-219287%22%20slang%3D%22en-US%22%3EYeah.%20Now%20tell%20me%20how%20to%20change%20the%20VLAN%20that%20Hy%C3%BCer-V%20injects%20there.%20Hint%3A%20you%20can%20not%20%3B)%3C%2Fimg%3E%20How%20do%20I%20enable%20things%20like%20Routerguard%20or%20disble%20them%3F%20Hint%3A%20you%20can%20not.%20This%20is%20not%20about%20%22oh%2C%20i%20am%20stupid%22%2C%20it%20is%20about%20a%20bug.%20Changing%20things%20in%20the%20VM%20does%20not%20help.%20THis%20is%20a%20bug%20-%20one%20that%20really%20needs%20fixing.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-219142%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20Change%20Adapter%20settings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-219142%22%20slang%3D%22en-US%22%3E%3CP%3EYes%2C%20that's%20correct...I%20need%20to%20find%20the%20old%20Control%20Panel%20(Old%20GUI).%3C%2FP%3E%3CP%3EIt%20does%20not%20allow%20to%20change%20the%20NIC%20settings%20from%20the%20Start%20Menu%20%26gt%3B%20Settings%20gear%20icon%20(Win10%20GUI)%20or%20right%20clicking%20from%20the%20NIC%20icon%20at%20the%20task%20bar.%3C%2FP%3E%3CBLOCKQUOTE%3E%3CHR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F168020%22%20target%3D%22_blank%22%3E%40Philip%20Rosen%3C%2FA%3E%26nbsp%3Bwrote%3A%3CBR%20%2F%3E%3CP%3EHi%3C%2FP%3E%3CP%3EIf%20you%20go%20to%20Server%20Manager-%26gt%3BLocal%20Server%20and%20in%20Properties%20view%20you%20see%20you%C2%B4r%20nic.%20Change%20there%3F%3C%2FP%3E%3CP%3ERegards%20Phil%3C%2FP%3E%3CHR%20%2F%3E%3C%2FBLOCKQUOTE%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-219135%22%20slang%3D%22en-US%22%3ERe%3A%20Cannot%20Change%20Adapter%20settings%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-219135%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3C%2FP%3E%3CP%3EIf%20you%20go%20to%20Server%20Manager-%26gt%3BLocal%20Server%20and%20in%20Properties%20view%20you%20see%20you%C2%B4r%20nic.%20Change%20there%3F%3C%2FP%3E%3CP%3ERegards%20Phil%3C%2FP%3E%3C%2FLINGO-BODY%3E
Bienvenido Arendayen Jr
New Contributor

Windows Server 2019 TP build 17713 and earlier build 17650.

I cannot change the network adapter settings when the server is a domain controller and logged in as a Domain Administrator. The following error will show up:

Windows cannot access the specified device, path, or file. You may not have the appropriate permission to access the item.

 

I am able to change the network adapter settings on standalone server Windows 2019 TP logged in as local Administrator.

 

Any tips to be able to change the network settings?

8 Replies

Hi

If you go to Server Manager->Local Server and in Properties view you see you´r nic. Change there?

Regards Phil

Yes, that's correct...I need to find the old Control Panel (Old GUI).

It does not allow to change the NIC settings from the Start Menu > Settings gear icon (Win10 GUI) or right clicking from the NIC icon at the task bar.


@Philip Rosen wrote:

Hi

If you go to Server Manager->Local Server and in Properties view you see you´r nic. Change there?

Regards Phil


 

Yeah. Now tell me how to change the VLAN that Hyüer-V injects there. Hint: you can not ;) How do I enable things like Routerguard or disble them? Hint: you can not. This is not about "oh, i am stupid", it is about a bug. Changing things in the VM does not help. THis is a bug - one that really needs fixing.

I am currently experiencing the same issue.  Did you ever get a resolution to this issue?  I installed my first two Windows 2019 Servers as DC's.  One worked perfectly the other did not.  

 

If I recall correctly, on one server I installed Windows 2019 and then went straight to Add Roles/Features to make it a DC without joining the domain first.

 

On the second server, I joined the domain and then promoted it to a DC.  This was the one that didn't work.  I've even demoted the server and checked the local Administrators group.  It's showing Domain Admins (which is how am I am logged in) in the Local Administrators group.   

 

Any thoughts on what is going on or what I may have done incorrectly?

 

Thanks!

John

I have the same problem, it must be a bug, because if you go to the domain and "copy" the "administrator" account to a new account, and log in to the server, you have been able to open the network card settings.

Look at this, it was a server policy that needs to be modified. Resolved for me .. (https://social.technet.microsoft.com/Forums/en-US/fb3bad72-82fb-4d74-9777-ddff71692707/domain-admini...? forum = win10itprogeneral)

The problem is happened on 2019, if you use the "administrator" Account as primary Admin-Account (after Domain Join). Create a new user and apply the admin-groups and you will have no error.

@Jack-Herow 
This was the fix for me. Just spun up a VM on 6.7, Server 2019 Standard.

After adding AD and elevating to a DC the local admin no longer functions as an elevated admin within the domain. 

Copy local administrator account, rename to what you need and reboot. 

Problem staying solved,