Have you been working with Planner in Microsoft Teams?  Starting today, you can access all your plans from Teams within the Planner web app.  On the Planner hub, you’ll see plans from Teams included within the Recent plans and All plans sections, as well as their associated team and channel information.  You can favorite a plan for easy access and then work on it in Planner or open it up in Teams.  Planner apps mobile will see this as an update in the next week or so.  


Untitled-1.pngRecent plans list showing a plan from Microsoft Teams

For more information about using Planner in Teams, check out this article.


Happy Planning!



Occasional Contributor

GREAT NEWS! Thank you for getting this fixed.

Mmm...is this feature for both the desktop and the web client? 

Occasional Contributor

@JC - it's been sort of a bug in Teams/Planner. If you create a Plan via a tab in Teams, then went to Planner directly, the Plan wasn't listed there. Now, it will be listed there, too. There's no desktop client for Planner, so on web, and it sounds like mobile soon.

Regular Contributor


I hope making preferences sticky is on the list. I prefer to see My Tasks by due date first, not plan or bucket.





Occasional Contributor

good news)

Great!!! Is there a way to have board/chart/schedule that group together all plan within the Teams main plan?

Regular Visitor

Very nice to see the associated team & channel for each plan!  This could be a game changer for me- allowing the creation of a plan for each channel as opposed to a plan for each team & having each team & channel clearly identified for each plan.  The continuity through Team channels is great!


Regular Contributor

This isn't working correctly. When I go to tasks.office.com I see all of the groups that we use, which is mostly Teams for us, but I cannot see additional Planners created in those teams.


For example, we have a team where I have created (in Teams) a planner for just my projects to track, but allow my boss to see what I am working on.

When I go to the Planner hub, I can see tasks in that Planner if assigned to me as part of My Tasks, but if I click on that Team/Group, it is showing me the default Planner for that team, and there is no way that I can find to get to that other Planner that was created within that Team.

The only way I can find to get to Planners created in Teams is to go to that Team and find the tab they are on.


The same is true with the Planner app on iOS, the one just released that now lets me group by due date. This is version 1.5.3.


Hi @Ed Hansberry - in your Planner Hub experience, do you see both the "Recent plans" and "All plans" sections?  In the "Recent plans" section, you should see any of the Plans you've visited in Microsoft Teams.  In the "All plans" section, you should see not only the default Plan for each group/team, but also all the other Plans from Teams.  If you have a lot of Groups/Teams and Plans, you may need to give it a few seconds to load all the additional plans in the "All plans" section.  We currently do not offer direct navigation between Plans of the same group/team (like when you're drilled into the Board) -- it's something we're thinking about, but haven't settled on a design yet.  For now, you'll always need to go from the Planner Hub.  If you're still not seeing Teams plans in "Recent plans" and "All plans", shoot me a direct message and I'll see if we can sort this out offline.  Thanks!

Regular Contributor

Yes. When I scrolled down I saw the plan I wanted within the group. I added it as a favorite so I wouldn't have to go searching for it anymore.


Would like to see the ability to click on a group/team and see something showing all plans in the group. Maybe similar to how the Power Bi site works. Click on a group (PBI calls it a workspace, but it is a Team/Group for the most part) and you can see all reports and dashboards in that group.


EDIT: Side benefit of Favorite - now I can easily see that plan on my iOS Planner app.

Occasional Visitor

I would like to see a way that you can copy tasks from one plan to another plan, not just copy tasks within the same plan as you can now. For example, A user can have an All Projects plan that has linked tasks from a detailed single-project implementation plan. 

Regular Contributor

@Stephanie Paterson - You can copy to other plans. Not sure when it got added, but I suppose sometime between your post, and today.

Occasional Visitor

Hi Ed, I only see the copy feature working inside the original plan. Select copy task and it is duplicated in the same bucket. If you can reference a video that shows how that would be great. 


I would also like to the ability to link the same plan to multiple teams. 

Regular Contributor

Go to planner on the web.

Find your task and click the ellipses and Copy Task.

I get a dialog that has:

  • New Task Name
  • Plan Name
  • Bucket Name
  • Task info to copy (7), some of which get disabled if you change the plan. You cannot apparently copy Assignment, Attachments, Labels, between planners.


In the Plan name is a dropdown of a bunch of our planners. 

I actually see the exact same thing if I am in a Plan inside of Teams. Sometimes Planner items In Teams doesn't have all of the same stuff. You cannot add attachment in Team tasks, but you can on the web. Teams only allows URLs and Sharepoint links, not actual files, so there is still not 100% parity for planners between the Teams UI and website UI, but copying tasks appears to be working.

Occasional Visitor

Bit of inconsistent behaviour I noticed. We have restricted the creation of new Office 365 Groups via an Azure AD setting, so only a specific group is allowed to created new Unified Groups (as per https://docs.microsoft.com/en-us/office365/admin/create-groups/manage-creation-of-groups?view=o365-w...).


Where the ability to create new UG's is surfaced across the office apps, for example in Outlook ('New Group'), in Teams ('Join or Create a Team'), or in Planner ('New Plan'), users not in said group receive an error message "Your organization's global admin has turned off the ability to create new Plans and Office 365 Groups" which is as documented.


Therefore users who are prevented from creating new UG's by this Azure AD setting cannot create new plans within an existing group, since that requires first clicking on the 'New Plan' button (which immediately throws the mentioned error) followed by clicking on 'Add to an existing Office 365 Group'. They can however still add plans to existing groups via the Teams UI (new tab in any channel > Planner app> create a new plan).


On a separate but related note, I noticed that when UG's are created via the admin portal, or by New-UnifiedGroup (as we routinely do in order to enforce our internal management standards upon them), the user who creates them is added as a group owner, but not as a group member. I thought the latter would be implied by the former (as the Teams UI suggests when managing Team membership - each user is listed as one or the other; never both), but it seems not. If you are not a member in addition to being an owner, you will be unable to see the group under 'All plans' in the Planner UI, and you will be unable to add new plans to the group via the Teams UI as above.