Forum Discussion
MSBuddy25
Microsoft
Mar 04, 2021Join multiple tables
TableA
TableB
TableC
GUID_PK
Name
Desc
GUID_FK
PriLoc
SecLoc
GUID_FK
IsPriLoc
IsSecLoc
1
Test1
Desc1...
JLospinoso
Jul 29, 2021Copper Contributor
MSBuddy25 Hello, did you ever find an answer to this question?
- JLospinosoJul 29, 2021Copper ContributorIn this example, the tables are joined on the commonly named field “UserPrincipalName”, both tables have an “Id” field but the values are not the same. You have to use the “project” syntax to de-conflict and distinguish the left and right values by using “project” for each table.
SigninLogs
| project UserPrincipalName, IdLeft = Id
| join (Anomalies
| project UserPrincipalName,IdRight = Id)
on $left.UserPrincipalName == $right.UserPrincipalName
| project UserPrincipalName, IdRight