Forum Discussion
Steve_Aston
Oct 30, 2019Copper Contributor
Log Analytics Views pinned on Dashboard are too restricted
Hello
When I pin a query to a Dashboard, such as a graph, I find that the X axis of the graph does not display correctly. It shrinks the view of the labels on the X axis , even if you make it as big as possible.
For example, I have a query for activity per user over a period of time. It lists the 'Caller' name@myorganisation.co.uk along the X axis , it only shows organisation.co.uk and you cannot see the name of the caller, the name is lost in the format of the graph So it becomes less useful when someone else uses the dashboard as they cannot see the name.
2 Replies
- CliveWatsonFormer Employee
Two ideas.
1. use Azure Monitor Workbooks (using the same query) or ,
2. remove the ending of the data e.g. remove anything after the @ symbol
AzureActivity | where Caller has "@" | extend CallerName = trim(@"[^\w]+",tostring(split(Caller,"@",0))) | summarize count() by bin(TimeGenerated, 1h), tostring(CallerName)Go to Log Analytics and Run Query
- Steve_AstonCopper Contributor