Forum Widgets
Latest Discussions
Effective Cloud Governance: Leveraging Azure Activity Logs with Power BI
We all generally accept that governance in the cloud is a continuous journey, not a destination. There's no one-size-fits-all solution and depending on the size of your Azure cloud estate, staying on top of things can be challenging even at the best of times. One way of keeping your finger on the pulse is to closely monitor your Azure Activity Log. This log contains a wealth of information ranging from noise to interesting to actionable data. One could set up alerts for delete and update signals however, that can result in a flood of notifications. To address this challenge, you could develop a Power Bi report, similar to this one, that pulls in the Azure Activity Log and allows you to group and summarize data by various dimensions. You still need someone to review the report regularly however consuming the data this way makes it a whole lot easier. This by no means replaces the need for setting up alerts for key signals, however it does give you a great view of what's happened in your environment. If you're interested, this is the KQL query I'm using in Power Bi let start_time = ago(24h); let end_time = now(); AzureActivity | where TimeGenerated > start_time and TimeGenerated < end_time | where OperationNameValue contains 'WRITE' or OperationNameValue contains 'DELETE' | project TimeGenerated, Properties_d.resource, ResourceGroup, OperationNameValue, Authorization_d.scope, Authorization_d.action, Caller, CallerIpAddress, ActivityStatusValue | order by TimeGenerated ascAdeelazizJan 17, 2025Brass Contributor101Views0likes0CommentsLog Analytics dropping logs if the application shuts down immediately after
In my micronaut application, there is an error condition where I write the error to the logs and then I am forcing my application to shutdown. The shutdown happens as expected, but I do not see the error log that was fired just before the shutdown. Is it possible it is lost? Is it related to latency? My understanding is that even with the latency, I should get to see the error log.JohnOldmanApr 05, 2023Microsoft496Views0likes0CommentsAzure Container Apps observability tools
Learn about the observability tools you can use to observe, debug, and diagnose your Azure Container Apps in the blog post below! https://techcommunity.microsoft.com/t5/apps-on-azure-blog/observability-with-azure-container-apps/ba-p/3627909 What observability features in Azure Container Apps do you use most frequently? Which are the most helpful for you?EricStarkerSep 19, 2022Former Employee746Views0likes0CommentsLog analytics - increase the column length
Hi In Azure Log Analytics I have noticed that the length of the column "Statement" is 4000 characters and we have queries written by some users longer than 4000 characters. Is there a configuration for column length in Log Analytics in order to store up to 8000 characters? Thank youdancraciunAug 24, 2022Copper Contributor1.1KViews0likes0CommentsAzure monitor alert for CPU usage > 80% for 30 minutes or more?
I would really appreciate if someone could help me with this. I am trying to create an Azure monitor alert for CPU usage >= 80% for 30 mins or more I've attached a screenshot of the condition for the alert rule. Under 'Evaluated based' on does the 'Aggregation granularity (Period)' mean that the alert will be triggered only if the CPU average is greater thank 80% for 30 minutes or more?terrymarkAug 18, 2022Copper Contributor4.1KViews0likes0CommentsCross app query doesn't work
In the past, we can do cross app query like the example mentioned in this articles: https://docs.microsoft.com/en-us/azure/azure-monitor/logs/cross-workspace-query#identifying-an-application Not sure starting from today or this week, it doesn't work anymore. It will always result "no result found from the XXX hours", even it DOES really have data if I go directly to the particular application insight to query.Gordon Lam (SH)Jul 18, 2022Microsoft509Views0likes0CommentsAutomate disconnecting(or pausing) VM Insights on VMs
Is there a way for me to automatically disconnect or pause VM Insight on VMs? I have a few problem VMs that have been producing several million event logs in just a few days and I want to be able to automate the process of turning off VM Insights on them once they pass a certain threshold as well as email the owners' of the VM(if possible)?3rdfitzgeraldJul 18, 2022Copper Contributor546Views0likes0CommentsActivity Alerts (set up via https://security.microsoft.com/managealerts) are not being received
To test activity alerts, I modified 10 different files in my SharePoint tenant and, though I set the alerts to detect those specific modifications and email me for each one, I only received 2 out of 10 emails. The first two email notifications were received within 10 minutes but, after 8 hours, the other 8 alerts have not been received. I do not see the activity for any of the 10 modifications in the activity log either. The metadata in SharePoint confirms that I made the changes, but the alerts are not being triggered. What can be done to ensure that these activity alerts are triggered with consistency?tgraham-legalopsJul 13, 2022Brass Contributor862Views0likes0Comments
Tags
- azure monitor1,093 Topics
- Azure Log Analytics401 Topics
- Query Language247 Topics
- Log Analytics63 Topics
- Custom Logs and Custom Fields18 Topics
- solutions17 Topics
- Metrics15 Topics
- workbooks14 Topics
- alerts14 Topics
- application insights13 Topics