Windows Server Summit 2024
Mar 26 2024 08:00 AM - Mar 28 2024 04:30 PM (PDT)
Microsoft Tech Community

Windows Server 2022 App Compatibility FOD breaks Remote Desktop

Brass Contributor

When installing the App Compatibility FOD on Windows Server 2022, Remote Desktop connections to the server seem to be no longer possible. I think this is a bug, but haven't found any other reports. Can someone confirm?


How to reproduce:

  • Install Windows Server 2022 Standard Core (physical and virtual installs are equally affected).
  • In SConfig, enable Remote Desktop.
  • Connect to the server via Remote Desktop using the default 'Administrator' account. Works fine.
  • Install the App Compatibility FOD and reboot:


Add-WindowsCapability -Online -Name ServerCore.AppCompatibility~~~~


  • Try establishing a Remote Desktop connection again. Doesn't work. You either get a blank screen or get disconnected immediately.
  • Install all applicable Windows Updates and try again. No change.
  • Remove the App Compatibility FOD and reboot:


Remove-WindowsCapability -Online -Name ServerCore.AppCompatibility~~~~


  • Try again. Remote Desktop functionality is now restored.

This did work fine in Server 2019.

32 Replies


I have the same issue and didn't find any solution yet

Same here.


Using windows admin center to remote manage but sometimes you still need RDP.  

Thanks for confirming. Hard to believe no-one at Microsoft noticed this. Without RDP, the App Compatibility FOD is pretty much useless, isn't it?
WAC is also my preferred management tool, but it's still missing some Hyper-V features (like attaching physical disks to a VM). So I would like to use the Hyper-V Manager (virtmgmt.msc) via RDP.
What's the best way to escalate this?
Because it's not a preview issue I'm not sure we can raise it via insiders. I did see the FOD install are currently broken in WinSvr vNext so perhaps this will get fixed when they re release it?

I will also try and raise this via my MS account team at work...
I'm running the release version and the issue is present. I'm waiting for an update that could fix it

I've been told by MS to log it in the feedback hub on a win10 or win 11 machine. I've done that so would be good for people to up vote.

I just noticed that the Devices Tool in Windows Admin Center shows a "Critical" device while trying to establish an RDP connection:


The drivers for this device are not installed. (Code 28)

I do not have any unknown devices when attempting to connect via RDP. It passes auth but then there is something not being invoked. I suspect it's graphics driver related, but not sure why FOD would alter that! I've done everything from re-install graphics drivers, to reverting to the windows basic driver to disable Bitmap Caching, RemoteFX etc. Still no joy :(
Same for me, tried several installs on different machines with different GPUs and drivers because I initially thought it might be a graphics driver issue. But I'm now pretty confident it isn't.
I've given up for now and use WAC plus local KVM when absolutely necessary. Hoping for a timely patch.

Hey @JOHNPILLAR, I just installed Feedback Hub to upvote the issue. But this seems to be just a steaming pile of rants about Facebook being broken and other nonsense. I was unable to locate your bug report. Could you post a link (if that's a possibility with Feedback Hub) or some keywords? I tried the obvious ones.

Link to bug report:
Title: Windows Server 2022 - App Compatibility FOD breaks Remote Desktop (RDP)

I used your well explained steps to re-produce, hope that was ok.
Thx, upvoted yesterday.

@JOHNPILLAR, the link doesn't work for me. Feedback Hub says: "Your account doesn't have access to this feedback". Is this for Insiders only?

Oh, there should be no restrictions on it. I did not set any so must be a MS thing.

@mauricewalker with my work Account i also have no access to this feedback...

Upvoted as well - since apparently uservoice doesn't exist anymore - would love to know how this hit GA.
I have the same problem without a server core. Any news?
same. rdp not working.
but in version with no graph interface it works.
@sysadminRiga thanks and interesting. Can you share install params/changes to any settings etc.

1 best response

Accepted Solutions
best response confirmed by mauricewalker (Brass Contributor)

This is now fixed in OS Build 20348.524 (KB5010354), available from Windows Update since February 8, 2022.

View solution in original post