Windows Server 2019 install product key not working

Copper Contributor

i Have tried both Standard and Datacenter product keys and get errors with both

83 Replies

Hi Greg, based on the information we have, we are unable to replicate the issue you are experiencing.  Can you tell us what build/source the running desktop (upgrading from) is, and what build/OS you are attempting to upgrade to?



best response confirmed by Dave Franklyn (Brass Contributor)

Did you install, choose NOT to enter the product key, then after the install was done, try to enter and activate the key?  if so, that does not appear to work.  I ran into the same issue on 2 of my 2019 servers.  I wiped them out and this time entered the key during install, and it successfully activated.  if I were to guess, they made something in the install to take into account these testing keys, but the Activation function within Settings, has not been updated to reflect that, so it thinks you are activating a live version of Windows, and that is not a valid key there.  That is entirely a guess on my part.  I didn't bother running a wireshark or anything to see what kind of response I was getting when trying to activate from Settings.


Just as an FYI, based on the earlier response, the 2 machines I was seeing this issue on, were not upgrades, they were brand new installs on a blank hard drive.  I have not gotten around to trying the in-place upgrade yet.  I don't know if this will help your situation, but I can say that I saw exactly what you were describing, and if you enter the key during the actual install, it appears to work.  I have not looked into the release notes to see if there is something that says Activation from Settings is not set up to work yet.


Sorry, I didn't see you had a screenshot attached.  I can't explain why it fails for you during the actual install.  That was the only way I could make it work.  Hopefully you will get some kind of answer.


Thanks, Gregory.  That's exactly what I did wrong.


See ya on the OTHER side of my re-installation!  LOL.




I also installed it without entering any key. At the moment I have not had any problem. How much time do I have to enter a key? Is it only possible to validate it by reinstalling the system?

I got the "Windows Not Activated" logo no the screen after about half an hour.


So I followed Gregory's advice above and reinstalled, this time putting in the key as part of the install job.  So far, I haven't got the Activation logo after 24 hours straight running.


As to your question, there is an old adage here in Alabama that goes, "If it ain't broke, don't fix it." 


I don't think you I should tell you what to do, since you aren't getting the issue I and others had, no? :)



I got it to work on a clean install. The only issue I have now is get .Net 3.5 to install

I find it strange that I did not show that logo, so I asked. I've been around for 3 days and for now nothing. I guess that soon I'll have that logo and I do not want to make much progress and do it all over again.

So I think I'll reinstall.

Thanks for the tips

Thanks Gregory .. wondered why the activation wasn't working. Blew the machine away and reinstalled and now working.

I have the same exact issue, but I have already installed twice now and not so thrilled that I may need to do it a 3rd time. I have ALWAYS installed windows by passing the key during install and just using my 10 Pro key from within settings. THAT has always worked for me on Windows 10 Pro.

So why that same exact thing doesnt work here is just crazy. It does however recognize that it is a Insider Build 17713 and it seems to run great. I just wish it would let me sign into my Microsoft account somewhere or at least let me Activate it using the Standard key that was given to everyone. I can't even find a Feedback Hub to give feedback as it tells me I need to install it. Jeez

Oh well... I should have just dumped Server and used Ubuntu Server, that is soooooooo much easier.


I had Windows Server 2019 Insider Preview Build 17692 installed and activated on my SRV. Just downloaded the Windows Server 2019 Insider Preview Build 17713 ISO - mounted it, end started an update. Everything went good, but now, the OS isnt activated. 


Windows activation not working. If i reenter the serial, the activation fails too.

I have the same exact problem :(

Hi Folks,

We apologize for the frustration this has been causing.  We have several bugs opened and are working through these.  Here is a possible solution in the meantime.  Since it is difficult to tell exact steps from this thread, here is our repro and workaround.  Step #6 is the workaround.  Hope this helps.


  1. Install RS_PRERELEASE 17692 (Standard Full)
  2. Mount RS5_RELEASE 17713 ISO
  3. Upgrade 17692 to 17713 (Standard Full)
  4. After upgrade check two issues that should repro.
    1. On the desktop there is no watermark for OS is not licensed
    2. When running from a command prompt, cscript c:\windows\system32\slmgr.vbs /dlv – OS shows as not licensed
  5. Try to activate from UI: Settings -> Update & Security -> Activation -> Activate
    1. This will error saying product key is not valid
  6. From a command prompt use cscript c:\windows\system32\slmgr.vbs /ipk <product_key>
    1. OS should activate
I have jumped staright to step 6., and OS activated now. Thanks for the solution!
Worked for me! Thank you so much, Brent!

Also, the issue is now fixed in 17723, so workaround should not be necessary.  Sorry, the workaround and fix came out at the same time but glad we are getting this covered for you!

Sadly, its too late now, I have already gone back to Server 2016 and probably not going to install 2019 until its time to retire 2016 in a few years. Glad they got the issue fixed though.

Thanks for the feedback, Rod.  And thanks for participating in the Insider program!

Brent you just saved me hours of re-installations... Thanks so much!