Windows Server Summit 2024
Mar 26 2024 08:00 AM - Mar 28 2024 04:30 PM (PDT)
Microsoft Tech Community

windows server 2019: DHCP/DNS/static IP

Copper Contributor


I'm using VMware and made a fresh install of windows server 2019 Version 1809. It is still configured as Workgroup and I want to migrate to Domain. I searched some tutorials but there is always one issue:

When I open the "network adapter - TCP/IPv4 - extended" it's not clear to me which IP-addresses to enter. I've tried some combinations and after closing all network adapter windows it always ends with a new window:

Windows network diagnosis - found problems - DHCP is for Ethernet0 not activated - solved

As my IP-settings are somehow based on beginners level I don't know the correct values.


My environment:

An AVM Fritz!Box is my router with IP so this is to enter as gateway (?) The router works as DHCP-Server and so DHCP is not needed in windows server 2019, right?

As I understand some posters it is recommended to set a static IP for the server, like which is still free.


Please have a look at my 3 screenshots.



4 Replies

Possibly there is a problem with the VMware settings - network adapter?

Default was NAT, now I changed to Host-only, but no success.

one step further:

I changed network settings to Bridged -> network is now ok.

Still trouble with IP settings as network diagnosis starts after closing TCP/IP window.

so far my WS2019 works now as domain server/controller.

It seems important to set VMware Network Adapter to Bridged.

Now I can successfully ping from the host-OS to WS2019 in the VM.


Some help I found in this Video and in this document

In this site they use NAT as network connection so its not clear how this works


As described in document "Windows Server 2019-Step by Step Installation of Domain Controller"

finish your work:

Server Manager - Tools - DNS - Reverse lookup zone - New Zone - ...


cheers folks

Yes, setup the guest as bridged. Then domain controller and any members should have the static address of DC listed for DNS and no others such as router or public DNS