WDSServer Service Event Error 7011

New Contributor

I am looking for advice in troubleshooting a WDS server. I have been using the same server for a little over a year, and it ceased responding to PXE boot requests last week. The system log on the server reports a Event 7011 error "A timeout (30000 milliseconds) was reached while waiting for a transaction response from the WDSServer service."

 

I have tried spinning up a new virtual server with a fresh install of Server 2019 and ended up with the same results. At this point I am thinking that MS released an update the may have caused an issue.

 

Any other idea I can check?

2 Replies

@JCorle 

 

Hello JCorle,

 

I hope you are doing well!

 

In order to troubleshoot the WDS server error or event ID 7011 error, you may need to follow the below-mentioned tips to resolve your issue,

 

In the software, click on the Start button and click Run 

Type regedit, and click OK to open service.

In the Registry Editor, go to: HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControl registry subkey.

In the Business section, find the ServicesPipeTimeout entry, right-click on it, and select Edit.

 

Now, You will have to edit the registry part to increase the default timeout value for service control handlers. To increase this value to 62 seconds, you have to follow these steps:

 

Click on the Start, open the Run command

Type regedit and press OK.

Locate and click the registry subkey:

HKEY_LOCAL_MACHINESYSTEMCurrentControlSetControl

In the right pane, find the ServicesPipeTimeout service.

 

If the ServicesPipeTimeout connection doesn’t exist, then follow these steps:

  • On the Edit menu, select New and click DWORD Value.
  • Type ServicesPipeTimeout and press Enter.
  • Click Decimal, enter 60000 and click OK to set.

 

The above value represents the time in milliseconds, after which the time product will get exhausted.

 

Lastly, Restart your computer.

 

Thus, I hope the above tips or ideas will help you resolve the WDSServer Service Event Error 7011.

 

-------------------

Regards,

Austin_M

@Austin_M 

 

       Thanks for the advice. I have been playing with different timeout settings, but unfortunately I don't seem to be making any headway yet. It doesn't seem to matter how long I make the timeout I am still getting the same error and not seeing much else in the event log that I can act on to find a solution.