Unable to install Windows Server Backup on Windows 2019 Essentials

Occasional Contributor

Trying to install Windows Server Backup feature on a newly installed Windows 2019 Essentials server. When trying to install it comes back with the below error:

 

Install-WindowsFeature : The request to add or remove features on the specified server failed.
Installation of one or more roles, role services, or features failed.
The source files could not be found.
Use the "Source" option to specify the location of the files that are required to restore the feature. For more
information on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077. Error: 0x800f081f
At line:1 char:1
+ Install-WindowsFeature Windows-Server-Backup
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (@{Vhd=; Credent...Name=localhost}:PSObject) [Install-WindowsFeature],
Exception
+ FullyQualifiedErrorId : DISMAPI_Error__Failed_To_Enable_Updates,Microsoft.Windows.ServerManager.Commands.AddWind
owsFeatureCommand

When looking at the available features the Backup feature is displaying this:

 

[ ] Windows Server Backup Windows-Server-Backup Removed

 

Have tried to download an ISO of the OS and installing using DSIM with the source switch, as well as the Install-Windowsfeature within Powershell. All advising that the source files cannot be found.

 

I have tried everything I can think of to get this installed.  Any suggestions would be appreciated.

 

Sean Buckle

4 Replies

Sounds like the OS may be broken. You can try repairing servicing

sfc /scannow

dism /online /cleanup-image /restorehealth

 

 

 

@Dave Patrick 

 

I have same problem with Server 2019 so followed your below instructions, however, it did not fix the situation.

 

sfc /scannow

dism /online /cleanup-image /restorehealth

 

Any other suggestions?

 

Thanks for your help.

Did you fix this problem as I am having same problem?

Thanks,

I am having the same issue on Server 2019 Std. Any one have a fix for this yet?
I have tried the following commands:

dism.exe /online /Cleanup-Image /StartComponentCleanup

dism /online /cleanup-image /restorehealth

sfc /scannow

 

They all succed with 100% and no errors. then once I run the installation, it comes back with no source found.. even if I provide source file from the wim or from another server, same issue.. very frustrating..

 

PS C:\Windows\system32> install-windowsfeature windows-server-backup
install-windowsfeature : The request to add or remove features on the specified server failed.
Installation of one or more roles, role services, or features failed.
The source files could not be found.
Use the "Source" option to specify the location of the files that are required to restore the feature. For more
information on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077. Error: 0x800f081f
At line:1 char:1
+ install-windowsfeature windows-server-backup
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : InvalidOperation: (@{Vhd=; Credent...Name=localhost}:PSObject) [Install-WindowsFeature],
Exception
+ FullyQualifiedErrorId : DISMAPI_Error__Failed_To_Enable_Updates,Microsoft.Windows.ServerManager.Commands.AddWind
owsFeatureCommand

Success Restart Needed Exit Code Feature Result
------- -------------- --------- --------------
False No Failed {}