Server 2019 .net 4.8 not showing in features

Copper Contributor

The server is up to date. The offline installer for .net 4.8 has been installed. Running the KB4486153 update for .net 4.8 says it is already installed. Version 4.7 is the only thing showing up in Add Features. Nothing is broken. Everything appears to be functioning correctly.



7 Replies
best response confirmed by Doug_Villaire (Copper Contributor)
It's included in the OS, , that's why you don't see it and Add Features

Thanks. That clarifies a lot. Our new software requiring .net 4.8 was installed last night with no problems.



Good to hear! Please mark my answer as the solution to mark this post as solved.

@Harm_Veenstra shows .NET 4.8 to be not preinstalled on Windows Server 2019.

It can be installed, though, but after that it doesn't show up in the Programs and Features control panel.


That's weird, I did see 2019 in that link with a checkmark? The software did install however?
I had a similar strange experience with Server 2019 but am still analyzing what was happening.
It was a customer-supplied fresh Server 2019 with all the recent updates installed (according to the customer).
Trying to install an msi file for an application requiring .NET 4.8 failed because the CA "DIRCA_CheckFX" (from the VS Setup Project) didn't find .NET 4.8.
After installing ndp48-x86-x64-allos-enu.exe, .NET Framework 4.8 didn't show up in Programs and Features, but now the installer went through.
The automatically generated boot strapper setup.exe still doesn't recognize .NET 4.8 to be installed, though.
That is strange. Why does it have to be so tricky/weird... Good thing that it is included in Server 2022, I don't install 2019 anymore at the moment and just 2022 for new installations/migrations (When possible, usually it is)
1 best response

Accepted Solutions
best response confirmed by Doug_Villaire (Copper Contributor)