Server 2016 Activation

Not applicable



I am having some trouble activating a newly installed Server 2016 VM. It is showing error 0xC004F074. We are simply attempting to use a MAK key. When trying to use slmgr /ipk or any other slmgry cmd we receive Error: 0xC004D032 as attached. Not sure if I have just used the wrong ISO or something during the initial install.



3 Replies
some ideas to try:
- are you sure that you tried to run your slmgr command in an ELEVATED CMD.EXE windows (run as administrator ) ?
- be carefull to use CMD.EXE et not the POWERSHELL windows
- always use for slmgr purpose, the full command line syntax with all pathes and runtime:
cscript.exe %Windir%\system32\slmgr.vbs /ipk xxxxxxxx
- have the same error if you try to activate via GUI ?

Please check whether you use MAK key for OLP licenses and KMS license key might not work as they need local key management server.


Make sure you have internet connection before activating it.




Encountering the following error during activation:

Error(s):  Activating Windows(R), ServerDatacenter edition

Error: 0xC004F074 The Software Licensing Service reported that the computer could not be activated. No Key Management Service (KMS) could be contacted. Please see the Application Event Log for additional information.

KMS Server authentication error due to caching.


Cleared the cache using the following commands and resolved the issue.


@echo off

slmgr.vbs /ckms

slmgr.vbs /ato



Steps are below:

Open PowerShell with Admin Privileges

% { iex "$env:windir\system32\cscript.exe $env:windir\system32\slmgr.vbs /ato" ; start-sleep 5 }

KMS Client Setup key will be changed as per OS Version

iex "$env:windir\system32\cscript.exe $env:windir\system32\slmgr.vbs /ipk CB7KF-BWN84-R7R2Y-793K2-8XDDG"


iex "$env:windir\system32\cscript.exe $env:windir\system32\slmgr.vbs /ato"


If you still facing activation issue try below command for clear activation.

Open CMD with Admin Privileges

@echo off
slmgr.vbs /ckms
slmgr.vbs /ato


Once Successfully cleared KMS Key retry below command with PowerShell

iex "$env:windir\system32\cscript.exe $env:windir\system32\slmgr.vbs /ato"