SOLVED

Server 2016/2019 Crash after Win Update

New Contributor

Hey :)

So we started to got this strange problem after January Patch Tuesday, our 2016 server will randomly crash when applying the new opdates.
It has happen at every Patch Tuesday since, and totaly random. Different server crash every patch tuesday.
It could be the same server og new server that crash after Patch Tuesday. No server have crash on all patch tuesday, but in totalt we have 35-40 differnt servers that have crashed out off 100 total 2016 with the specs down below.
I have restored a server from backup, and when i try to update it, it can crash after first try or after 5 times. It's random if it crash or not.

Crash Info:

Mads-Ejnar_0-1622720571476.png

 

The Server goes into BSOD and don't start.
Most time the server will start after a manuel restart, a few times we had to restore the server from the day before.

The only server we have this problem on is:
Windows Server 2016 / 2019
1 Core (E5-2690 v4 or Gold 6132)

All other server do not crash, if they got 2 or more cores.

All Server are VM's in VMware on ESXI 6.7 build: 17700523 - EVC: Intel Broadwell
VMware Tools Version 11.2.0 and 11.2.5 are running on the servers.

Everyting i have tried so far, but the problem is still there.
-SFC Scan and Dism
-Tried remove Anti-Virus software on server we installed back in December (F-Secure 15)
-Tried remove .Net 4.8 that was installed along F-Secure
-Tried remove VMware Tools / downgrade. Was upgraded to 11.2.0 back in December
-Tried upgrade Hardware Version on the VM from 10 to 15. Know this should not do anything, but tried anyway.
-Tried Reset firewall settings
-Tried Disable IPv6
-Tried Regsvr32

Also tried alot of combination of all of them. But nothing.

What fixed the problem so far, but not a solution
-Add more hardware. If they have 2 cores or more.
But that's no a great solution because we are a hosting site and end user pay for the hardware in the server, so either the end user have to pay more, or we should give it for free.
-Disconnect the network when restarting the server.
-Disable Firewall


So now om not sure what to try and what could be the problem.
I think there is a performens problem some where, since that serveres with more hardware don't have the problem. But can be totaly wrong. 
If there is a corrupt fil, should it not crash every time and not at random?

Do any of you have an idea on what's to try next?

 

1 Reply
best response confirmed by Mads-Ejnar (New Contributor)
Solution
Found the problem.
The problem start when F-Secure is installed. And will stay on the server after F-Secure is removed.
Tried to install windows from a ISO and only install F-Secure, server will crash if it only have 1 core.
Only thing to do is to give all server 2 core or more because F-Secure can't remove the error. They say the problem is at Microsoft, and they have a fix in Server 2022 and will not apply that fix to older windows. So nothing we can do about it beside give alle server more cores.

So do you have alot of 1 core server, don't use F-Secure as antivirus on your server.