SOLVED

remote desktop connection - Black Screen (nothing loads)

New Contributor

I am having some issues with a Windows 2012 R2 Standard with remote desktop services installed.


There are issues for a particular account that is experiencing login issues. When they log in, all they get is a black screen, nothing loads.

I have cleared the user profile, closed all sessions for the user and have successfully still been able to log in under other accounts on the same server.

 

When i check via task manager, there are only 3 running processes for the user:

Client server runtime process

Desktop window manager

windows logon application

 

In event viewer, under system, there is a common error log when they (no one else) logs in:
Unable to start a DCOM Server: {AAC1009F-AB33-48F9-9A21-7F5B88426A2E} as Unavailable/Unavailable. The error:
"5"
Happened while starting this command:
C:\Windows\system32\TSTheme.exe -Embedding

 

Any known issues for this one? There have been no recent windows updates that we have applied before this first started as well..

4 Replies

I've tried deleting local profile as well..

best response confirmed by Phillip Coronakes (New Contributor)
Solution
I added the user to the local users group and this resolved the issue

The user is only part of the domain admins group - which is most likely the issue

Thank You for right direction!

In my case was primary user group Domain Admins and server was DC.

When i add and changed primary user group to Domain Users, problem was solved and user logged without problem. :facepalm:

@pekas -Can you please provide the steps you have followed to resolve black screen after login to the server 2016.