RDP not working on hyper-v server 2022

Copper Contributor

I can only connect to any hyper-v server from hyper v manager on the fysical host.

When the connection is up and running i can start MSTSC from my local windows 11 and connect to the server and take over the session.


if i try to connect directly to the server i can logon but the connection gets droped.


when connected from the hyper-v manager the microsoft hyper-v videocard is installed.

when connecting using MSTSC the Microsoft Remote Display Adapter is also installed.


The Vm has all the latest update's installed.

In Hyper-V switching Enhanced Session mode has no results

The problem Exist on all my 2022 Hyper-V VM's


this is in the event log:

The Desktop Window Manager process has exited. (Process exit code: 0x800401f0, Restart count: 8, Primary display device ID: Microsoft Basic Display Driver)

this happens multiple times per second. 


The servers i have are all installed afther  8-8-2022.


anybody any sugestions? 




13 Replies

@Ferry001 - I just setup a Server 2022 box on Hyper-V 2019 today, and am having the exact same issue.  Did you ever find a resolution?

Sophos Endpoint Agent is the problem. deinstall it and the problem is gone. I have not found the right setting for sophos yet to solve the problem it. I did find out that changing the setting of the firewall it is working on one server and not on an other.
We have the same problem, but there is no third-party anti-virus on the Hyper-V server to blame, so it's something.

Did you solve your issue, and if so what was the problem, please?
best response confirmed by Ferry001 (Copper Contributor)

It turned out it was not the anti virus but the amount off processors. You need at least two of them


@Ferry001 thanks for the reply.


Sadly your suggestion does not apply to us, because we are having the blackscreen problem on the physical Hyper-V server itself, not one of the VM's. The Hyper-V server has direct access to the physical Xeon CPU.




I use ConnectWise ScreenConnect and have a similar problem on server 2022 physical hosts only, the VMS work fine. This issue started a couple months ago. The issue does not happen on Server 2019.


Both servers are Dell PowerEdge (T430, T550) with different Matrox chips.


The issue occurs whenever I log off my session. I can see my cursor go to the top left of the screen and then I get a message from ScreenConnect that my session was "interrupted and possible UAC prompt."

When the issue occurs the Matrox display driver gets disabled and shows error 43 in device manager with yellow exclamation. After this RDP gives black screen and disconnects with error 0x3 extend 0x10.

After this happens, I can no longer connect to the server via Connectwise or VPN/RDP. After some time (1-2 hours) the T430 recovers but the T550 requires a reboot every time . In the event log I see about 7-10 errors "The Desktop Window Manager process has existed. (Process exit code: 0x800401f0, Restart count: 4, Primary display device ID: Matrox G200eR (Renesas) WDDM 2.0)". I have tried removing the Matrox software and using only the Microsoft Basic Display Driver and it exhibits the same behavior as the Matrox driver just at a crappier resolution.


Like you I do not have 3rd party AV on these servers, but there is still Microsoft Defender. My only solution is to disable Microsoft Defender's Real Time Protection either permanently or just before I log off (tamper protection might re-enable after a few minutes?) so for me it does appear to AV related as others have said. Once I do this, I can log off the server without the ScreenConnect error and without the display driver crashing with error 43 on the T430, the T550 which is a much newer host still crashes and requires a reboot to recover.


I can replicate this scenario at will on both physical hosts.


I have tried older drivers to the newest Matrox drivers, various rdp related GPO settings, dism, sfc, but nothing helps. Any other suggestions would be appreciated. I would open case with MS and may still, but it took them 8 weeks to get back to me when I reported the "effective access" issue, and the support agent did not even know that was already fixed, ugh.

Thank you very much for your detailed response.

We traced the problem back to Splashtop remote access software. Once we uninstalled Splashtop and went back to TeamViewer the black screens stopped and we don’t see the continuous Dwminit errors in the Application logs anymore.

We too only observed this problem on Windows Server 2022. The Hyper-V hosts we manage that run Windows Server 2019 do not suffer from this problem when Splashtop is installed.

We still have the Matrox Display Driver error in Device Manager on the Server 2022 Hyper-V host, but it no longer seems to result in the black screens.

It sounds like our Splashtop problem was a very similar problem to your issues with ConnectWise ScreenConnect. In our case, we are happy to switch back to TeamViewer Host. I suspect it is a GPU driver issue in Server 2022, but we are not going to pursue the problem any further at this stage.

I hope this helps you in some way.

Hey thanks you so much for your response, that actually helps a lot and certainly narrows it down for me. I was suspecting it might be the ScreenConnect after all the other things I have tried. I think I will open a case with them and see what they say. It's interesting that SC works perfectly in Server 2022 VM but not physical host. So bad interaction with Matrox driver I guess or MS Remote Display adaptor.

Thanks again, it was very helpful.
A very similar problem to what we saw. In our case, Splashtop worked fine on all the Server 2022 VMs. It only broke the physical host.

The fact that we still see the GPU error in Device Manager, even with Splashtop uninstalled and after a reboot, makes me think it has something to do with the Matrox GPU when running Server 2022.

Good luck with your search and post back here if you get to the bottom of it!

In our case, the issue was caused by the software BackupAssist. Uninstalling the software and re-installing version 12.0.4r1 resolved the issue.


BackupAssist Classic v12.0.4r1
Released August 28th, 2023

Urgent fix release
Urgent: Avoid “black screen” and other Remote Desktop/Team Viewer connection issues after reboots on installations that have applied Windows update KB5028166 on Windows 11 and KB5028171 on Windows Server 2022.
The root cause is a change in the OS that causes some services to fail to start when driver operations are unexpectedly handled as failures (eg. in CryptoSafeGuard Shield, various Anti-Malware drivers, etc).

@mwisch , thank you for your reply.


Your findings are VERY interesting because we had Backup Assist v12.0.3 installed on the server that was exhibiting the problem.


We have recently upgraded to v12.0.4r1 so hopefully it is fixed for good now. 

You just made my day!

Thanks for this information, both servers have Backup Assist. I have tested on our internal lab server which also had the issue described. I installed version 12.05 over the top of the existing 12.03 and the issue is now resolved. I am able to RDP and have also put Screen Connect back on the system and both work flawlessly. No crashed display driver, no black screen, no problem 43 in device manager. I had forgotten this was even on the test server because it did not show in the add/remove programs (was installed under local administrator account when server was built and then was joined to domain, after this it no longer shows in start menu or add/remove), apparently it installs only for current user with no option to change.

Going to tackle client's server later this week but this looks like your solution is the fix for our situation as well.

Again, thank you, your sharing of information is invaluable.



I know this is a little late in response to this, but this issue has just come up for me.  In my case this VM doesn't do much, just holds some license servers so I had left it with a low amount of resources.  It does have Connectwise Control and Trend Micro Worry Free installed.  We were having issues where it would login and then give an error about "Network problem has occurred" and boot us out.  Dwminit errors in the Event Logs.


The solution seems to be adding more virtual processors and RAM.  Once I did this, the RDP connection logged in successfully (I added 3 processors and another 8GB RAM).


Thanks for the tips!

1 best response

Accepted Solutions
best response confirmed by Ferry001 (Copper Contributor)

It turned out it was not the anti virus but the amount off processors. You need at least two of them


View solution in original post