NLB does not respond on same subnet

New Contributor

I'm having an issue with a Microsoft NLB server cluster, it DOES respond to ICMP from clients on different subnets but it DOES NOT respond to ICMP on the same subnet (broadcast domain).


Both servers are running Windows Server 2012 R2.

Both servers are running with a single NIC.

Both servers were working until a recent restart.

Both servers are VMs running on a 2012 R2 hypervisor.


I know this is an ARP issue, but this ARP problem only impacts guests in the same broadcast domain. Our routers have a static ARP entry which is working for clients on different subnets, but when a client tries to discover the MAC address for this NLB cluster within the same broadcast domain it never receives a reply.


If I manually enter the ARP entry into the clients table this works.


Has anyone else experienced this before?


(The issue is not our routing as devices from different VLANs are OK.)


If I run apr -a -v from a client on the same subnet that has tried to discover this ARP is has the following entry:


Internet Address         Physical Address           Type               00-00-00-00-00-00       invalid


2 Replies
NOTE: I cannot add these manually to our server estate, that isn't a viable option, I need to identify why the NLB process isn't responding to ARP queries.
best response confirmed by Alex Wilden (New Contributor)
Found a resolution to this, some how the virtual interface used by the NLB had an advanced feature disabled.

The resolution was to enable the Enable MAC address spoofing setting for all members of the NLB cluster.