Issue with duplicate DNS fix when DC's mix uppercase/lowercase

Occasional Contributor

So, in a recent KB fix included in:


It is supposed to solve:

Addresses an issue that might cause domain controllers (DC) to register a lowercase and a mixed or all uppercase Domain Name System (DNS) service (SRV) record in the _MSDCS.<forest root domain> DNS zone. This occurs when DC computer names contain one or more uppercase characters. 


Here's an issue I have been running into however. This worked well on one of my DC's, the PDC, which does not do any automatic updates. However, I think this fix is left OUT of the April cumulative update, which is a problem.


It seems like this was an addendum to the March cumulative update, so it will not be installed if that cumulative update is. Then, when the April update is installed, you end up with a problem.


You can't install the prior update due to it now being "Not Applicable" since a more recent cumulative update exists. I have tried removing the April update, but still having an issue. Working on removing some other more recent updates as well.


Can anyone from MS confirm whether or not this particular fix is included in the April cumulative update, or if it was left out mistakenly? Right now the domain is fine, but I would like to get this fix in place on all the DC's running DNS, not just the PDC.


Will update if I am able to manually install the update that contains the fix after some more update roll backs.


8 Replies

Not sure where you got an April update as that has not been released (at least publicly) as yet. If you think this is a bug you can report here and no charge will be incurred..




best response confirmed by Jim_Mason (Occasional Contributor)

Ok, looks like an almost year old cumulative update. May want to get current by installing the latest SSU


followed by the latest cummulative update.









@Dave Patrick 


Jesus. I completely missed the year.


I see what has been going on here. It looks like this DC has not been properly updating the full cumulatives. Something was getting missed in WSUS automatic approvals.


Given the current month, my brain just filled in 2020 lol. Man I spent an entire day looking at all of this and completely missed that.


I'm glad I got some other eyes on the problem because I was beating my head against the wall getting way more complicated in "solving" this than obviously was needed.


Thanks for taking the time to respond, you saved me another wasted bunch of hours.

@Dave Patrick 


Oh and also thank you for mentioning:


It turns out, my issue with the latest cumulative package being considered "Not Applicable" seems to have been related to not having installed the above first.


The most recent cumulative is installing currently on that DC, looking forward to having everything patched up.


Thanks again.

Glad to hear, you're quite welcome.



@Dave Patrick 


FYI, installed perfectly after being sure to install the previously mentioned update before the cumulative.


Everything great across the domain now, thanks again so much for taking a minute to assist!

More good news, you're welcome.