Error reconnecting to RemoteApp Workspace

%3CLINGO-SUB%20id%3D%22%5C%26quot%3Blingo-sub-3175408%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Ben-US%5C%26quot%3B%22%3EError%20reconnecting%20to%20RemoteApp%20Workspace%26lt%3B%5C%2Flingo-sub%26gt%3B%3CLINGO-BODY%20id%3D%22%5C%26quot%3Blingo-body-3175408%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Ben-US%5C%26quot%3B%22%3E%3CP%3EI'm%20having%20an%20issue%20in%20a%20Corporate%20RemoteApp%20configuration%20with%20this%20setup%3A%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3E-%20Server%202019%2C%20Connection%20URL%20is%20not%20public%2C%20just%20Private%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3E.%20Client%20WIN10%2C%20Workspace%2FRemoteApp%20connection%20created%20succesfully%20connected%20to%20Corporate%20VPN%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3ESituation%3A%20When%20I%20restart%20the%20Computer%20I%20have%20the%20following%20error%20trying%20to%20open%20the%20RemoteApp%20Workspace%20(Already%20connected%20to%20VPN)%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3E-%3CI%3E%3CSPAN%3E%26nbsp%3B%26lt%3B%5C%2FSPAN%26gt%3BWindows%20cannot%20find%20the%20remote%20computer%20that%20contains%20the%20connection%26nbsp%3B%26lt%3B%5C%2FI%26gt%3B%3CI%3E%E2%80%83(IMAGE1)%26lt%3B%5C%2FI%26gt%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FI%3E%3C%2FSPAN%3E%3C%2FI%3E%3C%2FP%3E%3CP%3E%3CI%3E%E2%80%83-Make%20sure%20that%3A%3CBR%20%2F%3E%26nbsp%3B%20%E2%80%83%E2%80%83%E2%80%83%26nbsp%3B%20-%20the%20computer%20can%20connect%20to%20the%20internet%3CBR%20%2F%3E%E2%80%83%E2%80%83%E2%80%83%E2%80%83-%20the%20administrator%20has%20not%20removed%20this%20connection%3CBR%20%2F%3E%26lt%3B%5C%2FI%26gt%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FI%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3EIf%26nbsp%3BI%20want%20to%20reconnect%20from%20the%20Taskbar%20Icon%20I%20receive%20this%20error%3A%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3E%3CI%3E-%20Failed%20to%20reconnect%2C%20there%20are%20no%20disconnected%20RemoteApp%20programs%20or%20desktops%20to%20connect%20to%26lt%3B%5C%2FI%26gt%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FI%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3EIf%20I%20go%20to%20Control%20Panel%20and%20try%20to%20manually%20reconnect%20I%20have%20another%20error%20(IMAGE%202)%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3E%3CI%3E-%20error%20updating%20this%20connection%20error%20code%3A%200x80070003%2C%200x0%26lt%3B%5C%2FI%26gt%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FI%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3E%3CI%3EIMAGE1%26lt%3B%5C%2FI%26gt%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FI%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22%5C%26quot%3Blia-inline-image-display-wrapper%22%20lia-image-align-inline%3D%22%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Fgxcuf89792%2F%5C%26quot%3Bhttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F348851i0C27F6AF0DBD688A%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%5C%26quot%3B%22%20role%3D%22%5C%26quot%3Bbutton%5C%26quot%3B%22%20title%3D%22remoteDesk.JPG%22%20alt%3D%22%5C%26quot%3BremoteDesk.JPG%5C%26quot%3B%22%20%2F%3E%26lt%3B%5C%2Fspan%26gt%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CI%3E%26nbsp%3B%26lt%3B%5C%2FI%26gt%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FI%3E%3C%2FP%3E%3CP%3E%3CI%3EIMAGE%202%26lt%3B%5C%2FI%26gt%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FI%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22%5C%26quot%3Blia-inline-image-display-wrapper%22%20lia-image-align-inline%3D%22%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Fgxcuf89792%2F%5C%26quot%3Bhttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F348852iD87B165C91A5E0C6%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%5C%26quot%3B%22%20role%3D%22%5C%26quot%3Bbutton%5C%26quot%3B%22%20title%3D%22remoteDesk1.JPG%22%20alt%3D%22%5C%26quot%3BremoteDesk1.JPG%5C%26quot%3B%22%20%2F%3E%26lt%3B%5C%2Fspan%26gt%3B%3CSPAN%3ESo%20it%20looks%20like%20after%20rebooting%20my%20computer%2C%20the%20RemoteApp%20connection%20cannot%20connect%20to%20the%20URL%20(Private)%20since%20my%20Client%20connection%20is%20not%20yet%20connected%20to%20VPN.%20%26lt%3B%5C%2FSPAN%26gt%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EBut%20after%20connect%20to%20VPN%20the%20Workspace%20cannot%20get%20refreshed%20and%20I%20will%20need%20to%20delete%20it%20from%20control%20panel%20and%20recreate%20it%20which%20is%20something%20I%20dont%20want%20to%20do%20daily.%26lt%3B%5C%2FSPAN%26gt%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FSPAN%3E%3C%2FP%3E%3CDIV%3E%3CBR%20%2F%3EThanks%20and%20regards%20from%20Argentina%26lt%3B%5C%2FDIV%26gt%3B%26lt%3B%5C%2Flingo-body%26gt%3B%3CLINGO-LABS%20id%3D%22%5C%26quot%3Blingo-labs-3175408%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Ben-US%5C%26quot%3B%22%3E%3CLINGO-LABEL%3EWindows%20Server%26lt%3B%5C%2Flingo-label%26gt%3B%26lt%3B%5C%2Flingo-labs%26gt%3B%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3C%2FLINGO-SUB%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3175408%22%20slang%3D%22en-US%22%3EError%20reconnecting%20to%20RemoteApp%20Workspace%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3175408%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20having%20an%20issue%20in%20a%20Corporate%20RemoteApp%20configuration%20with%20this%20setup%3A%3C%2FP%3E%3CP%3E-%20Server%202019%2C%20Connection%20URL%20is%20not%20public%2C%20just%20Private%3C%2FP%3E%3CP%3E.%20Client%20WIN10%2C%20Workspace%2FRemoteApp%20connection%20created%20succesfully%20connected%20to%20Corporate%20VPN%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESituation%3A%20When%20I%20restart%20the%20Computer%20I%20have%20the%20following%20error%20trying%20to%20open%20the%20RemoteApp%20Workspace%20(Already%20connected%20to%20VPN)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E-%3CI%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3EWindows%20cannot%20find%20the%20remote%20computer%20that%20contains%20the%20connection%26nbsp%3B%3C%2FI%3E%3CI%3E%E2%80%83(IMAGE1)%3C%2FI%3E%3C%2FP%3E%3CP%3E%3CI%3E%E2%80%83-Make%20sure%20that%3A%3CBR%20%2F%3E%26nbsp%3B%20%E2%80%83%E2%80%83%E2%80%83%26nbsp%3B%20-%20the%20computer%20can%20connect%20to%20the%20internet%3CBR%20%2F%3E%E2%80%83%E2%80%83%E2%80%83%E2%80%83-%20the%20administrator%20has%20not%20removed%20this%20connection%3CBR%20%2F%3E%3C%2FI%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%26nbsp%3BI%20want%20to%20reconnect%20from%20the%20Taskbar%20Icon%20I%20receive%20this%20error%3A%3C%2FP%3E%3CP%3E%3CI%3E-%20Failed%20to%20reconnect%2C%20there%20are%20no%20disconnected%20RemoteApp%20programs%20or%20desktops%20to%20connect%20to%3C%2FI%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20I%20go%20to%20Control%20Panel%20and%20try%20to%20manually%20reconnect%20I%20have%20another%20error%20(IMAGE%202)%3C%2FP%3E%3CP%3E%3CI%3E-%20error%20updating%20this%20connection%20error%20code%3A%200x80070003%2C%200x0%3C%2FI%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CI%3EIMAGE1%3C%2FI%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22remoteDesk.JPG%22%20style%3D%22width%3A%20873px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F348851i0C27F6AF0DBD688A%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22remoteDesk.JPG%22%20alt%3D%22remoteDesk.JPG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CI%3E%26nbsp%3B%3C%2FI%3E%3C%2FP%3E%3CP%3E%3CI%3EIMAGE%202%3C%2FI%3E%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22remoteDesk1.JPG%22%20style%3D%22width%3A%20846px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F348852iD87B165C91A5E0C6%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22remoteDesk1.JPG%22%20alt%3D%22remoteDesk1.JPG%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%3ESo%20it%20looks%20like%20after%20rebooting%20my%20computer%2C%20the%20RemoteApp%20connection%20cannot%20connect%20to%20the%20URL%20(Private)%20since%20my%20Client%20connection%20is%20not%20yet%20connected%20to%20VPN.%20%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EBut%20after%20connect%20to%20VPN%20the%20Workspace%20cannot%20get%20refreshed%20and%20I%20will%20need%20to%20delete%20it%20from%20control%20panel%20and%20recreate%20it%20which%20is%20something%20I%20dont%20want%20to%20do%20daily.%3C%2FSPAN%3E%3C%2FP%3E%3CDIV%3E%3CBR%20%2F%3EThanks%20and%20regards%20from%20Argentina%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-3175408%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EWindows%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

I'm having an issue in a Corporate RemoteApp configuration with this setup:

- Server 2019, Connection URL is not public, just Private

. Client WIN10, Workspace/RemoteApp connection created succesfully connected to Corporate VPN

 

Situation: When I restart the Computer I have the following error trying to open the RemoteApp Workspace (Already connected to VPN)

 

- Windows cannot find the remote computer that contains the connection  (IMAGE1)

 -Make sure that:
       - the computer can connect to the internet
    - the administrator has not removed this connection

 

If I want to reconnect from the Taskbar Icon I receive this error:

- Failed to reconnect, there are no disconnected RemoteApp programs or desktops to connect to

 

If I go to Control Panel and try to manually reconnect I have another error (IMAGE 2)

- error updating this connection error code: 0x80070003, 0x0

 

IMAGE1

remoteDesk.JPG

 

IMAGE 2

remoteDesk1.JPGSo it looks like after rebooting my computer, the RemoteApp connection cannot connect to the URL (Private) since my Client connection is not yet connected to VPN.

But after connect to VPN the Workspace cannot get refreshed and I will need to delete it from control panel and recreate it which is something I dont want to do daily.


Thanks and regards from Argentina
1 Reply
well....I have tested this connection in a test machine directly connected to corporate network and all testing went well, so this is an isolate case in my PC which is always connected through VPN. In some moment, I guess when machine boots, the workspace cannot be recreated since the RemoteApp URL is not reachable before connects to VPN or something similar.
thoughts?