Domain user can not change password for AD by him self

New Contributor


I have a domain controller with windows server 2019 and also i joined many users to this DC and everything is ok expect that domain user cannot change his password by his self through his PC and when he tried to do this this message show to him "Unable to update the password. The value provided for the new password does not meet the length, complexity, or history requirements of the domain."

I did everything right from group policy , i opened group policy then right click on default domain policy and then clicked edit , then i clicked on this path : Computer Configuration>Policies>Windows Settings>Security Settings>Account policies>Password policy. and made changes about password policy and i saw that user`s PC had applied the policy but nothing change and also use could not change password, is this bug or what?

Please help me to solve this problem ASAP.

Sorry for little English 


4 Replies
best response confirmed by Vaguer (New Contributor)
Got it thanks , its work

Glad to hear, you're welcome.



Thanks for putting in here what worked so others that came along could give it a try.  Very useful...  @Vaguer