Windows Server Summit 2024
Mar 26 2024 08:00 AM - Mar 28 2024 04:30 PM (PDT)
Microsoft Tech Community

BitLocker network unlock issue

Copper Contributor



I'm struggling a bit with Bitlocker network unlock deployment in my environment.
I'm following this guide:


And I have 2 issues overall.

First one is the certificate request to CA. I'm able to request certificate and issue it w/o problems. The issue appears later on - the cert looks like it's selfsigned (certificate on the first screenshot is revoked beacuse I didn't want it to stay there since it didn't work like it should). Certificate on the second screenshot is the cert that's popping up in certmgr.msc on the machine that I was sending the cert request from. It is the same cert - yet it is not? It should end up in Personal container signed by CA but instead it goes to Pending container and it looks like its selfsigned.. Am I missing something? I'll be honest - I do not have an experience with CA. I simply followed the guide.

I made a workaround by doing a selfsigned in the next part, so it is not that big of a problem - although I'd like to have a signed cert there.

The real problem is - GPO settings.

I've tried everything. Updated the .ADMX files in SysVol manually, cleared GPO cache on the client machine, tried setting the GPO's from the guide to the multiple containers, even on the root domain level itself (just for testing puropses) - no luck. The policy simply do not apply. There is no error in RSOP or in gpresult. I've tested it on multiple machines and user accounts with Security filtering and without. I tied to split it to 3 separate policies to check if maybe one of them is problematic. None of these 3 policies applied even once. Other poclies are applied without any problems or issues.
What should I do now? Anyone had similar issue?

0 Replies