SharePoint Online Management Shell install issues

Frequent Contributor

I am on a Windows 10 system, local admin.

I go to run SharePointOnlineManagementShell_20616-12000_x64_en-us.msi

 

I accept the license agreement and ..... then nothing.

I see in taskmanager msiexec.exe

 

I logged on as my admin account (I log on with my user account) and then did the same, I was prompted for a username and password and the program installed.

Seems then it is MY user account.

I go to Pwsh.exe - PowerShell 7.1.0 and run as admin, I get the Consent prompt, and click Yes - UAC.

Administrator: Pwsh.exe

I tried to copy it from my c:\users\%username%\desktop folder to say c:\intel to see if it was causing issues...

I go to run SharePoint Online Management Shell Setup.  I click accept terms.  Install.

It disappears.

If it was the UAC, wouldn't it cause me to have the issue WHEN I launched PowerShell 7.1.0?

Again, when I logged off it worked.  I can't seem to get it to work for ALL users, it seemed to only work for that user account, or I would be happy.

I do NOT see it listed in Programs and Features or now Settings - Apps.

When I right click the MSI and go Repair - This action is only valid for products that are currently installed.

I see it listed in my start menu, yet I go to Uninstall, it takes me back to "Apps" and nothing is listed.

 

Is there any listing that shows the locations to remove or a way to resolve this without renaming the account.

I logged on as my admin account and seemed to mess it up as well.  Now both show the command prompt and never get past the flashing cursor.

Ctrl-C closes the program, which I was hoping would try to kick start it to "acknowledge" that it is was supposed to be working.

Thank you!

1 Reply

@Matthew Carter I have never done the msi install, I just installed the module from PSGallery. Using something like:

Install-Module SharePointPnPPowerShellOnline -Scope AllUsers -Confirm:$false