SOLVED

PowerShell UPDATE-HELP error

New Contributor

Dear Community,

I am a complete beginner with MS PowerShell. While making my first steps with PowerShell, I tried to update Help System by means of running UPDATE-HELP cmdlet on my PowerShell 5.1 - but I have gotten the following error message:

 

update-help : Failed to update Help for the module(s) 'PSReadline' with UI culture(s) {en-US} : Unable
to retrieve the HelpInfo XML file for UI culture en-US. Make sure the HelpInfoUri property in the
module manifest is valid or check your network connection and then try the command again.
At line:1 char:1
+ update-help
+ ~~~~~~~~~~~
+ CategoryInfo : ResourceUnavailable: (:) [Update-Help], Exception
+ FullyQualifiedErrorId : UnableToRetrieveHelpInfoXml,Microsoft.PowerShell.Commands.UpdateHelpCommand

 

Would you be so kind to advise me with solving this issue?

Many thanks in advance!

5 Replies
best response confirmed by kochetov_oleksii (New Contributor)
Solution
https://devblogs.microsoft.com/powershell/updating-help-for-the-psreadline-module-in-windows-powersh...

"The root problem in Windows PowerShell 5.1 is that the module is automatically loaded at startup using the PSReadline name (with the lowercase l). Use the following steps workaround this problem and update the help.

Close all powershell.exe processes. Then rename the PSReadline module folder name to PSReadLine.
Open an powershell.exe session in Administrator privilege.
Run Remove-Module PSReadLine to remove the auto-loaded PSReadLine module.
Run Import-Module PSReadLine (use PSReadLine with capital L).
Then run Update-Help -Module PSReadLine -Force
These steps load the module in your session using the new name, which allows Update-Help to use the correct name to find the help content."
Hello @#Harm_Veenstra
Thank you very much for your help. I've followed proposed solution and everything worked smoothly.
BR, Alex (Oleksii)

Hi @Harm_Veenstra 

 

Thanks for your suggestions but unfortunately this steps didn't work for me and getting below error please help with other solutions or how about installing a new version of Powershell which doesn't have this issues I am using WIN Datacenter 2019 server 64bit. with PS version 5.1.17763.592

PFA.

 

Rajeshlanke_0-1675796702208.png

 

 

You have many more modules with this issue in updating the help than just the PSReadline one... Does running "[Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12" before updating help?

@Harm_Veenstra  No luck ! even I executed below 2 command same issue .. but I would like to confirm this issue will not impact on my Powershell Administrative stuff like running scripts, commands everything will be accessible just If I go for help with that listed command/module  which is currently giving error that i won't able to get info. right?
Also please suggest how about installing a whole new version of Powershell which doesn't have this issue can you help with correct version.