HLK build 10586 is required starting on February 10, 2016
Published Mar 12 2019 07:13 AM 482 Views
Copper Contributor
First published on MSDN on Feb 04, 2016

Starting on February 10, 2016, HLK build 10586 is required in order to satisfy compatibility requirements. This kit enables compatibility testing of hardware for the Windows 10 and Windows Server 2016 operating systems.


In order to successfully test for Windows 10 compatibility, you must have the latest version of the Windows Hardware Compatibility Program Playlist.  The latest playlist is located here:



In order to certify your hardware for previously-released operating system versions, you must continue to use version 2.1 of the Windows Hardware Certification Kit (HCK). HCK 2.1 must be used to certify hardware for following operating systems:



  • Windows 7

  • Windows 8

  • Windows 8.1

  • Windows Server 2008 R2 (x64)

  • Windows Server 2012

  • Windows Server 2012 R2

Version history
Last update:
‎Mar 12 2019 07:13 AM
Updated by: