Windows Admin Center Access Denied

Occasional Visitor

Greetings,

2 days ago I installed WAC on my desktop Win 10 (1909). I was using Edge and added just a couple servers to monitor while I test this product. This morning I fired it up in Edge and right after I see the short list of Servers followed with the following error:

Denied.png

 

Please advise

Thanks

20 Replies
must have been a recent update - I just fired it up for the first ever and I'm getting this error message
Just tried again this morning. Same issue. Please advice if there is something I can do to get this going.
Thanks
Same exact issue, just installed the latest version with WinRM over https.

Exact same thing here. Incredibly frustrating to actually see it starting correctly, then after a second or two it changes its mind and says Access denied. Now I am left with nothing working, old version can't be installed either after uninstalling this new version. Well done MS. @ImNotBob 

Same problem here, even about the warning in the top right banner. Tried with Edge and Chrome.
I downloaded the installer again and reinstalled but doesn't work.
Worked fine last week.
Any suggestion?

So I managed to solve it with some trickery! My setup is btw a Windows 10 computer, joined to domain. What I did was make my useraccount a member of the local admin group, restarted my computer, and then installed with my normal useraccount, not the domain admin account I also have. Now I could start WAC by simply doubleclicking the shortcut on the desktop, select the correct certificate and then it works. MS has made a mess of this installation, seems they seem to think we are all local admins on our computers. Elevating with another account screws everything up. Still have not tried removing my local admin membership on the computer, it might break again when I do. I'm going to use the storage migration tool so I can live with adding my account to local admins when I use that in a couple of days, but it is not pretty. Hope anyone from MS reads this thread.....Fix an installer that isn't broken please! @ImNotBob 

Interesting but not a practical work around since we all run with non-admin accounts on our PC's at work.

Greetings, then you will be happy to hear that I have now verified that after installing like I described in my previous post, removing your non-admin account from local admins on the pc and rebooting will not break the WAC. It works like it is supposed to without being admin. Just required during installation.@--BF-- 

Same issue here after the last update.

Same issues here.  When I login as my admin user account it works fine but as a non admin on the WAC server (2016 Server Core) I get the permission denied error and it asks for credentials to Localhost.

@ImNotBob @Deargubel @NebulousBurrito @AndreasM1976 @--BF-- @Antonio_Filho @TinklemyFinkle  Thanks for reporting folks! The Windows Admin Center team is aware of this issue and are investigating right now! Will update this thread and Twitter (@servermgmt) as soon as we have a workaround or a new update available.

@Prasidh_Arora @ImNotBob @Deargubel @NebulousBurrito @AndreasM1976 @--BF-- @Antonio_Filho @TinklemyFinkle

 

It looks like when running with a standard user account it does not have rights to make updates to the admin center as there seems to be some extensions that need to be updated.

 

To fix this problem, open up the console from a location that you can log in with an account that either has domain admin rights or admin rights on the server that is hosting the admin center. It will then do all the updates to the extensions needed. Once done, and it has reloaded, you can then open up the console on your normal desktop and should all start working again.

@jpope3435 

 

Did as you suggested and it seems to be ok now.

 

Very odd behavior.  One would think that launching WAC with a prv account that has local admins would solve this like any other product.  

 

Thanks everyone for feedback and workaround.

Well today is a new day and after firing up WAC, I'm greeting with the same issue again.

Perhaps I'm not looking at this correctly. Having to add my non-prv account to the admin group, log in, run WAC, remove my non-prv account from admin, log out, log back might be a feature?

So far so good....
Fresh install of 2110 in windows 11 and still greeted with this message.

I'll keep using a server for this. I was just hoping to use it locally a bit more for speed gains.
Yeah, I got a new laptop at work (Win 10) and getting WAC going again was a major test of patience. If the user has local admins, not a problem. But we use our PC's with regular user rights and then have a privileged account that we use as needed. In almost all cases, when installing an app, with the prv account on our PC's, it's not a problem. Next time it runs, it prompts for the prv, I give it the prv finger and life goes on. Easy Peasy. Even trying to install it while under my prv account, it still fails initially when using this with my regular account. I again had to put my regular account into the local admin group, then launch WAC so that it could get whatever backend bits tacken care of, then remove myself from local admins. No other administrative application we use has such hoops to jump through.

Now it does work under my normal account but still need to manually log in to at least one of the systems on my WAC list with my prv account since they all try to use my non-prv account. Very much a pain since my prv account's password is quite long.

This solution is very much NOT non-admin profile friendly at all. If it would just work so that we can use Windows Hello prv account signon at launch like 95% of everything else on my laptop, this thread wouldn't exist.

Anyone know of a better alternatives than WAC?

Did anyone find a reliable fix for this in the end?

Thanks