WAC 1808 File Copy errors and powershell disconnecting...

Copper Contributor



I have few gateway "WACs" deployed in our however there is some "behind the scenes" security mechanism that prevents me from:

1. Running powershell on a remote computer (it disconnect immediately although domain permissions are ok and when I run powershell on the computer without WAC all works ok. So it is not permissions issue. That applies to all machines not particular OS of the server
2. I am not able to copy files (upload) to a remote server getting following error message: "Version:1.0 StartHTML:000000279 EndHTML:000055890 StartFragment:000055574 EndFragment:000055706 StartSelection:000055574 EndSelection:000055706 SourceURL:https://......./servermanager/connections/server/........../tools/files/path/C%253A%255C Files - Server Manager - Windows Admin Center

Failed to upload to C:\scripts\test. Error: This operation was blocked by role based access control settings or other network issue.
The user I use is a member of server admin group which is added as administrators in access section. Any ideas. tips, feedback?

10 Replies

Please check out the troubleshooting guide for common issues and resolution steps. If nothing there solves your issue, please reply back here with the answers to the troubleshooting common questions.


For the PowerShell issue, please confirm if the Events and Remote Desktop tool work, the issue you describe occurs when something is blocking websockets in your environment. 


For the file upload issue - please also include:

  • Size of the file you are trying to upload
  • Local path of the source file
  • Remote destination path 

Hi @Jeff Woolslayer


Thank you for replying. I tried to apply suggested changes. We are talking about version 1809 now (after upgrade from 1808). Initially after accessing site I was indeed getting error message websocket/powershell could not connect. I checked features on Server 2016 and added WebSocket feature. Now I am not able to connect to server even locally getting connection refused message. On the other WACs (using version 1808) I am able to both view the events and trigger RDP session. However Powershell disconnect immediately.
Any thoughts?

Thank you

As per file copying. I tried running WAC locally (server 2016 VM) and copy 3k txt file from my computer to another remote WAC server. Permissions are not an issue. All ran as admin

Error message:
Failed to upload to C:\install. Error: This operation was blocked by role based access control settings or other network issue.

There is no WebSocket feature in Windows server. Practically all WebSockets compatibility issues are caused by the network environment (proxy servers, firewalls, etc..


Please create an item for your upload issues here for ease of tracking: https://aka.ms/wacfeedback 

Hi @Jeff Woolslayer There is a feature for a WebSocket withing Web Server / Application Development however installing it made no difference. The link provided just takes me to Microsoft site. Is there any more detailed how to's regarding WAC? I see a lot of potential but practical usage is a different story. Any steps I can do for troubleshooting? Of course completely disabling firewall and "opening the shop" is out of question but is there a way to adjust more finely error handling in order to make it work?

Thanks for the clarification on the role! Unfortunately, the WebSocket Protocol role feature under IIS\Web Server\Application Development is for enabling it on IIS websites. The HTTPS listener created by WAC does not use IIS.


Since WebSocket compatibility can be impacted by any device that routes or filters network traffic in your environment, there is no definitive guide to configuring it. I can assure you that you it is possible to support WebSockets in an environment without completely disabling firewall and "opening the shop."


We have only seen WebSocket compatibility issues reported by a small subset of users, and have yet to identify any common root cause. I'm continuing to track this, and will update this location in our documentation with any new information: https://aka.ms/wacwebsockets


@Jeff Woolslayer I followed troubleshooting guide yet no solution. While in version 1808 I was able to view events on remote machine, version 1809 just throws websocket error (though configuration of the server has not been changed) I pretty much gave up on trying to run powershell from WAC as it dies before it starts and there doesn't seem to be any contstructive feedback nor solution. Any news on that front?

The PowerShell tool has the same dependency on websockets as the events tool, so it makes sense that it's not working for you either. The actual managed server configuration doesn't impact Websocket support, it's your network environment. Any device on the network that routes or filters traffic can break websockets. Firewalls, switches, VPNs, etc...


Do you still happen to have the 1808 installer? If you are able to uninstall 1809 and reinstall 1808 to verify and describe the difference experience, we can follow up.

Hi @Jeff Woolslayer


I did downgrade to version 1808. Unfortunately still get Websocket/powershell not installed or not configured message when trying to access Event Viewer, PowerShell or RDP. Any new developements?

Thank You

@Jeff Woolslayer


Here's event log entry for the error:
sessionId : 58ef4281-eb8a-453d-80ea-e5d9a0f9ddcc
eventId : Trace
level : Error
sourceName : msft.sme.event-viewer
source : appErrorHandler
timestamp : 1542105315958
message : WebSocket connection errors after retries.
stack : Error: WebSocket connection errors after retries.
    at Object.next (https://cwoper02.diehlako.local/modules/msft.sme.event-viewer/main.0cfb0e6e09cf2ed5a19a.bundle.js:1:...)
    at WebSocket.r.onclose [as __zone_symbol__ON_PROPERTYclose] (https://cwoper02.diehlako.local/modules/msft.sme.event-viewer/main.0cfb0e6e09cf2ed5a19a.bundle.js:1:...)
    at WebSocket.p (https://cwoper02.diehlako.local/modules/msft.sme.event-viewer/main.0cfb0e6e09cf2ed5a19a.bundle.js:1:...)
    at e.invokeTask (https://cwoper02.diehlako.local/modules/msft.sme.event-viewer/main.0cfb0e6e09cf2ed5a19a.bundle.js:1:...)
    at Object.onInvokeTask (https://cwoper02.diehlako.local/modules/msft.sme.event-viewer/main.0cfb0e6e09cf2ed5a19a.bundle.js:1:...)
    at e.invokeTask (https://cwoper02.diehlako.local/modules/msft.sme.event-viewer/main.0cfb0e6e09cf2ed5a19a.bundle.js:1:...)
    at t.runTask (https://cwoper02.diehlako.local/modules/msft.sme.event-viewer/main.0cfb0e6e09cf2ed5a19a.bundle.js:1:...)
    at t.invokeTask [as invoke] (https://cwoper02.diehlako.local/modules/msft.sme.event-viewer/main.0cfb0e6e09cf2ed5a19a.bundle.js:1:...)
    at h (https://cwoper02.diehlako.local/modules/msft.sme.event-viewer/main.0cfb0e6e09cf2ed5a19a.bundle.js:1:...)
    at WebSocket.f (https://cwoper02.diehlako.local/modules/msft.sme.event-viewer/main.0cfb0e6e09cf2ed5a19a.bundle.js:1:...)
moreEventData :