SOLVED

Storage Migration Service stucks at 30% - Can't unjoin domain

New Contributor

Hi,

I tried to migrate a 2012R2 fileserver to a new 2022 machine this weekend.
It wasn’t the first time I used the storage migration service, but this time it didn’t worked.

On phase 3 (cutover) it goes on 30% (“Removing the source computer from the domain...”) pretty fast, but then stucks forever.
In debug log I got the message:

[Erro] Attempt #351 failed to unjoin machine '2012R2machine.FQDN' from the domain with credential 'domain\adminuser'. Error 0x6D1.    [d:\os\src\base\dms\proxy\cutover\cutoverproxy\CutoverUtils.cs::UnjoinDomain::2216]”

I know, the message sounds like there are some problems with my credentials, but I tried different typing (without domain) and even a different account. I also tried to do this step manually, unjoined the old machine, waited for sms to notice (nothing happened) and finally rebooted the machine (now in workgroup). But still no progress (error message now changed because my domainuser couldn’t authenticate).
I rejoined the machine and tried again a dozen times (rebooted the Orchestrator service every time because there is no other abort option).

There are no information online about this error, any clue?

The windows admin center is installed and accessed on a Service-Service
The Orchestrator service (v2.6.2) is installed on the new 2022 fileserver
Windows firewall is disabled on source machine

 

Thank you for any help

 

 

5 Replies
Well, a standalone search for “0x6d1” gave me this thread https://social.technet.microsoft.com/Forums/exchange/en-US/0745e8e2-6678-45f5-bb4e-a5d5c8629d95/erro...
KB3191564 (WMF 5.1) is also installed on the source server (because of admin center connection). I guess it broke something?
PS C:\> $PSVersionTable
Name Value
---- -----
PSVersion 5.1.14409.1018
PSEdition Desktop
PSCompatibleVersions {1.0, 2.0, 3.0, 4.0...}
BuildVersion 10.0.14409.1018
CLRVersion 4.0.30319.42000
WSManStackVersion 3.0
PSRemotingProtocolVersion 2.3
SerializationVersion 1.1.0.1

How to check any further?
Hi,
have you find any solution?
Thanks
I am having the same issue trying to migrate a 2008 R2 to 2019. My question is it possible to cutover manually and be successful?
best response confirmed by RedlineMS (New Contributor)
Solution

Hello again,

after three months we finally gave it a new try.
The migration succeeded.
There was quite a few maintanance things we did, I will tell you the most likely reasons:

-since March a new admin center version and SMS version released
-Also new windows updates was released which were installed on all relevant servers
-We checked the eventlog on the source server for any errors and fixed them
-> NTP, shares, ....
-we also did a winsock reset:

Reset Winsock control.

Restoring transaction logs.
fsutil resource setautoreset true C:\

Restoring TPC/IP.
netsh int ip reset

Restoring Winsock.
netsh winsock reset

Restoring default policy settings.
netsh advfirewall reset

Restoring the DNS cache.
ipconfig /flushdns

Restoring the Proxy.
netsh winhttp reset proxy

Some of these may be the solution!

 

I had to do an in place upgrade from 2008 to 2012R2 before I could get the cutover to work.
Clone VM, snapshot, upgrade then cutover.