Cannot add extension to Windows Admin Center on offline network

New Contributor

We installed Windows Admin Center 1904.1. I am trying to add a nupkg extension using as a reference. I've tried adding every combination of file share path I can think of on the Feeds tab, including \\DFS namespace\share\folder, \\hostname\share\folder\ , \\hostname\share\folder\name.nupkg, etc. Unfortunately the Available extensions tab just says "No records found." Can anyone provide an example path that worked to add extensions on an offline network?

4 Replies
best response confirmed by Loc750 (New Contributor)
I've used a local path on the server running Windows Admin Center to install extensions.
Have you downloaded the extension nupkg files to the location? Does the share have the correct permissions set?
Using a local path instead of a file share worked.

@Loc750  -- I too am failing to install Windows Admin Center extensions in an offline mode. I've success fully copied all the .nupkg files to the "C:\temp" directory on the WAC server itself.

I've successfully registered the feed "C:\temp" and the .nupkg files do indeed show up in the "Available extensions" area.

However -- when you click "Install" it fails with:



Couldn't install the extension: 'Active Directory'. Error: Failed to install package Error: Unable to connect to the remote server


I've tried making the "C:\temp" directory have "Everyone" = "Full" NTFS permissions. No change.

I've tried accessing the WAC console with FQDN/shortname/localhost and in the URL field. Same error.

Tried rebooting the WAC server after registering the new "C:\temp" feed. Same error.

The puzzling piece is "unable to connect to the remote server" which doesn't make sense as it is connecting to itself.




@pbergergeoblue We run the WAC service as Network Service. I made sure both the admin group that login to WAC and Network Service have at least read and execute NTFS permissions to the local path. We access the WAC console via the FQDN. I just upgraded to the AD 0.86.0 extension without any issues using a local path similar to your C:\temp. So unfortunately, I don't have any suggestions beyond double checking that are no Deny NTFS permissions and also checking your Security Event Logs just in case there is something there about the failed connection.