User Profile
Arjun_Rajan
Copper Contributor
Joined Jun 25, 2020
User Widgets
Recent Discussions
Re: Custom Detection rule to find Inactive Device
Princely Much appreciated your response to my query. Unfortunately, It does not return any result even if I choose the last 30 days. Please let me know if you happen to know how to set the Time range in the query. However, I do get all inactive devices by running the below query DeviceTvmSecureConfigurationAssessment | where ConfigurationId in ("scid-91", "scid-2000", "scid-2001") | summarize arg_max(Timestamp, IsCompliant, IsApplicable) by DeviceId, ConfigurationId | extend Test = case( ConfigurationId == "scid-2000", "SensorEnabled", "N/A"), Result = case(IsApplicable == 0, "N/A", IsCompliant == 1, "GOOD", "BAD") | extend packed = pack(Test, Result) | summarize Tests = make_bag(packed) by DeviceId | evaluate bag_unpack(Tests)3.9KViews0likes4Comments
Recent Blog Articles
No content to show