VMM Support Tip: Adding hosts fails with Error 2927
Published Feb 15 2019 04:50 PM 2,808 Views
First published on TECHNET on Dec 13, 2012

Alvin Morales here again, and today I wanted to talk briefly about an issue that I ran across in System Center 2012 Virtual Machine Manager (VMM 2012) Service Pack 1 but is probably applicable to non-SP1 (RTM) VMM 2012 as well.

The issue you can run into is that when adding hosts, the process starts but fails at 66% and returns an error similar to the following:

Error (2927)
A Hardware Management error has occurred trying to contact server "servername.domain" :n:CannotProcessFilter :HRESULT 0x8033801a:No instance found with given property values. .

WinRM: URL: [http://"servername.domain":5985], Verb: [INVOKE], Method: [AddPeerCertificate], Resource: [http://schemas.microsoft.com/wbem/wsman/1/wmi/root/scvmm/AgentManagement]

Unknown error (0x8033801a)

Recommended Action
Check that WinRM is installed and running on server "servername.domain". For more information use the command "winrm helpmsg hresult".

This can occur if the Virtual Machine Manager agent is not started. When the process tries to sync up certificates, it fails and thus fails the job. In a trace you will likely also see errors such as this:

FAILED. The WS-Management service cannot process the request. The WMI service or the WMI provider returned an unknown error. HRESULT 0x8004100e

A Hardware Management error has occurred trying to contact server "servername.domain" :n:CannotProcessFilter :HRESULT 0x8033801a:No instance found with given property values. .

WinRM: URL: [http://"servername.domain":5985], Verb: [INVOKE], Method: [AddPeerCertificate], Resource: [http://schemas.microsoft.com/wbem/wsman/1/wmi/root/scvmm/AgentManagement]

Fortunately the resolution is an easy one - start the System Center Virtual Machine Manager agent.  Now as a side note, you may find that the System Center Virtual Machine Manager agent isn’t running for a reason (e.g. the service is failing). If that’s the case then of course you’ll need to troubleshoot the cause of that so that the service will start successfully. When I ran into this, the service was failing due to performance counter corruption and restarting the WMI service or using winmgmt /salvage repository fixed the issue, although as they say, your mileage may vary.

Alvin Morales | Senior Support Escalation Engineer | Management and Security Division

Get the latest System Center news on Facebook and Twitter :

System Center All Up: http://blogs.technet.com/b/systemcenter/
System Center – Configuration Manager Support Team blog: http://blogs.technet.com/configurationmgr/
System Center – Data Protection Manager Team blog: http://blogs.technet.com/dpm/
System Center – Orchestrator Support Team blog: http://blogs.technet.com/b/orchestrator/
System Center – Operations Manager Team blog: http://blogs.technet.com/momteam/
System Center – Service Manager Team blog: http://blogs.technet.com/b/servicemanager
System Center – Virtual Machine Manager Team blog: http://blogs.technet.com/scvmm

Windows Intune: http://blogs.technet.com/b/windowsintune/
WSUS Support Team blog: http://blogs.technet.com/sus/
The AD RMS blog: http://blogs.technet.com/b/rmssupp/

App-V Team blog: http://blogs.technet.com/appv/
MED-V Team blog: http://blogs.technet.com/medv/
Server App-V Team blog: http://blogs.technet.com/b/serverappv

The Forefront Endpoint Protection blog : http://blogs.technet.com/b/clientsecurity/
The Forefront Identity Manager blog : http://blogs.msdn.com/b/ms-identity-support/
The Forefront TMG blog: http://blogs.technet.com/b/isablog/
The Forefront UAG blog: http://blogs.technet.com/b/edgeaccessblog/

Version history
Last update:
‎Mar 11 2019 09:45 AM
Updated by: