Announcement: Update to Linux/Unix Support Matrix with SCOM
Published Dec 01 2021 04:13 AM 4,058 Views
Microsoft

A lot is going on currently in the SCOM world. Various versions are hitting lifecycle milestones and undergoing support changes. SCOM 2022 is about to be released, SCOM 2019 UR3 is about an year old, SCOM 2016 is about to enter extended support, and SCOM 2012 is nearing end of support. Each of the versions have a different set of supported Linux/Unix OS versions.

 

In parallel, the Linux/Unix OS versions are independently going through their lifecycle. Multiple Linux/Unix versions have recently hit or about to be end-of-life. All of this means your environments are going through upgrades and you are planning SCOM & server upgrades in tandem. We understand that could be tricky and are here to give some help. 

 

Effective immediately, we are updating our approach towards supported Linux/Unix versions with SCOM. Directionally, following are the two changes - 

  • Support for new LINUX versions shall be added to SCOM 2019 & beyond within 2 months of the OS release.
  • Support for Linux/Unix versions as soon as they get to end-of-life (the vendor drops support for them) will be dropped from SCOM

That means - 

  • Debian 11 is now supported with SCOM 2019, despite it having released in August/September. No more waiting for the next UR or SCOM release for support of the new versions. 
  • Debian has ended support for Debian 8 in June 2020, Debian 9 is going to be end of life in 7 months. That means these versions would now accumulate known issues from security and reliability perspective, making your environments vulnerable and difficult to maintain. It is highly recommended for you to upgrade from these end-of-life OS versions. For us as well, it gets harder to maintain support for these versions as we build SCOM feature updates. To make it easier for both of us and give you one lever to look at, we are going to sync support in SCOM with the OS version lifecycle. Support for Debian 8 (and all other end of life Linux/Unix OS versions) would be discontinued from SCOM 2016 and SCOM 2019. We shall continue to apply the same principle and update the support matrix for SCOM 2019 & 2022 onwards. This does not mean monitoring would break for these versions immediately. Your existing setups shall continue to be functional. However, SCOM updates might impact that state. 

In summary,

  • For SCOM 2016, we are going to drop support for RHEL 5, CentOS 6, and Debian 8. Here is the latest support matrix.
  • For SCOM 2019, we are going to drop support for CentOS 6, CentOS 8, and Debian 8. And from UR3 onwards, support for Debian 11 has be added. Here is the latest support matrix.
2 Comments
Co-Authors
Version history
Last update:
‎Dec 01 2021 04:13 AM
Updated by: