SQL Server 2019 Upgrade from Developer to Standard license failed

Copper Contributor

I am attempting to upgrade an installed SQL Server 2019 developer addition to a purchased standard addition with a new key.  I am using the Maintenace Edition Upgrade tool, and all appears to work when executed.  However, the edition does not get changed to Standard.  There are no compatibility issues reported in the log and show it competed successfully.  Please advise if this is a known issue.


Note:  This is running on a VM with Windows Server 2019 and does not have Internet access.


Summary shows addition change with some other updates.



Result only shows 2 feature updates when completed.  No errors reported.



SQL Edition did not get changed.




6 Replies

Have you check the logs. What about logs in bootstrap.
Restarted the server / SQL Server and tried?

By the screenshot it seems you selected only "Shared Component" to upgrade, but not the installed SQL Server instance. Rerun the upgrade and select the instance.
The log file created when the upgrade is completed is all green. I have not checked the system logs, but will take a look.
I included the SQL Server instance and was listed in the summary before I ran the update. I have tried it a few times and rebooted after each. It is either a bug with the upgrade routine or you need Internet access for it to verify the license key. Not sure because there are no error messages of any kind.
The screenshot shows build 15.0.1600.8, that's a CTP = Community Technology Preview, a beta version.
Edition or any other upgrades are not supported for a CTP.
See https://sqlserverbuilds.blogspot.com/
Uninstall everything and reinstall SQL Server with your product key.
I was afraid you would say that. This install has been a bit flaky / buggy. This was my next course of action anyway. Thanks for confirming it.