SOLVED

Data Loss Prevention - Client Error

Occasional Contributor
Can anyone please help me with this kind of error in DLP.. I can't edit the policy settings and I also tried to do this in 3 different tenant. Same result, is this a bug? Please see error below. Thank You in advance.

 

Client Error

 

Your request couldn't be completed. Please try again, and if the problem persists, contact your administrator.

Request: /api/policy?policyType=Dlp
Status code: 500
Exception message: {"Message":"The DlpComplianceManagementRule type entity does not have the following type command: Update.\r\nParameter name: entityMetadata","DiagnosticContext":"{Version:16.00.2927.001,Environment:EASPROD,DeploymentId:3c31d0adf8964fe5bc51a71de288012e,InstanceId:WebRole_IN_3,SID:83a1fd6e-6cef-45ca-87c3-a7cc8ed8a811,CID:485d36c9-0688-4fa1-8d68-400e7d127b36}","Time":"2019-03-21T05:22:03.304024Z","ExceptionType":"System.ArgumentException"}
Diagnostic information: **{Version:16.00.2927.001,Environment:EASPROD,DeploymentId:3c31d0adf8964fe5bc51a71de288012e,InstanceId:WebRole_IN_0,SID:83a1fd6e-6cef-45ca-87c3-a7cc8ed8a811,CID:41deba65-b463-46cf-b986-8aea7b3d042c}
Time: 2019-03-21T05:22:01.641Z

 
 
 

 

6 Replies

If you can reliably reproduce the issue, open a support case so it gets properly investigated and fixed. In the meantime, you can try making the change via PowerShell as a workaround.

@Vasil Michevsorry.. can you please share the link where I can properly share the concern? Thank You

I'm moving this conversation to the Security, Privacy & Compliance space which I believe is a better fit for this content.

best response confirmed by Deleted
Solution

I am having exactly the same error when trying to edit an existing DLP policy.  I tried both IE11 and Chrome with the same result.  Sometimes (but not always), if I refresh the screen, the change I made before clicking save will actually have been made.

 

Note to Microsoft:  STOP trying to invent new navigation and edit widgets in admin tools.  I haven't got time to be your lab rat - I have real work to do and I just need the admin tools to work!!

The correct place to report this is via a support ticket, or by using the Feedback functionality in the SCC. And in the meantime use PowerShell instead to make the changes to the policy.

@JeffV I'm getting the same thing in trying to create a new (first) DLP policy in our system. I'm wondering if it's a licensing issue..