SOLVED

Teams Screen Sharing Disabled

Occasional Contributor


We are having multiple users reporting that they are not able to do Screen Sharing when they initiate the call the button is greyed out and says "Screensharing is disabled".

 

Scenarios where it works:

If Someone else initiates the call then the user who had issues in this case the receiver of the call, can share screen.

They can initiate a screen share then unmute, works.

 

Device OS: Windows 10 20H2 Enterprise

Seems to be random but started between Friday and today..

 

31 Replies

I am having this same problem exactly as you describe. It started Friday morning and is still ongoing. 

 

Multiple users were only able to share their screen through the Teams Web app, OR if I called them first. When the users made the call they were unable to share, but when I made the call they could share. I assumed that if anyone called them first that they would be able to share.
 
None of the below resolved the issue. 
  • Cleared cache
  • Checked settings & compared to my own
  • Checked that the O365 license was valid
  • Restarted app
  • Restarted PC
  • Installed Visual C++ 2015-2022
  • Rolled back video drivers
  • Updated Windows
  • Updated Teams app
  • Changed resolution lower... (I went from 1920x1080 to 1280x720)
  • Disabled/enabled GPU acceleration
  • Checked security settings
  • Re-installed the teams app

@vRickEBK I don't see a service health message from Microsoft reporting this issue but its worth checking by opening a case with Microsoft support team if you guys are paying for a premium service. have them collect the logs and analyze it for you.

 

Also, can you please provide more details about this working scenario "They can initiate a screen share then unmute, works." I thought you mentioned the screen share button is greyed out for them or that's not always the case ? are they guest users or using an account with a domain different than yours ? how about your meeting policies under the Teams admin center, do you have access to check them out and see if there are custom meeting policies that disable "screen sharing mode" for specific users. if you don't have this level of access, you need to check with your Teams administrator and have them go through the meeting policies in your tenant.

its possible when the "screen sharing mode" is disabled via custom meeting policy for a specific users in your tenant those same users will be able to share their screen if the invite came from a different tenant and they were joining as guests simply because that tenant doesn't have restrictions on screen sharing.

@vRickEB I was facing this also yesterday. Today it just start to working again! 

 

I was on ubuntu 22.04.... I also tried a lot of workarounds but nothing solved it.

 

I get it working yesterday using the web version in chrome and also the Teams for linux https://github.com/IsmaelMartinez/teams-for-linux (unofficial).

same here.. whole company 150 ppl has the same issue since last week, web version works fine, on desktop version caller cant share screen.

-_-

And currently (06-07-2022) again the problem occurring.

Hello All,
What devices are having the issues (VM/VDI, Laptop, Desktop), OS?
What installer are you using on your endpoints?
Same issue here with Teams 1.5.00.10453 (Ubuntu). Was working fine earlier this morning, but "Screen sharing is disabled is now showing up on all outbound calls I make."
I got exactly the same issue. I'm on Ubuntu 22.04, with Xorg desk environment.
Teams Version: 1.5.00.10453

As previous description:
If someone else initiates the call then I received, I can share screen.
If join in the meeting from calendar, I can share screen.
If I initiate the call, the screen share button show greyed out and says "Screensharing is disabled".

But the "umute" workaround doesn't work from me.
Ubuntu 22.04 in X11 on Dell Laptop. Using Teams Insiders version 1.5.00.10453 installed from ubuntu software store.
Same problem here with Ubuntu 20.04. Noticed this by today.
No Wayland. Just Xorg ...

Version 1.5.00.10453 (64-bit).

"Screensharing is disabled" for outbound calls.
Works for inbound calls.

@vRickEBK We are experiencing the exact same issue too. We are on a Windows environment and using the desktop app.   It doesn't appear to be any rhyme or reason when screen share is greyed out during a call and get the message "Screensharing is disabled".  So far it's only affecting some users in the office.  

 

We tried the steps mentioned earlier to see if that resolves it, but didn't work.

 

I'm certain it's a global issue with Microsoft that they haven't posted yet on their site.

We've also been experiencing this issue over the past several days. It is very intermittent.

I'm also experiencing the same issue. Teams screen sharing is disabled.

First I thought it is related to my Ubuntu upgrade from 20.04 to 22.04.

Because with newer Ubuntu versions the default display server is now Wayland and no longer X11/X.org.

But I tried some solutions I found in some articles on the web, but nothing helped.

Afterwards I found this report here where also Windows user are affected.

 

What I already tried:

1.) Disable Wayland safe mode:
global.context.unsafe_mode=true

 

2.) Disable Wayland completely with below configuration:
vi /etc/gdm3/custom.conf
WaylandEnable=false

 

3.) Or only start a desktop session directly with X11/X.org without disabling Wayland completely

 

4.) Instead of using Teams as a Debian package (*.deb), I also tried the Snap package, but this also did not help.

Same issue here on a Ubuntu 20.04.4 LTS.
After downgrade to teams 1.4.00.26453 using "sudo apt install teams=1.4.00.26453" I can now share the screen again in one2one calls I initated
Same here, no screen-sharing for outgoing calls.

I am using:
* Ubuntu 22.04LTS
* Using Xorg (Wayland disabled)
* On Dell Latitude 7420
* Teams Insider 1.5.00.10453

I tried to switch back to Wayland but its even worse.
+1 but the issue seems to be limited to outgoing calls towards a single endpoint ... as soon as I add a second enpoint the sharing option gets enabled and is working.

Using Teams 1.5.00.10453 on Fedora 36.

I had this same issue with a few users in our corporation.

I was able to see that the user could ONLY screen share during an incoming call or just by screen sharing directly instead. I checked to see if I could sign them into my Teams app installed on my laptop and the issue was no longer present. I also checked the web version of Teams and the issue was not present either. Below was the following issue on their own laptop and their install of Teams:

zgmartinez_0-1654715672598.png

After trying to delete cache, edit the registry, uninstall/reinstall the Teams program, reboot the machine, etc. I was able to do the following to get it working which didn't make sense since the cache was being physically deleted in the AppData folder:

 

1. I signed the user out of Microsoft Teams and signed into my account. The issue was removed.

2. I signed back into the user's account and the issue was no longer present.

3. With another user I just signed them out and back in and the issue was removed.

During the 2nd step, I did receive the following message after trying to sign them back in:

zgmartinez_0-1654715180616.png

When clicking on "try again" the program closed out and reopened. The user was able to screen share after that with no issues when initiating the call.

 

@vRickEBK 

best response confirmed by Therese_Solimeno (Moderator)
Solution
I tried signing out and back in and it worked... will do this for more employees and update if it worked for them too.
Glad it worked! I was more than stunned about the fix for this. Super easy... yet NOT the first step I would of taken as a tech.