Microsoft Stream Recording - No Audio when microphone enabled in browser

Copper Contributor

I have been creating a few videos of screen recordings (with audio, no web cam) to add to our teams work instructions file. I have been able to record with audio with no problems in the past. However the last few days it disables my microphone as soon as I connect it. I have checked my preferences to ensure the Stream webpage allows my microphone yet it still disables it. How do I fix this?

6 Replies

I am facing the same issue today - very frustrating and I tried in Chrome and IE and with two separate input devices (ie Microphones) so its almost certainly a bug with MS Stream



Same problem for me. Tried Edge browser and chrome incognito but with no success. In the browser the microphone is "allowed" but stream anyways displays error message instructing me to "click on the lock icon and set microphone to allowed and reload browser". 

@bob_sacamanoyes, thats the exact same thing I see.  As a temp workaround, I tried to record my screen from Teams and that worked.  Basically had to start a meeting with no other invitees.

I have the same issue. Mic works fine on other sites. Site settings for Stream show that the mic has permission however I get the following message when I try to switch the mic on:


Stream needs permission to record video and audio. Click the lock icon in your browser's address bar, make sure to allow camera and microphone, then refresh this page to continue.


Refreshing does not help. Definitely seems like a bug in Stream. I am using the 'Record your Screen' mode.

OK I think I may have figured out a workaround:


The record screen option requires camera permissions before it will work. I was able to plug in a spare webcam, enable the camera permissions, refresh the page, disable my camera and then switch to my non-camera mic. Recording then worked fine.


I have submitted a bug report via Stream with a link to this thread.

Here too. Using wireless headset (PowerBeats). Microphone is working with Skype and Teams but not here in Microsoft Stream specifically. I've checked all security settings (all that I can drill down to) and nothing works.


I was using the same setup just fine a few weeks ago.  This is a recent bug.  Sadly, the device I'm trying to record screen on is older and we have no camera to plug in per samccs' suggested workaround.