SOLVED

Cross tenant synchronisation not successfull

Occasional Contributor

Hi there,

 

today I tried a cross-tenant synchronization between two tenants.

 

I did the steps mentioned in the microsoft manual:

https://learn.microsoft.com/en-us/azure/active-directory/multi-tenant-organizations/cross-tenant-syn...

 

  • Enabled user sync in the target tenant
    (organization added, allowed user sync under cross-tenant sync in the inbound settings)
  • Configured automatically reedem invitations in the target tenant
  • Configured automatically reedem invitations in the source tenant
  • Configured the cross tenant configuration in the source tenant
    (done the connection-test in the automatic provisioning mode)
  • Definded the scope (assigned users and groups)
  • No additional scoping filters set
  • Did the attribute configuration (showInAddressList --> Constant; True and userType = Member)

Now I´m in step 11: testing

 

I´ve got an error in "4. Perform action"

theunknown_0-1680100040621.png

The details:

theunknown_0-1680165329325.png

 

I can not figure out what the problem is :(

 

Hope that anyone can help me. Thanks in advance :)

 

 

6 Replies

@theunknown hi please check your inbound settings of the organization you add from the source tenant. make sure that you allow the users and applications in case your default settings is to block 

also, double check if you enabled the cross tenant sync option.

eliekarkafy_0-1680166769577.png

 

 

 

@eliekarkafy 

 

Here the screenshots of my In- and Outbound settings ;)

 

TARGET TENANT: Inbound access settings

theunknown_5-1680168354848.png

theunknown_6-1680168375448.png

theunknown_7-1680168395633.pngtheunknown_8-1680168436942.png

 

TARGET TENANT: Outbound access settings

theunknown_9-1680168522810.png

theunknown_10-1680168548166.png

theunknown_11-1680168570679.png

 

 

 

 

Applications are also allowed.
best response confirmed by theunknown (Occasional Contributor)
Solution

@theunknown hi , thanks for the below, can you please check the settings of your external collaboration settings on the target tenant and source tenant 

 

eliekarkafy_0-1680169054868.png

 

@theunknown  can you please share if this solve your issue to help the community finding their answers with the same issue 

If edited the "Collaboration restrictions" in the "External collaboration settings" like you mentioned in your post. Change it from "Deny invitations to the specific domains" to "Allow invitations to be send to any domain".

 

--> Now it works :)

 

Microsoft did not mentioned this setting in the guide:
https://learn.microsoft.com/en-us/azure/active-directory/multi-tenant-organizations/cross-tenant-syn...

 

Thx @eliekarkafy  for your help :)