Azure Active Directory Connect - error with AuthorizationManager check failed

Occasional Contributor

When configuring AAD Connect I get to the 'connect directories' stage, and it auto discovers my local AD/forest name, but when I click Add Directory, I enter the domain administrators credentials and get the message back saying:


"An error occured while auto creating an account in the forest <forestname>. AuthorizationManager check failed."


Here is the error trace:

[ERROR] Caught exception while creating synchronization account.
Exception Data (Raw): System.Management.Automation.CmdletInvocationException: AuthorizationManager check failed. ---> System.Management.Automation.PSSecurityException: AuthorizationManager check failed. ---> System.Management.Automation.Host.HostException: A command that prompts the user failed because the host program or the command type does not support user interaction. The host was attempting to request confirmation with the following message: File C:\Program Files\Microsoft Azure Active Directory Connect\AdSyncConfig\AdSyncConfig.psm1 is published by CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US and is not trusted on your system. Only run scripts from trusted publishers.
   at System.Management.Automation.Internal.Host.InternalHostUserInterface.ThrowPromptNotInteractive(String promptMessage)
   at System.Management.Automation.Internal.Host.InternalHostUserInterface.PromptForChoice(String caption, String message, Collection`1 choices, Int32 defaultChoice)
   at Microsoft.PowerShell.PSAuthorizationManager.AuthenticodePrompt(String path, Signature signature, PSHost host)
   at Microsoft.PowerShell.PSAuthorizationManager.SetPolicyFromAuthenticodePrompt(String path, PSHost host, Exception& reason, Signature signature)
   at Microsoft.PowerShell.PSAuthorizationManager.CheckPolicy(ExternalScriptInfo script, PSHost host, Exception& reason)
   at Microsoft.PowerShell.PSAuthorizationManager.ShouldRun(CommandInfo commandInfo, CommandOrigin origin, PSHost host, Exception& reason)
   at System.Management.Automation.AuthorizationManager.ShouldRunInternal(CommandInfo commandInfo, CommandOrigin origin, PSHost host)


I'm not sure where else to look, as I'm using the current logged in user domain admin account on the same VM which has AD/DNS installed etc, so permissions shouldn't be an issue

1 Reply
best response confirmed by Kevyn Williams (Occasional Contributor)

I've solved this by manually installing the Microsoft certificate:


  1. Locate C:\Program Files\Microsoft Azure Active Directory Connect\AdSyncConfig\AdSyncConfig.psm1
  2. Right click the file, and open properties
  3. Go to 'Digital Signatures' tab and open the details for the certificate
  4. Click View certificate
  5. Click Install certificate
  6. I ran this twice, for both current user and local machine
  7. Manually choose the following store to place certificates: 'Trusted publishers'
  8. Re-run AAD Connect


I hope this helps someone else