MX Record invalid format

New Contributor

I have a domain through Google and work email through Microsoft. When I try to add the MX Record from Microsoft to Google, I get the error message "Invalid Format". I don't know what other way to get around this in order to start receiving emails. Can someone please help me with this issue?

11 Replies

@Aksmith14 

I'm having the same issue. 

@Aksmith14 I'm receiving the same error; please advise.

I found a fix that worked for me...I put the number "1" before the domain name and it was accepted.

I think this issue is largely created by the common mistake in which the Priority value on the Microsoft Domain page is ignored when entering a value into the Data field on the Google Domain page.

 

When you enter the info into the Data field of the Google Domain page for the MX record, it's actually a combination of two separate fields from the Microsoft Domain setup page called Priority and Points to address or value.

 

So, for example, if the MX record in Microsoft Domain setup page state the Priority value is "0" and the Points to address or value field shows the value of "xxxx.com.mail.outlook.com." then when completing the "data" field on the Google Domain page for the MX record, it should read "0 xxx.com.mail.outlook.com."

 

 

@TKO_888 I did this and it appears to work somewhat better than before.  However, I'm now receiving 'invalid entry'.  Any other recommendations?

@SLE2022 Not sure, if you want to screenshot the fields on your domain page and then what you entered into Microsoft field that is prompting the error, maybe we can see something to help?

@TKO_888 nevermind, I had a typo in the value!  It works now with your recommendation.  Appreciate your answer, I was on with MS and they didn't know this either!

@SLE2022 That's excellent! Thank you for closing the loop =)

@TKO_888 , Hi we are facing the same issue after adding MX records it is showing clearly in the MXtoolbox Lookup when it comes to the office 365 admin panel it shows an invalid entry.

i have provided like priority 40  xxx-in.mail.protection.outlook.com. third party vendor MX records 10 123-in.mail.protection.outlook.com 20 456-in.mail.protection.outlook.com. pls suggest do you have any solution

For anyone else who comes across this issue, it looks like google is expecting a period at the end of the address (see here for more info: https://support.google.com/a/answer/9222085?product_name=UnuFlow&hl=en&visit_id=637995379456910280-6...)

Worked for me.
none of these seem to be working for me.