Cannot delete sharepoint after I delete a group

Frequent Contributor

I deleted a test group but the sharepoint site did not delete and I don't see in in the sharepoint admin center. It is hidden from my view. I tried deleting the site from within the site itself (settings menu --> site settings) but doing that just brings me back to the documents folder Smiley Mad

12 Replies
The Group site should be deleted when the Group is deleted...if that's not the case, to avoid the redirection, append to the Url ?noredirect=true

You can try using PowerShell to delete the site collection, here are the scripts.  A SharePoint site collection created by an Office 365 group currently will not show up in the SharePoint Online admin center. 

that site with the powershell scripts no longer exists.


I have the same problem described above.  I deleted some groups but their sites still remain.  I tried to go in and delete the sistes from sharepoint admin but there is not option to delete them.

Are you talking about deleting a Group SPO Site ?  (a SPO Site which was created via an O365 Group)


I had (or still have) exactly the same case where a SPO Site remain available after i deleted the O365 Group.

In order to delete a SPO, you need to add an globald admin account as an owner to the site


Set-SPOSite -Identity https://<name>/sites/<sitename> -owner <your global admin account>


afterwards trigger the removal by issuing this cmdlet

Remove-SPOSite -Identity https://<name>/sites/<sitename> -NoWait



i had the issue that i couldn't add an owner to ANY Group SPO's. So i had to open a MS support ticket for that :(


hope that helps

I also had the same problem. Deleted some Office 365 Groups, but the SharePoint sites were not deleted.


Trying to add my own global admin account as an owner using


Set-SPOSite -Identity https://<name>/sites/<sitename> -owner <your global admin account>


did not work.  The site was "not cuurently available" according the Powershell error message.


Apperently the site was locked. Unlocking the site using


Set-SPOSite -Identity https://<name>/sites/<sitename> -LockState Unlock


made it possible the add the global admin account. After adding the global admin account there was no problem deleting the SharePoint site.


I hope this works for everybody.

I did all these steps and it seems that it works.

The thing is that when I try to create a group with the same name, the "site name" is like "sitename2"

I want to use the name without the 2 at the end.

Any help?


If the suggestions described here don't work, I would recommend to use the cmdlets you can find in the preview of the PowerShell Module for Azure AD to completely remove the Group. I had to use them for a customer site group that was not deleted after deleting the Group...specifically follow this support article:
Many thanks Juan Carlos, it works!!!
You save my day.
Gracias de nuevo.
My pleasure Alvaro!

Great guys, thank you for your help here. Any clue about other leftovers ? Exchange, Teams...




AFAIK, No...the only once causing problems when deleting a Group seems to be SPO