Exchange CXP team has released Update Rollup 4 for Exchange Server 2010 RTM (KB 982639) to the download center.

KB 982639 lists all the fixes included in this rollup. Here are some of the product improvements and critical bug fixes we'd like to call out starting with 5 improvements we made to prevent crashes in very unique scenarios.

  • KB 980852 The RpcClientAccess process on an Exchange Server 2010 server crashes when you access a mailbox by using a MAPI application
  • KB 979801 An error message is generated in Exchange Server 2010 when you use Exchange Troubleshooting Assistant
  • KB 980364 The Exchange Transport service on an Exchange Server 2010 server crashes when a certain message is processed
  • KB 980353 A MAPI application that is used to access Exchange Server 2010 mailboxes crashes when the application accesses an address book
  • KB 979790 An IMAP4 client crashes when accessing an Exchange Server 2010 mailbox

We corrected a few replication issues some of you encountered.

  • KB 980149 The Add-MailboxDatabaseCopy command fails when it is used to add a database copy to a Database Availability Group in an Exchange Server 2010 environment
  • KB 981961 Event ID 4033 is logged and the Free/Busy replication from an Exchange Server 2003 server to an Exchange Server 2010 server fails
  • KB 979921 You cannot replicate a public folder from one Microsoft Exchange Server 2010 server to another, and Event ID 3079 is logged on the target server

One unique thing added was an ability for an administrator to adjust filtering of XML attachments so an OWA user can save them. Some customers were facing a compliance versus level of security tradeoff. See more about configuring this option in KB 983200, which discusses adding administrator control over attachment stripping. We also included at least eight other fixes that some of you requested in this release which we already had worked on for a service pack but are able to deliver to you sooner.

KB 982639 has more details about this release and a complete list of all fixes included in this worthwhile rollup.

Forefront users:

For those of you running Forefront, be sure you perform these important steps from the command line in the Forefront directory before and after this rollup's installation process.  Without these steps, Exchange services for Information Store and Transport will not start back up.  You will need to disable ForeFront via "fscutility /disable" before installing the patch and then re-enable after the patch by running "fscutility /enable" to start it up again post installation. 

Questions / discussions of the Update Rollup and issues

Please go to our Update forum: http://social.technet.microsoft.com/Forums/en/exchangesoftwareupdate

GPO Execution Policy Issue

If you use a GPO to define the Windows PowerShell execution policy, you probably had problems installing previous RUs. We have addressed this problem in this Update.

Availability on Microsoft Update:

We plan to release this update on Microsoft Update in about 2 weeks.

- Exchange SE Team

Not applicable
I'm getting error code 1603 on installation, any ideas?
Not applicable
Odd, I ran the installation with a "/lvx .update.log" switch to try and see what was happening and it finished successfully.  Hope this helps anyone else having the issue.
Not applicable
First time through this failed - I started the Exchange RPC service and then it went through fine.
Not applicable
It's worth noting that this update rollup is for Exchange Server 2010 RTM.  Do not install it on the Exchange 2010 SP1 beta.
Not applicable
Getting error:1603 also.. baaaaad update.
Not applicable
I imagine Update Rollup 3 (or 2 and 1) qualifies as an “Interim Update” that has to be uninstalled before applying 4.
Not applicable
Update rollups are not "interim updates".
Interim updates are hotfixes issued after a update rollup.
Not applicable
I'm also getting error code 1603 on installation?
Not applicable
I'm getting "error code 2771" on installation, any ideas maybe?
Not applicable
For specific issues and support, please go to http://social.technet.microsoft.com/Forums/en/exchangesoftwareupdate.
Not applicable
1603 and other errors:
Select “Command Prompt”, right click and choose “Run as administrator”.
Navigate to the directory were your rollup file is and execute.
This is the only way I could this rollup and others to complete without errors.
Not applicable
I have installed this update on a back end and front end server....no errors reported during install, but both servers when you click the "about" in the managment tool shows:

Where as the server list under "Server Configuration" shows the versions as been build 639.21

Even Windows Update wants to update both "RU4" servers to RU3!!!!
Not applicable
From Server 2008 R2, I had to follow Larry's suggestion and launch the MSP from an elevated Administrator CMD shell.  Neither Running the updater normally nor running it as Administrator worked.

When creating the .NET assemblies, it really did take a very long time (nearly 5 minutes), just like the installer said.

After running the installer, I forced a check for updates, but did not see the problem that Stephen found.
Not applicable
fails to install, and breaks outlook web access. useless
Not applicable
Failed with 1603 for me too, also failed from command prompt with elevated permissions. The second time around, I manually stopped the Exchange System Attendant service first, then kicked it off from the command line as Administrator and it installed successfully
Not applicable
Yeah same for me, I've tried installing Update Rollup 4 and get the same error in the event viewer: 1024 (error code 1603). I tried the idea of starting the command prompt run as administrator but I still get the same error and have to reboot the server to get the Exchange services to start up again!

Big waste of time - someone should have tested this first!
Not applicable
Agreed - installed and received error 1603.  Tried to uninstall - that wouldn't work and asked for EXCHANGESERVER.MSI from UR3.msi. No luck, so cancelled the uninstall, which left all Exchange services disabled.  Managed to get UR4 on (I think) by using CMD prompt elevated perms, but OWA is STILL broken.  So my Exchange 2010 is in a mess - thank you so much microsoft... Exch 2010 is a real regret - avoid at all costs folks, this is not a production-ready release.
Not applicable
Re-install Powershell. WINRM KB968930-x64 then re-install. You can see that Powershell will not open before the fix.

or follow:

Not applicable
Stay away from this if you want your exchange enviroment to still be running. I had rollup 3 and everything worked fine, went to 4 and it has been a mess since. OWA is completely broken and outlook won't connect to exchange.

And do not cancel the uninstall of the rollup it disables all exchange services which you then have to set all back to automatic and start again.
Not applicable
I was getting 1603 errors,

I removed the HKLMsoftwarePoliciesMicrosoftpowershell key

ran the fscutility /disable

and then it all installed correctly

Not applicable
i think the logic for ForeFront should be added..
for mbx roles:

net stop FSCController
net stop MSExchangeIS
fscutility /disable

for hub:
Net Stop MSExchangeTransport
Net Stop FSCController
fscutility /disable

when rollup finish installing , just run net start and the fscutility /enable

IMHO, Batch files for installing updates looks bad, especially when I recommend forefront protection...
Not applicable
Oh boy, wish I'd seen this before I installed today from my internal WSUS server... The update failed to deploy, and on reboot, all of the Exchange (and several other) services are disable!

Restoring last nights backup... :|
Not applicable

Why restore, you just had to enabel services again and Exchange would work as it should. The Update disabled all services, failed an did not enabled those services again.


Take a look here, MS makes me mad.....

Not applicable
After installing this rollup I noticed that OCS integration are no more availale in OWA.
does anybody else have same problem?
Not applicable
On my first attempt at installing Rollup 4, it failed. I rebooted and couldn't connect to anything as far as Exchange management goes. Was getting WINRM errors via the shell and EMC wouldn't connect. So, I ran the update again. This time it succeeded and I rebooted. Still, no connectivity to Exchange.

I noticed that ALL the exchange services were set to Disabled, as well as W3SVC/IISADMIN and a few others.  I also read some threads about reinstalling WINRM. Turns out, it was not installed on the server. I installed it and then ran "winrm quickconfig." Then I set all the Exchange services to Automatic and started them all manually. Did the same for W3SVC and IISADMIN. I compared the services on another 2008R2 server to make sure everything else was set as it should be.

Rebooted, and everything came back. So far so good. [knocks on wood.]
Not applicable
In my case OWA also got broken and it left all services disabled.

Solved it with:

Change all "Microsoft Exchange...." services back to Automatic Startup

(Microsoft Exchange POP3, IMAP4, Monitoring and Server Extension for Windows Server Backup are set to manual by default - you might want to keep them that way)

Change the following (non-"Microsoft Exchange") services back to Automatic Startup:

- IIS Admin Service

- Microsoft Search  (Exchange)

- Remote Registry

- Windows Management Instrumentation

- World Wide Web Publishing Service

That got me up and running with UM, mail flow and Outlook clients connected, but OWA was still broken with the following symptoms:

When simply applying the Update Rollup 4 for Exchange 2010, you might end up with a blank logon screen at your CAS servers when you want to reach OWA.

When opening up the details of the error message, the following text is shown:

Message: Syntax error

Line: 1

Char: 1

Code: 0



How to solve it?

Stop all "Microsoft Exchange..."

(In my case also: Backup Exec and Symantec Mail Security for Exchange)

Start an Administrative Exchange Management Shell

Type ii Exchange2010-KB982639-x64-en.msp

Close the Exchange Management Shell and finish the patch.

Not applicable
Works with the german version too! THX to Steen Kirkby!
(ii Exchange2010-KB982639-x64-de.msp)
Not applicable
@Steen Kirkby - you are a life saver thank you.

After installing UR4 after being prompted by windows update I got the successfull install message but also experienced all services disabled and no owa..

your post was excellent and saved me from an office full of angry peeps with no email!

Not applicable
@Steen Kirkby - you are a life saver thank you.

After installing UR4 after being prompted by windows update I got the successfull install message but also experienced all services disabled and no owa..

your post was excellent and saved me from an office full of angry peeps with no email!

Not applicable
@Steen Kirkby
Excellent Post, works for me to
Not applicable
@Steen Kirkby
Thanks very much, you've just saved my bacon!
Not applicable
Very important problem!!!

We update RU4 automattically. But two times failed occurred.

after update successfully. but all exchange services disabled and owa crashed. And cannot open Exchange Management console.

We CAS server re-install. Owa working now. but blackberry not receive mail. And cannot open management console.

getting error : The Winrm client cannot process the request.İ cannot determine the content type of the HTTP response from the destination computer.The content type is apsent on invalid....

please help me!

Am I unistall rollup 4?

Not applicable
THX alot Steen. If u ever come to germany you will get a beer from me :)
Not applicable
I spoke to Microsoft Germany about this. Our problem was that the update rollup 4 would always stop with event id 1024 (error code 1603).
They recommended I stop all the Microsoft Exchange services, IISadmin and World Wide Web Publishing. Then change all the service startup types to manual (not automatic). Then install the update from an elevated command prompt. Then restart all the services and change back the startup types.

This worked for me.

As feedback for Microsoft I would say these sort of issues really should be caught before release. For my company Exchange server downtime is hard to organize and not a fun project when you read the problems people have had with this update! With Exchange 2007 we had no problems with any "update rollups" but with Exchange 2010 the team should really look at resolving all issues before releasing them.

Not applicable
I had to stop all services (exch*, iis, www) and run this from an admin command prompt in order to get it to install correctly.

msiexec /lv c:tempex-ur4-install.log /update C:tempExchange2010-KB982639-x64-en.msp
Not applicable
After this update i dont have permissions to create new mailbox and more... i log as an admin and a part of Organization Management group... before the update all worked well :)
Not applicable
Thanks Steen Kirkby!!   You saved me from this nightmare - Microsoft really left a steaming pile on the the floor with 2010 and this rollup.
Not applicable
Thanks Kirby! You save my hide big time. I can't believe there are so many people having these problems. The rollup was forced on me by Windows Update. Why would MS put this in Windows Update when there are so many problems with it?
Not applicable
Steen Kirkby's fix didn't work for me :( but I was able to get it done another way:

What I did to get it working again was download Rollup 4 from MS and saved it to the desktop:


Stopped the following services: all Exchange services, World Wide Web Publishing Service, IIS Admin, Microsoft Search (Exchange), Remote Registry, Windows Management Instrumentation and changed their startup type back to what they should be.

Then I launched the installer for rollup 4, finished the patch, rebooted and all was in order once again.  Hopefully this helps someone else.

Not applicable
Thanks Steen Kirkby!  Your solution fixed this nightmare.  It floors me that so many people can be having the exact same problem and Microsoft 1) won't fix it and 2) at least give us some warning.
Not applicable
The installer needs a more verbose way to tell what it is doing, brand new machine with Exchange 2010, and it runs update, and then just hangs, doesnt tell me that it cant go further, just hangs. Manually applying KB982639 after it fails (doesnt tell me it fails, just disables all my services) WTF?? Trying to work on why to migrate to 2010, and wondering if we actually should not. Hopefully gets better from here.
Not applicable
I had the same issues - 1st attempt at the update rollup "hanging" . . . 2nd attempt went through but all services diesabled and OWA no longer working as well.  I reenabled the Exchange services but OWA was still not working.  I called MS Tech support and the rep ultimately walked me through deleting the OWA and ECP virtual directories and recreating them.  Once that was done OWA worked again and all that was left was tweaking the redirects to how we had them before (mainly so that you didn't have to type /owa).

Not applicable
Hi All,

If we install Exchange 2010 UR4 ;
Do we still need UR1, UR2, UR3 to be installed ?

I think UR4 would have all the previous fixes as well, I have just installed a 2010 Trial download from Microsoft yesterday, so updated it with UR4 via Windows Update.

Also, the Exchange Mgmt console and Shell, both are very slow as compared to Ex.2007 - any suggestions to speed them up ?

Not applicable
I have installed Exchange 2010 SP1 Beta and seeing this error. Even though on same machine and domain setup i didn't face this error with exchange 2010
Not applicable
I just ran the UR4 2 more times (after is already completed successfully once) and the last time it changes all services back to automatic and corrected OWA.
Not applicable
Just my 2c worth: I noticed that on both our servers where we had this issue the .Net Framework 4 had been applied just before update rollup 4 was applied...

Could it be that the rollup and .Net4 don't like each other too well...? Maybe that's why the "creating assemblies" is taking ages - and people kill the installer because it seems to 'hang'...
Not applicable

"Creating assemblies" is taking ages because the install is trying to obtain the publisher CRL for all the .NET assemblies in the install package. Disable the option to check for publisher CRL as described in the KB: http://support.microsoft.com/?kbid=982639
Not applicable
Thanks Rob ..that worked

msiexec /lv c:tempex-ur4-install.log /update C:tempExchange2010-KB982639-x64-en.msp
Not applicable
Thanks to the Steen Kirkby solution.
I'm still alive.....
Not applicable
Thanks Steen Kirby. My internal OWA is fixed.
However, external OWA is not, it displays The page cannot be found error: with HTTP Error 404 - File or directory not found screen, even after successfully selecting Yes to continue to this website on the certificate warning page.

Can anybody assist? Thanks in advance.