%3CLINGO-SUB%20id%3D%22lingo-sub-2122256%22%20slang%3D%22en-US%22%3ERe%3A%20EXO%20V2%20PowerShell%20module%20is%20now%20Generally%20Available%20on%20Linux%20%26amp%3B%20macOS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2122256%22%20slang%3D%22en-US%22%3E%3CP%3EI%20found%20the%20problem.%20PowerShell%20requires%20an%20old%20version%20of%20OpenSSL%3A%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fpowershell%2Fscripting%2Finstall%2Finstalling-powershell-core-on-macos%3Fview%3Dpowershell-7.1%26amp%3Bpreserve-view%3Dtrue%23installing-dependencies%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fpowershell%2Fscripting%2Finstall%2Finstalling-powershell-core-on-macos%3Fview%3Dpowershell-7.1%26amp%3Bpreserve-view%3Dtrue%23installing-dependencies%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2122182%22%20slang%3D%22en-US%22%3ERe%3A%20EXO%20V2%20PowerShell%20module%20is%20now%20Generally%20Available%20on%20Linux%20%26amp%3B%20macOS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2122182%22%20slang%3D%22en-US%22%3E%3CP%3EGreat%20news!%20I%20am%20very%20excited%20about%20this%20functionality.%20I%20tried%20it%20out%20today%20and%20I'm%20still%20getting%20this%20error%3A%3CBR%20%2F%3E%3CBR%20%2F%3E%22no%20supported%20WSMan%20client%20library%20was%20found%22%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20on%20MacOS%2011.2.1%2C%20using%20PowerShell%207.1.1.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2125750%22%20slang%3D%22en-US%22%3ERe%3A%20EXO%20V2%20PowerShell%20module%20is%20now%20Generally%20Available%20on%20Linux%20%26amp%3B%20macOS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2125750%22%20slang%3D%22en-US%22%3E%3CP%3EIf%20you%20get%20an%20error%20while%20running%20Connect-ExchangeOnline%20on%20native%20Ubuntu%2020.04%20you%20need%20to%20ensure%20that%20libssl%201.0%20is%20installed.%3CBR%20%2F%3E%3CBR%20%2F%3EYou%20can%20use%20the%20following%20commands%3A%3C%2FP%3E%0A%3CPRE%3Esudo%20wget%20http%3A%2F%2Fsecurity.ubuntu.com%2Fubuntu%2Fpool%2Fmain%2Fo%2Fopenssl1.0%2Flibssl1.0.0_1.0.2n-1ubuntu5.5_amd64.deb%0A%0Asudo%20dpkg%20-i%20libssl1.0.0_1.0.2n-1ubuntu5.5_amd64.deb%3C%2FPRE%3E%0A%3CDIV%20class%3D%22ms-editor-squiggler%22%20style%3D%22color%3A%20initial%3B%20font%3A%20initial%3B%20font-feature-settings%3A%20initial%3B%20font-kerning%3A%20initial%3B%20font-optical-sizing%3A%20initial%3B%20font-variation-settings%3A%20initial%3B%20forced-color-adjust%3A%20initial%3B%20text-orientation%3A%20initial%3B%20text-rendering%3A%20initial%3B%20-webkit-font-smoothing%3A%20initial%3B%20-webkit-locale%3A%20initial%3B%20-webkit-text-orientation%3A%20initial%3B%20-webkit-writing-mode%3A%20initial%3B%20writing-mode%3A%20initial%3B%20zoom%3A%20initial%3B%20place-content%3A%20initial%3B%20place-items%3A%20initial%3B%20place-self%3A%20initial%3B%20alignment-baseline%3A%20initial%3B%20animation%3A%20initial%3B%20appearance%3A%20initial%3B%20aspect-ratio%3A%20initial%3B%20backdrop-filter%3A%20initial%3B%20backface-visibility%3A%20initial%3B%20background%3A%20initial%3B%20background-blend-mode%3A%20initial%3B%20baseline-shift%3A%20initial%3B%20block-size%3A%20initial%3B%20border-block%3A%20initial%3B%20border%3A%20initial%3B%20border-radius%3A%20initial%3B%20border-collapse%3A%20initial%3B%20border-inline%3A%20initial%3B%20inset%3A%20initial%3B%20box-shadow%3A%20initial%3B%20box-sizing%3A%20initial%3B%20break-after%3A%20initial%3B%20break-before%3A%20initial%3B%20break-inside%3A%20initial%3B%20buffered-rendering%3A%20initial%3B%20caption-side%3A%20initial%3B%20caret-color%3A%20initial%3B%20clear%3A%20initial%3B%20clip%3A%20initial%3B%20clip-path%3A%20initial%3B%20clip-rule%3A%20initial%3B%20color-interpolation%3A%20initial%3B%20color-interpolation-filters%3A%20initial%3B%20color-rendering%3A%20initial%3B%20color-scheme%3A%20initial%3B%20columns%3A%20initial%3B%20column-fill%3A%20initial%3B%20gap%3A%20initial%3B%20column-rule%3A%20initial%3B%20column-span%3A%20initial%3B%20contain%3A%20initial%3B%20contain-intrinsic-size%3A%20initial%3B%20content%3A%20initial%3B%20content-visibility%3A%20initial%3B%20counter-increment%3A%20initial%3B%20counter-reset%3A%20initial%3B%20counter-set%3A%20initial%3B%20cursor%3A%20initial%3B%20cx%3A%20initial%3B%20cy%3A%20initial%3B%20d%3A%20initial%3B%20display%3A%20block%3B%20dominant-baseline%3A%20initial%3B%20empty-cells%3A%20initial%3B%20fill%3A%20initial%3B%20fill-opacity%3A%20initial%3B%20fill-rule%3A%20initial%3B%20filter%3A%20initial%3B%20flex%3A%20initial%3B%20flex-flow%3A%20initial%3B%20float%3A%20initial%3B%20flood-color%3A%20initial%3B%20flood-opacity%3A%20initial%3B%20grid%3A%20initial%3B%20grid-area%3A%20initial%3B%20height%3A%200px%3B%20hyphens%3A%20initial%3B%20image-orientation%3A%20initial%3B%20image-rendering%3A%20initial%3B%20inline-size%3A%20initial%3B%20inset-block%3A%20initial%3B%20inset-inline%3A%20initial%3B%20isolation%3A%20initial%3B%20letter-spacing%3A%20initial%3B%20lighting-color%3A%20initial%3B%20line-break%3A%20initial%3B%20list-style%3A%20initial%3B%20margin-block%3A%20initial%3B%20margin%3A%20initial%3B%20margin-inline%3A%20initial%3B%20marker%3A%20initial%3B%20mask%3A%20initial%3B%20mask-type%3A%20initial%3B%20max-block-size%3A%20initial%3B%20max-height%3A%20initial%3B%20max-inline-size%3A%20initial%3B%20max-width%3A%20initial%3B%20min-block-size%3A%20initial%3B%20min-height%3A%20initial%3B%20min-inline-size%3A%20initial%3B%20min-width%3A%20initial%3B%20mix-blend-mode%3A%20initial%3B%20object-fit%3A%20initial%3B%20object-position%3A%20initial%3B%20offset%3A%20initial%3B%20opacity%3A%20initial%3B%20order%3A%20initial%3B%20origin-trial-test-property%3A%20initial%3B%20orphans%3A%20initial%3B%20outline%3A%20initial%3B%20outline-offset%3A%20initial%3B%20overflow-anchor%3A%20initial%3B%20overflow-wrap%3A%20initial%3B%20overflow%3A%20initial%3B%20overscroll-behavior-block%3A%20initial%3B%20overscroll-behavior-inline%3A%20initial%3B%20overscroll-behavior%3A%20initial%3B%20padding-block%3A%20initial%3B%20padding%3A%20initial%3B%20padding-inline%3A%20initial%3B%20page%3A%20initial%3B%20page-orientation%3A%20initial%3B%20paint-order%3A%20initial%3B%20perspective%3A%20initial%3B%20perspective-origin%3A%20initial%3B%20pointer-events%3A%20initial%3B%20position%3A%20initial%3B%20quotes%3A%20initial%3B%20r%3A%20initial%3B%20resize%3A%20initial%3B%20ruby-position%3A%20initial%3B%20rx%3A%20initial%3B%20ry%3A%20initial%3B%20scroll-behavior%3A%20initial%3B%20scroll-margin-block%3A%20initial%3B%20scroll-margin%3A%20initial%3B%20scroll-margin-inline%3A%20initial%3B%20scroll-padding-block%3A%20initial%3B%20scroll-padding%3A%20initial%3B%20scroll-padding-inline%3A%20initial%3B%20scroll-snap-align%3A%20initial%3B%20scroll-snap-stop%3A%20initial%3B%20scroll-snap-type%3A%20initial%3B%20shape-image-threshold%3A%20initial%3B%20shape-margin%3A%20initial%3B%20shape-outside%3A%20initial%3B%20shape-rendering%3A%20initial%3B%20size%3A%20initial%3B%20speak%3A%20initial%3B%20stop-color%3A%20initial%3B%20stop-opacity%3A%20initial%3B%20stroke%3A%20initial%3B%20stroke-dasharray%3A%20initial%3B%20stroke-dashoffset%3A%20initial%3B%20stroke-linecap%3A%20initial%3B%20stroke-linejoin%3A%20initial%3B%20stroke-miterlimit%3A%20initial%3B%20stroke-opacity%3A%20initial%3B%20stroke-width%3A%20initial%3B%20tab-size%3A%20initial%3B%20table-layout%3A%20initial%3B%20text-align%3A%20initial%3B%20text-align-last%3A%20initial%3B%20text-anchor%3A%20initial%3B%20text-combine-upright%3A%20initial%3B%20text-decoration%3A%20initial%3B%20text-decoration-skip-ink%3A%20initial%3B%20text-indent%3A%20initial%3B%20text-overflow%3A%20initial%3B%20text-shadow%3A%20initial%3B%20text-size-adjust%3A%20initial%3B%20text-transform%3A%20initial%3B%20text-underline-offset%3A%20initial%3B%20text-underline-position%3A%20initial%3B%20touch-action%3A%20initial%3B%20transform%3A%20initial%3B%20transform-box%3A%20initial%3B%20transform-origin%3A%20initial%3B%20transform-style%3A%20initial%3B%20transition%3A%20initial%3B%20user-select%3A%20initial%3B%20vector-effect%3A%20initial%3B%20vertical-align%3A%20initial%3B%20visibility%3A%20initial%3B%20-webkit-app-region%3A%20initial%3B%20border-spacing%3A%20initial%3B%20-webkit-border-image%3A%20initial%3B%20-webkit-box-align%3A%20initial%3B%20-webkit-box-decoration-break%3A%20initial%3B%20-webkit-box-direction%3A%20initial%3B%20-webkit-box-flex%3A%20initial%3B%20-webkit-box-ordinal-group%3A%20initial%3B%20-webkit-box-orient%3A%20initial%3B%20-webkit-box-pack%3A%20initial%3B%20-webkit-box-reflect%3A%20initial%3B%20-webkit-highlight%3A%20initial%3B%20-webkit-hyphenate-character%3A%20initial%3B%20-webkit-line-break%3A%20initial%3B%20-webkit-line-clamp%3A%20initial%3B%20-webkit-mask-box-image%3A%20initial%3B%20-webkit-mask%3A%20initial%3B%20-webkit-mask-composite%3A%20initial%3B%20-webkit-perspective-origin-x%3A%20initial%3B%20-webkit-perspective-origin-y%3A%20initial%3B%20-webkit-print-color-adjust%3A%20initial%3B%20-webkit-rtl-ordering%3A%20initial%3B%20-webkit-ruby-position%3A%20initial%3B%20-webkit-tap-highlight-color%3A%20initial%3B%20-webkit-text-combine%3A%20initial%3B%20-webkit-text-decorations-in-effect%3A%20initial%3B%20-webkit-text-emphasis%3A%20initial%3B%20-webkit-text-emphasis-position%3A%20initial%3B%20-webkit-text-fill-color%3A%20initial%3B%20-webkit-text-security%3A%20initial%3B%20-webkit-text-stroke%3A%20initial%3B%20-webkit-transform-origin-x%3A%20initial%3B%20-webkit-transform-origin-y%3A%20initial%3B%20-webkit-transform-origin-z%3A%20initial%3B%20-webkit-user-drag%3A%20initial%3B%20-webkit-user-modify%3A%20initial%3B%20white-space%3A%20initial%3B%20widows%3A%20initial%3B%20width%3A%20initial%3B%20will-change%3A%20initial%3B%20word-break%3A%20initial%3B%20word-spacing%3A%20initial%3B%20x%3A%20initial%3B%20y%3A%20initial%3B%20z-index%3A%20initial%3B%22%3E%26nbsp%3B%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2121811%22%20slang%3D%22en-US%22%3EEXO%20V2%20PowerShell%20module%20is%20now%20Generally%20Available%20on%20Linux%20%26amp%3B%20macOS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2121811%22%20slang%3D%22en-US%22%3E%3CP%3EAt%20Microsoft%20Ignite%202020%2C%20we%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fexchange-team-blog%2Fexchange-online-admin-news-at-microsoft-ignite-2020%2Fba-p%2F1687700%22%20target%3D%22_blank%22%3Eannounced%3C%2FA%3E%20the%20preview%20of%20support%20for%20Linux%20and%20Windows%20PowerShell%20Core%20%26nbsp%3Bin%20Exchange%20Online%20management%20using%20EXO%20V2%20Module.%20Today%2C%20we%20are%20delighted%20to%20announce%20general%20availability%20of%20this%20feature%20along%20with%20the%20support%20for%20macOS.%3C%2FP%3E%0A%3CP%3EOfficially%20supported%20distributions%20of%20Linux%20are%20Ubuntu%20versions%2018.04%20and%2020.04%20(native%20installations%20-%20not%20WSL).%20For%20macOS%2C%20supported%20versions%20are%20Mojave%2C%20Catalina%20%26amp%3B%20Big%20Sur.%20Read%20more%20in%20the%20detailed%20release%20notes%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fpowershell%2Fexchange%2Fexchange-online-powershell-v2%3Fview%3Dexchange-ps%23release-notes%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehere%3C%2FA%3E.%3C%2FP%3E%0A%3CP%3EIn%20addition%20to%20cross%20platform%20support%2C%20we%20added%20support%20for%20longer%20session%20timeouts%20in%20interactive%20scripting%20scenarios.%20The%20module%20is%20now%20more%20secure%20with%20real%20time%20policy%20and%20security%20enforcement%20in%20all%20interactive%20cases%20with%20the%20help%20of%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fazure-active-directory-identity%2Fmoving-towards-real-time-policy-and-security-enforcement%2Fba-p%2F1276933%22%20target%3D%22_blank%22%3E%3CEM%3EContinuous%20Access%20Evaluation%3C%2FEM%3E%3C%2FA%3E%20provided%20by%20Azure%20AD.%3C%2FP%3E%0A%3CP%3EVersion%202.0.4%20of%20EXO%20V2%20module%20is%20available%20at%20%3CA%20href%3D%22https%3A%2F%2Fwww.powershellgallery.com%2Fpackages%2FExchangeOnlineManagement%2F2.0.4%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noreferrer%22%3EPowerShell%20Gallery%3C%2FA%3E%20and%20we%20recommend%20all%20Exchange%20Admins%20start%20using%20this%20version%20of%20the%20module.%20Read%20more%20about%20how%20to%20install%20or%20update%20EXO%20V2%20module%20%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fpowershell%2Fexchange%2Fexchange-online-powershell-v2%3Fview%3Dexchange-ps%23install-and-maintain-the-exo-v2-module%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehere%3C%2FA%3E.%3C%2FP%3E%0A%3CP%3E%3CSPAN%20class%3D%22author%22%3EThe%20Exchange%20Online%20Admin%20Team%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-TEASER%20id%3D%22lingo-teaser-2121811%22%20slang%3D%22en-US%22%3E%3CP%3EAt%20Microsoft%20Ignite%202020%2C%20we%26nbsp%3B%3CA%20style%3D%22background-color%3A%20%23ffffff%3B%22%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fexchange-team-blog%2Fexchange-online-admin-news-at-microsoft-ignite-2020%2Fba-p%2F1687700%22%20target%3D%22_blank%22%3Eannounced%3C%2FA%3E%26nbsp%3Bthe%20preview%20of%20support%20for%20Linux%20and%20Windows%20PowerShell%20Core%20%26nbsp%3Bin%20Exchange%20Online%20management%20using%20EXO%20V2%20Module.%20Today%2C%20we%20are%20delighted%20to%20announce%20general%20availability%20of%20this%20feature%20along%20with%20the%20support%20for%20macOS.%3C%2FP%3E%3C%2FLINGO-TEASER%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2121811%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAnnouncements%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EExchange%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2128057%22%20slang%3D%22en-US%22%3ERe%3A%20EXO%20V2%20PowerShell%20module%20is%20now%20Generally%20Available%20on%20Linux%20%26amp%3B%20macOS%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2128057%22%20slang%3D%22en-US%22%3E%3CP%3EGreat%20news!%20Thanks%20and%20works%20with%20MacBigSur%20but%20I%20have%20the%20problem%20that%20everyone%20else%20haas%20too%2C%20namely%20openssl%201.1%20problem.%20I%20have%20downgrade%20to%20openssl%201.0%20and%20is%20functional%20now.%3CBR%20%2F%3EBut%20I%20think%20that%20is%20not%20optimal%2C%20due%20to%20securtity.%3CBR%20%2F%3EAre%20there%20any%20plans%20to%20get%20it%20updated%20so%20it%20works%20with%20openssl%201.1%20or%20later%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E

At Microsoft Ignite 2020, we announced the preview of support for Linux and Windows PowerShell Core  in Exchange Online management using EXO V2 Module. Today, we are delighted to announce general availability of this feature along with the support for macOS.

Officially supported distributions of Linux are Ubuntu versions 18.04 and 20.04 (native installations - not WSL). For macOS, supported versions are Mojave, Catalina & Big Sur. Read more in the detailed release notes here.

In addition to cross platform support, we added support for longer session timeouts in interactive scripting scenarios. The module is now more secure with real time policy and security enforcement in all interactive cases with the help of Continuous Access Evaluation provided by Azure AD.

Version 2.0.4 of EXO V2 module is available at PowerShell Gallery and we recommend all Exchange Admins start using this version of the module. Read more about how to install or update EXO V2 module here.

The Exchange Online Admin Team

4 Comments
Occasional Contributor

Great news! I am very excited about this functionality. I tried it out today and I'm still getting this error:

"no supported WSMan client library was found"

 

I am on MacOS 11.2.1, using PowerShell 7.1.1.

Occasional Contributor

I found the problem. PowerShell requires an old version of OpenSSL: https://docs.microsoft.com/en-us/powershell/scripting/install/installing-powershell-core-on-macos?vi...

If you get an error while running Connect-ExchangeOnline on native Ubuntu 20.04 you need to ensure that libssl 1.0 is installed.

You can use the following commands:

sudo wget http://security.ubuntu.com/ubuntu/pool/main/o/openssl1.0/libssl1.0.0_1.0.2n-1ubuntu5.5_amd64.deb

sudo dpkg -i libssl1.0.0_1.0.2n-1ubuntu5.5_amd64.deb
 
Frequent Visitor

Great news! Thanks and works with MacBigSur but I have the problem that everyone else haas too, namely openssl 1.1 problem. I have downgrade to openssl 1.0 and is functional now.
But I think that is not optimal, due to securtity.
Are there any plans to get it updated so it works with openssl 1.1 or later?