Last week we released Exchange Server 2010 Service Pack 1. It has received some great feedback and reviews from customers, experts, analysts, and the Exchange community.

The starting point for SP1 setup/upgrade should be the What's New in SP1, SP1 Release Notes, and Prerequisites docs. As with any new release, there are some frequently asked deployment questions, and known issues, or issues reported by some customers. You may not face these in your environment, but we're posting these here along with some workarounds so you're aware of them as you test and deploy SP1.

  1. Upgrade order

    The order of upgrade from Exchange 2010 RTM to SP1 hasn’t changed from what was done in Exchange 2007. Upgrade server roles in the following order:

    1. Client Access server
    2. Hub Transport server
    3. Unified Messaging server
    4. Mailbox server

    The Edge Transport server role can be upgraded at any time; however, we recommend upgrading Edge Transport either before all other server roles have been upgraded or after all other server roles have been upgraded. For more details, see Upgrade from Exchange 2010 RTM to Exchange 2010 SP1 in the documenation.

  2. Exchange 2010 SP1 Prerequisites

    Exchange 2010 SP1 requires the installation of 4-5 hotfixes, depending on the operating system – Windows Server 2008, or Windows Server 2008 R2. To install the Exchange 2010 SP1 administration tools on Windows 7 and Windows Vista, you requires 2 hotfixes.

    Note: Due to the shared code base for these updates, Windows Server 2008 and Windows Vista share the same updates. Similarly, Windows Server 2008 R2 and Windows 7 share the same updates. Make sure you select the x64 versions of each update to be installed on your Exchange 2010 servers.

    Update 2/11/2011: Windows 2008 R2 SP1 includes all the required hotfixes listed in this table — 979744, 983440, 979099, 982867 and 977020. If you're installing Exchange 2010 SP1 on a server running Windows 2008 R2 SP1, you don't need to install these hotfixes separately. For a complete list of all updates included in Windows 2008 R2 SP1, see Updates in Win7 and WS08R2 SP1.xls.

    Here’s a matrix of the updates required, including download locations and file names.

    HotfixDownloadWindows Server 2008Windows Server 2008 R2Windows 7 & Windows Vista
    A .NET Framework 2.0-based Multi-AppDomain application stops responding when you run the application
    or Microsoft Connect
    Windows6.0-KB979744-x64.msu (CBS: Vista/Win2K8)
    Windows6.1-KB979744-x64.msu (CBS: Win7/Win2K8 R2)
    N. A.
    An ASP.NET 2.0 hotfix rollup package is available for Windows 7 and for Windows Server 2008 R2
    Request from CSS
    N. A.
    AD RMS clients do not authenticate federated identity providers in Windows Server 2008 or in Windows Vista. Without this update, Active Directory Rights Management Services (AD RMS) features may stop working
    Request from CSS Select the download for Windows Vista for the x64 platform.
    Two issues occur when you deploy an ASP.NET 2.0-based application on a server that is running IIS 7.0 or IIS 7.5 in Integrated mode
    MSDN Windows6.0-KB979917-x64.msu (Vista)
    N. A.
    N. A.
    FIX: ArgumentNullException exception error message when a .NET Framework 2.0 SP2-based application tries to process a response with zero-length content to an asynchronous ASP.NET Web service request: "Value cannot be null".

    Microsoft Connect

    N. A.
    RPC over HTTP clients cannot connect to the Windows Server 2008 RPC over HTTP servers that have RPC load balancing enabled.

    Request from CSS

    Select the download for Windows Vista (x64)
    N. A.

    An update is available to remove the application manifest expiry feature from AD RMS clients.

    Download Center
    N. A.
    N. A.
    WCF services that are hosted by computers together with a NLB fail in .NET Framework 3.5 SP1
    MSDN Windows6.0-KB982867-v2-x64.msu (Vista) Windows6.1-KB982867-v2-x64.msu (Win7) X86: Windows6.1-KB982867-v2-x86.msu (Win7)
    x64: Windows6.1-KB982867-v2-x64.msu (Win7)
    FIX: An application that is based on the Microsoft .NET Framework 2.0 Service Pack 2 and that invokes a Web service call asynchronously throws an exception on a computer that is running Windows 7.
    Microsoft Connect
    N. A.

    x64: Windows6.1-KB977020-v2-x64.msu

    x64: Windows6.1-KB977020-v2-x64.msu

    X86: Windows6.1-KB977020-v2-x86.msu

    Some of the hotfixes would have been rolled up in a Windows update or service pack. Given that the Exchange team released SP1 earlier than what was planned and announced earlier, it did not align with some of the work with the Windows platform. As a result, some hotfixes are available from MSDN/Connect, and some require that you request them online using the links in the corresponding KBAs. The administrator experience when initially downloading these hotfixes may be a little odd. However, once you download the hotfixes, and receive two of the hotfixes from CSS, you can use the same for subsequent installs on other servers. In due course, all these updates may become available on the Download Center, and also through Windows Update.

    These hotfixes have been tested extensively as part of Exchange 2010 SP1 deployments within Microsoft and by our TAP customers. They are fully supported by Microsoft.

  3. Prerequisite download pages linked from SP1 Setup are unavailable

    When installing Exchange Server 2010 SP1 the prereq check may turn up some required hotfixes to install. The message will include a link to click for help. Clicking this link redirects you to a page saying that the content does not exist.

    We're working to update the linked content.

    Meanwhile, please refer to the TechNet article Exchange 2010 Prerequisites to download and install the prerequisites required for your server version (the hotfixes are linked to in the above table, but you'll still need to install the usual prerequisites such as .Net Framework 3.5 SP1, Windows Remote Management (WinRM) 2.0, and the required OS components).

  4. The Missing Exchange Management Shell Shortcut

    Some customers have reported that after upgrading an Exchange Server 2010 server to Exchange 2010 SP1, the Exchange Management Shell shortcut is missing from program options. Additionally, the .ps1 script files associated with the EMS may also be missing.

    We’re actively investigating this issue. Meanwhile, here’s a workaround:

    1. Verify that the following files are present in the %ExchangeInstallPath%\bindirectory:
      • - CommonConnectFunctions.ps1
      • - CommonConnectFunctions.strings.psd1
      • - Connect-ExchangeServer-help.xml
      • - ConnectFunctions.ps1
      • - ConnectFunctions.strings.psd1
      • - RemoteExchange.ps1
      • - RemoteExchange.strings.psd1

      NOTE: If these files are missing, you can copy the files from the Exchange Server 2010 Service Pack 1 installation media to the %ExchangeInstallPath%\bin directory. These files are present in the \setup\serverroles\common folder. < /note>

    2. Click Start -> AdmiinistrativeTools ->, right-click Windows PowerShell Modules, select Send to -> Desktop (as shortcut)
    3. Go to the Properties of the shortcut and on Target replace the path to C:\WINDOWS\system32\WindowsPowerShell\v1.0\powershell.exe -noexit -command ". 'C:\Program Files\Microsoft\Exchange Server\V14\bin\RemoteExchange.ps1'; Connect-ExchangeServer -auto"

      Note: if the Exchange installation folder or drive name is different than the default, you need to change the path accordingly.

  5. Upgrading Edge Transport on Forefront Threat Management Gateway (TMG) and Forefront Protection for Exchange 2010

    If you upgrade a server with the Edge Transport server role running with ForeFront Threat Management Gateway (TMG) and ForeFront Protection for Exchange (FPE) enabled for SMTP protection, the ForeFront TMG Managed Control Service may fail to start and E-mail policy configuration settings cannot be applied.

    The TMG team is working on this issue. See Problems when installing Exchange 2010 Service Pack 1 on a TMG configured for Mail protection on the ForeFront TMG (ISA) Team Blog. Exchange 2010 SP1 Release Notes has been updated with the above information.

    The ForeFront TMG product team has released a software update to address this issue. See Software Update 1 for Microsoft Forefront Threat Management Gateway (TMG) 2010 Service Pack 1 now av....

  6. Static Address Book Service Port Configuration Changes

    The location for setting the port the address book service should use has changed in SP1. In Exchange 2010 RTM you had to edit the Microsoft.exchange.addressbook.service.exe.config to configure the service port. In SP1 you must use the following registry key:
    Path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\MSExchangeAB\Parameters
    Value name: RpcTcpPort
    Type: REG_SZ (String)

    When you apply SP1 to a machine where you had previously configured a static port by editing the Microsoft.exchange.addressbook.service.exe.config file, the upgrade process will not carry forward your static port assignments. Following a restart, the Address Book Service will revert to using a dynamic port instead of a static port specified in the config file. This may cause interruptions in service.

    As with all upgrades where servers are in load balanced pools, we recommend you perform a rolling upgrade — removing servers from the pool, updating them and then moving the pool to the newly upgraded machines. Alternatively, we recommend that you upgrade an array of servers by draining connections from any one machine before you upgrade it.

    There are times when these approaches may not be possible. You can maintain your static port configuration, and have it take effect the moment the address book service starts for the first time following the application of the service pack, by creating the registry key BEFORE you apply SP1 to your server. The registry key has no impact pre SP1, and so by configuring it before you apply the Service Pack you can avoid the need to make changes to set the port post install, and avoid any service interruptions.

  7. iPhone, OWA Premium and POP3 & IMAP4 issues due to invalid accepted domain

    After applying E2010 SP1:

    1. iPhone users may not be able to view the content of incoming messages in their Inboxes, and when they try to open a message, they get an error saying:

      This message has not been downloaded from the server.

      Admins may see the following event logged in the Application Event Log on Exchange 2010 CAS Server:

      Watson report about to be sent for process id: 1234, with parameters: E12, c-RTL-AMD64, 14.01.0218.011, AirSync, MSExchange ActiveSync, Microsoft.Exchange.Data.Storage.InboundConversionOptions.CheckImceaDomain, UnexpectedCondition:ArgumentException, 4321, 14.01.0218.015.

    2. OWA Premium users may not be able to reply or forward a message. They may see the following error in OWA:

      An unexpected error occurred and your request couldn't be handled. Exception type: System.ArgumentException, Exception message: imceaDomain must be a valid domain name.

    3. POP3 & IMAP4 users may also not be able to retrieve incoming mail and Admins will see the following event logged in Event Log:

      ERR Server Unavailable. 21; RpcC=6; Excpt=imceaDomain must be a valid domain name.


    Please run the following command under Exchange Management Shell and verify that there is one domain marked as ‘Default’ and it's DomainName & Name values are valid domain names. We were able to reproduce the issue by setting a domain name with a space in it, like "aa bb"

    Get-AcceptedDomain | fl

    If you also have an invalid domain name there (for example, a domain name with a space in it), then removing the space and restarting the server will fix the EAS (iPhone), OWA, POP3 & IMAP4 issues as mentioned above.

    Command to run under EMS would be:

    Set-AcceptedDomain –Identity alue>lue>ue>e>>
    value>-Name “ValidSMTPDomainName”

    Thes examples update the Name parameter of the "My Company" and "ABC Local" accepted domains (the space is removed from both):

    Set-AcceptedDomain –Identity “My Company” –Name “MyCompany.Com”
    Set-AcceptedDomain –Identity “ABC Local” –Name “ABC.Local”

  8. Error when adding or removing a mailbox database copy

    If a server running Exchange 2010 RTM (or Exchange 2010 SP1 Beta) is upgraded to Exchange 2010 SP1, administrators may experience an error when using the Add-MailboxdDatabaseCopy or Remove-MailboxDatabaseCopy cmdlets to add or remove DAG members.

    When you try to add a DAG member, you may see the following error:

    Add-MailboxDatabaseCopy DAG-DB0 -MailboxServer DAG-2

    The result:

    WARNING: An unexpected error has occurred and a Watson dump is being generated: Registry key has subkeys and recursive removes are not supported by this method.

    Registry key has subkeys and recursive removes are not supported by this method.
    + CategoryInfo : NotSpecified: (:) [Add-MailboxDatabaseCopy], InvalidOperationException
    + FullyQualifiedErrorId : System.InvalidOperationException,Microsoft.Exchange.Management.SystemConfigurationTasks.

    The command is not successful in adding the copy or updating Active Directory to show the copy was added. This happens due to presence of the DumpsterInfo registry key.

    Workaround: Delete the DumpsterInfo key, as shown below.

    1. Identify the GUID of the database that is being added using this command:

      Get-MailboxDatabase DAG-DB0 | fl name,GUID

      The result:

      Name : DAG-DB0
      Guid : 8d3a9778-851c-40a4-91af-65a2c487b4cc

    2. On the server specified in the add command, using the database GUID identified, remove the following registry key:

      The GUID identified in this case is 8d3a9778-851c-40a4-91af-65a2c487b4cc. With this information you can now export and delete the DumpsterInfo key on the server where you are attempting to add the mailbox database copy. This can be easily done using the registry editor, but if you have more than a handful of DAG members, this is best automated using the Shell.

      This example removes the DumpsterInfo key from the 8d3a9778-851c-40a4-91af-65a2c487b4cc key:

      Remove-Item HKLM:\Software\Microsoft\ExchangeServer\V14\Replay\State\8d3a9778-851c-40a4-91af-65a2c487b4cc\DumpsterInfo

      To automate this across all servers in your organization, use the DeleteDumpsterRegKey.ps1 script.

      File: deletedumpsterregkey_ps1.txt
      Description: The DeleteDumpsterRegkey.ps1 script can be used to delete the offending DumpsterInfo registry keys that can cause this problem on all Exchange 2010 SP1 Mailbox servers in the organization. Rename the file to DeleteDumpsterRegkey.ps1 (remove the .txt extension).

      For more info, see Tim McMichael’s blog post Exchange 2010 SP1: Error when adding or removing a mailbox database copy.

Thanks to all the folks in CSS and Exchange teams who helped identify, validate and provide workarounds for some of the issues mentioned above, and to the Exchange community and MVPs for their feedback.

Bharat Suneja, Nino Bilic
M. Amir Haque, Greg Taylor,
& Tim McMichael


  • 9/7/2010: Updated list of files for the missing Exchange Management Shell shortcut issue
  • 9/15/2010: Udpated pre-reqs table:
    - 982867 required on Windows 2008 SP2
    - 983440 not required on Windows 2008 SP2
    - 977020 required on Windows 2008 R2
  • 9/21/2010: Added link to Software Update 1 for ForeFront Threat Management Gateway (TMG) 2010 Service Pack 1
    - Replaced "Request from CSS..." verbiage for KB 979917 with link to KB 979917 download on MSDN
  • 9/22/2010: Updated correct default Exchange install path (highlighted) in 'The Missing Exchange Management Shell Shortcut" section: C:\WINDOWS\system32\WindowsPowerShell\v1.0\powershell.exe -noexit -command ". 'C:\Program Files\Microsoft\Exchange Server\V14\bin\RemoteExchange.ps1'; Connect-ExchangeServer -auto"
Not applicable

Just a short question: Is it right that after installing SP1 it is no longer possible to manage Exchange 2010 forests with the EMC that don't have SP1 installed?

Thanks for your reply,
Not applicable
This: http://support.microsoft.com/kb/981474 also applies and the installer doesn't appear to have any detection logic to avoid it, so it simply fails halfway through. If you're doing an upgrade this can leave your server in an inconsistent state as it occurs just after all the old binaries are deleted.
Not applicable
FYI - The SP1 Prerequisites differ depending on role - per the SP1 upgrade Readiness Checks. I installed E2010 SP1 on my E2010 RTM/W2k8 R2 servers. CAS needed: 982867 979744 983440 977020 979099. HUB and MBX only needed: 979099 and Microsoft Office 2010 Filter Packs. UM only needed: Microsoft Unified Communications Managed API, Core Runtime 64-bit and Microsoft Server Speech Platform Runtime (x64).  I also had to make sure the Windows Firewall service was running.
Not applicable
I'm having trouble installing the UC Managed API Core Runtime... it fails with an error 1603. Unfortunately it doesn't seem to identify in the log which file path/registry entry it might be failing on. Any suggestions?
Not applicable
@MS PFE: Thanks for the details on requirements per server role. Note, this post only covers hotfixes. As mentioned in the post, Exchange 2010 Prerequisites lists the OS pre-reqs such as Filter Pack, .Net Framework, etc.
Not applicable
also noticed that in  addition to The Missing Exchange Management Shell Shortcut
powershell reg settings for some snapins are missing as below
Not applicable
@Exchange Team: Next time around please take another month or two and release products that install cleanly. Thanks for the post, surely helps (but should be done before release).
Not applicable
I got an error when upgrading my MB/HT server, the Upgrade ran perfectly on CAS, but in MB/HT Server i'm getting an error on the Mailbox Role, it says this:

[ERROR] This server role can't be installed because the following roles aren't current: AdminToolsRole

Any idea?
Not applicable
Is it supported, recommended that for a new Exchange 2010 install the SP1 is copied to the Updates folder, to incorporate the service pack into the install server installation process?
Not applicable
As far as I know, the SP1 you downloaded - after unpacking - it's a full Exchange 2010 Installation "Disc" with SP1 integrated.
You don't need your old "RTM" Disk.

You can install your future exchange server with this new install files.
Not applicable
Why Microsoft is no more considering quality of software?
Why Exchange 2010 SP1 has all these bugs?
Not applicable
Just to be aware!

Following my upgrade i could no longer open EMC, OWA etc on any of my CAS servers.

I discovered that the default website was not started. New bindings had been added to a secondary website which i use for external owa on a additional IP address.

As these bindings were to localhost on port 80 & 443 this obviously conflicted with the deafult website. Removing the newly created bindings and starting the default website solved my issues.
Not applicable
Better not to run SP1, exchange 2010 looks better with out it.
Not applicable
I am amazed...  in the history of all Exchange hotfixes, rollups and Service Pack releases, I don't think I recall seeing so many possible variations of flaws in the process to either upgrade or deploy new.

Can someone please explain why it was acceptable practice to release such an update with this many potential flaws, the majority of which seem to incur downtime and inconvenience to the end customer?  I'd really like to be able to see the positives with this release, but am struggling when the first hurdle to be jumped is so large.

Many thanks in advance.
Not applicable
Another issue I have uncovered. Brand new install, SP1 with server r2.  Install is completed but cant intialize the EMC at all. More than one person is reporting this

The following error occured when retrieving user information for Contosoadministrator
The operation could not be performed because object 's-1-5-21-4280747840-81974243-757702645-500' couldnt be found on
dc01.contoso.com. It was running command Get-LogonUser

CMDlet failed. Cmdlet Get-User, parameters {Identity=s-1-5-21-4280747840-81974243-757702645-500}
MsExchange Management Event ID 6
Not applicable
I have the same issue as Jon, but in this case I installed sp1 on an existing Exchange 2010 server.

Have tried to run the get-logonuser from Exchange Management Shell but it seems that the cmdlet can't be found at all.

[PS] C:UsersAdministratorDesktop>get-logonuser
The term 'get-logonuser' is not recognized as the name of a cmdlet, function, script file, or operable program. Check t
he spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:14
+ get-logonuser <<<<
   + CategoryInfo          : ObjectNotFound: (get-logonuser:String) [], CommandNotFoundException
   + FullyQualifiedErrorId : CommandNotFoundException
Not applicable
@CypherBit & Tim Bauer: Yes, the SP1 download is the full product. For new installs, you don't need to install RTM and then upgrade to SP1, and you don't need to slipstream SP1 bits into RTM bits.

Not applicable
Just a heads up for anyone wondering, to make sure the upgrade process will not have any issues with services start-up - when ForeFront for Exchange 2010 is installed disable the integration before upgrading, and enable it back after...

"C:Program Files (x86)Microsoft Forefront Protection for Exchange ServerFSCUtility.exe" /disable & /enable

Not applicable
Thanks for the info...
Not applicable

I work with hosted Exchange version and i don't have the "New-MailboxImportRequest" command... I search in the list with "Get-Command" but it does not appear.

However, i have the "Get-MailboxImportRequest" command so it's wired...

Can anyone verify if this command is available please ?

Thanks !
Not applicable
I love SP1, and have installed it on two servers, but I too am "scared" each time I install it, thinking it's not going to work.  How I long for the service packs of, say, Exchange 2003, when it just worked.
Not applicable
People who whine about Exchange 2010 SP1 not being "stable", "buggered" or whatever should conisder the complixty of the product, and the hundreds of thousands of lines of code this involves. Just upgraded different environments without any issue, including a test lab from SP1 Beta to SP1 RTM.

The devteam *can not* test each SP/rollup on *all* possible environments; of course they're testing them, but the core assumption is that the environment to upgrade is mastered and clean.

Anyway, dear DevTeam, there's no (public) mention on the move of the following settings:
- Address Book throttling moved to the Throttling Framework (companies with BES will be interested in knowing ;))
- OWA/IM integration: configuration during upgrade will be cleaned up (removed from the Web.config) and will have to be reconfigured with the Set-OwaVirtualDirectory cmdlet.
Not applicable
I confirm issue describe in number 7. However it occurs only when the CAS is on the same server than Mailbox.
Not applicable
I have the same issue as Flemming,  I also installed sp1 on an existing Exchange 2010 server. And now EMC dont work!!
Not applicable
If you've got this many bugs in a service pack, you're really quite messed up in that someone did not do enough testing or that you tried to cram too much into one service pack.
What you should do is withdraw this SP from the market, fix it so it works properly, and also bake in all the additional dependencies that you created with hotfixes and whatnot.
Basically no one in their right mind should install this until you release Service Pack Two (2) to fix all the mistakes in SP1.
Seems like E2k10 is becoming the Windows Vista of email servers.
Only reason to buy it with all these bugs etc. is vendor lock-in.
Not applicable
As one of many customers moving from 2003 to 2010, the issues with SP1 leave us pondering whether we should wait for SP2 ...
Not applicable
I think a lot of people don't get the big picture here.

If SP1 was so bad, I am sure that someone could uncheck the checkbox somewhere and pull the download.

Instead, the team is up front about issues that some people see. If you read this blog, you know its not the first time they do that.

Thanks for being honest, Exchange team! Would like to see fewer gotchas and that hotfix list is just crazy. But I applied SP1 withno issues.
Not applicable
@ExchangeTeam: Thanks for a comprehensive and informative blog post on the known issues with SP1. We just upgraded to SP1 with no issues other than the initial time required to figure out and download the hotfixes. Yes, we have DAGs too.

Keep up the great work!!

@Tom and others: You may want to read the blog again and actually try installing SP1 - not all of these are bugs. :)
Not applicable
Followed instructions to fix the DAG issue in lab. Nice post!
Not applicable
Hi, first off thanks for al the hard work. The update went as expected. There is just one problem. Some users have an empty global address list in outlook 2007.  They can't search it or anything. In OWA the addressbook seems fine. When I disable offline mode the addresslist is still empty. No static port was set prior to sp1. Someone seen this issue and was able to resolve it?
Not applicable
The EMC issue is fixed by following http://msexchangeteam.com/archive/2010/02/04/453946.aspx :

If the WSMan module entry is missing from the global modules section of the C:WindowsSystem32InetsrvconfigApplicationHost.config file, as follows:

              <add name="WSMan" image="C:Windowssystem32wsmsvc.dll" />

For some reason SP1 installer stripped this line.  Adding it back in and restarting the Default Web Site in IIS Admin solved that issue for us.

I'd also recommend a reboot after updating Mailbox servers, though a restart of the Windows Search (Exchange) service will suffice.  Otherwise you may get reports of "corrupt index" trying to switch  the Active node for DAG databases.
Not applicable
@Bharat Suneja [MSFT]: Thank you. Any idea when it will be available on VLSC? I only have the non SP1 version available.
Not applicable
I have WSMan module in C:WindowsSystem32InetsrvconfigApplicationHost.config file.
And EMC is not working!
Not applicable
Just like to say that I am seeing this aswell...thought it was my setup, and I have been going crazy trying to work out whats going on...any ideas from the Exchange team?

Mellachi said:
Hi, first off thanks for al the hard work. The update went as expected. There is just one problem. Some users have an empty global address list in outlook 2007.  They can't search it or anything. In OWA the addressbook seems fine. When I disable offline mode the addresslist is still empty. No static port was set prior to sp1. Someone seen this issue and was able to resolve it?
September 3, 2010 2:57 AM
Not applicable
Hi, having a problem with SP1, get the following when installing on CAS:
Organization Preparation Failed
Error: The following error was generated when "$error.Clear();
initialize-ExchangeUniversalGroups -DomainController $RoleDomainController -ActiveDirectorySplitPermissions
$RoleActiveDirectorySplitPermissions" was run:
"The well-known object entry 32:45FA417B3574DC4E929BC4B059699792:CN=Public Folder Management�ADEL:5b5de428-8721-4900-ab3a-fcd4641d408f,
CN=Deleted Objects,DC=sample,DC=com on the otherWellKnownObjects attribute in the container object
CN=Microsoft Exchange,CN=Services,CN=Configuration,
DC=sample,DC=com points to an invalid DN or a deleted object.  
Remove the entry, and then rerun the task.".
Not applicable
I'm confused on the release notes, so when it says it doesnt support OCS2007 does that mean after I install SP1 that my users with communicator will not longer have their integration working? such as the calendar not syncing with there presence.
Not applicable
I noticed that sp1 includes the  x-originating-ip email header when sending out of orgainzation and the inclusion of the mapi version (with mapi id 14.01.0218.012exchange) on the received header.  Was under the impression that Exchange was trying not  to advertise the version running (the smtp banner was changed with exchange 2007 to be "nuetral").  I've removed the x-originating-ip email header  by creating a transport rule but was wondering why the change in information released in an email.

Thanks for the great work
Not applicable
SP1 = iPad IMAP fail.    After the upgrade any IMAP connection gets a "This message has no content." error on about 50% of the emails that have HTML in them.    The listed iPhone tweak does not fix this.    Activesync seems fine, its IMAP that seems to be the problem.   Anyone know of a fix for this?    I have to wait 2 more months before I can have mutlipe activesyncs on the iPad, so I'm stuck using IMAP.     Its making me think about ditching the Exchange server at home and going gmail - just too many issues.
Not applicable
I had a problem after upgrading to SP1 where my Receive connector no longer accepted connections, it was refusing even the server its installed from telnet access to port 25.

Send connector was fine but I found I had to reapply the receive connector settings in either the powershell or EMC to make it work again.

Anyone else experience this issue ?

Unless it has been noted and I missed the comment before....
Not applicable
I'm having an error (Some controls aren't valid. - Setup previously failed while preforming the action "Install".  You can't resume setup by performing the action "BuildToBuildUpgrade".) when trying to apply SP1 to Server 2008 R2 that has the Exchange 2010 Management Tools installed.  Can an installation of just the management tools be upgraded to SP1?
Not applicable
I've tested with multiple accounts, all the same problem. Now I'v stumbled on to an account that doesn't have the problem on a laptop that's not member of the domain. Anyone any ideas, I'm going insane with this problem.

Anthony Spiteri said:
Just like to say that I am seeing this aswell...thought it was my setup, and I have been going crazy trying to work out whats going on...any ideas from the Exchange team?

Mellachi said:
Hi, first off thanks for al the hard work. The update went as expected. There is just one problem. Some users have an empty global address list in outlook 2007.  They can't search it or anything. In OWA the addressbook seems fine. When I disable offline mode the addresslist is still empty. No static port was set prior to sp1. Someone seen this issue and was able to resolve it?
September 3, 2010 2:57 AM  
Not applicable
this is just inacceptable. reminds me of the the first release of systems management server 2.0 many many years ago. please exchange team, pull the sp1 back and get some time for a better sp1. just a realistic opinion of someone who has been with exchange since 4.0.
Not applicable
Not applicable
Hi All,

I still have problem with EMC after installing SP1! I check http://msexchangeteam.com/archive/2010/02/04/453946.aspx :
and still got this problem please help.
Not applicable
for people with EMC issues. check if .dotnet 4 is installed .
remove from system restart the system and check EMC again.
Not applicable
IBVO i have  .NET Framework 4 Client profile and .NET Framework 4 Extended
Installed should i remove them? Are you sure?
Not applicable
I had the same issue. remove client first then framework4.
Problem is that it worked in my situation. cannot be 100% sure it will work in any situation.
You can check if more MC's have the same issue. if so, then it will be DOTNET4.
Not applicable
yepp i have more and will check this now THX!
Not applicable
On my other MC i dont have .net 4 installed.
.NET 4 is only installed on my exchange server with all of Exchange roles.

Exchange server = Win 2008 r2, Exchange server 2010 SP1
MC server = Win 2008 r2, EMC sp1

Not applicable
CHECK for instance the server manager is opening or event viewer and many other MC'S on the system where exchange is installed.