Announcing the Re-release of Exchange 2007 Service Pack 3 Update Rollup 3 (V2)

Published Mar 31 2011 04:00 AM 5,421 Views

Update 4/11/11: Please note that the E2007 SP3 RU3 will be available via Microsoft Update on 4/24/11.

On March 29th we posted an announcement to the EHLO blog about removing Update Rollup 3 for Exchange Server 2007 SP3 due to an issue that could result in database corruption.

The Exchange Servicing team has fixed the reported issue with RU3 and is making available a new version of RU3 for our customers, version, (KB2530488). We strongly advise all customers install this newly released version of Microsoft Exchange Server 2007 SP3 Update Rollup 3 and to discard any prior version of RU3 (KB2492691) which you may have.

RU3 Installation Guidance:

  • Customers with RU3 already installed within your Exchange environment

    It is not necessary for you to uninstall the existing RU3 within your environment. The new RU3 package can be installed over the top of the existing package installed on your servers.

  • Customers with previous SP3 RU’s installed within your Exchange environment

    You can simply install the new version of the RU3 package.

General RU Installation Guidance

  • Note for deployments that leverage Forefront Security for Exchange: For those of you running Forefront Security for Exchange perform these important steps from the command line in the Forefront directory before and after this rollup's installation. Without these steps, Exchange services for Information Store and Transport will not start back up. You will need to disable Forefront via "fscutility /disable" before installing the patch and then re-enable after the patch by running "fscutility /enable" to start it up again post installation.

We deeply regret the impact that these issues have had on our customers, and as always, we continue to identify ways to better serve your needs through our regular servicing releases.

Kevin Allison
General Manager
Exchange Customer Experience

Not applicable
Not applicable


We are working on a fix for the issue you mentioned. You can call Support and request an interim update or perform the following temporary workaround:

Get-OrganizationConfg | fl showInlineAttachments -> take note of the value and record it for future use.

Set-OrganizationConfig -ShowInlineAttachments $true


Not applicable

How is it possible that over the weekend a problem is identified in RU3, and then by Thursday it is re-released.  There clearly was not enough testing done on the first RU3 release, and with the second RU3 release out so quickly, I am guessing that the same amount of testing was applied.

Having been bit by the RU3 problem, I am not going to the "new" RU3 for awhile.

Not applicable

What abot re-seeding the databases on the passive ccr nodes?

Not applicable

Lamar - if you have been affected by the corruption issue, then yes you will need to reseed the affected databases.  you can follow the guidance at

If you were not affected, then you do not need to reseed databases.


Not applicable

While I can understand airwear's reluctance to trust this update, I think the speedy resolution is a testament to how determined the team is when it comes to issues like this. I have seen incidents in the past where a "faulty" patch was pulled for weeks before a re-release, and the fact it was back out so quickly suggests that the problem was obvious and simple enough to be resolved quickly.

Not applicable

Hi. For the folks who installed the V2 update, did the update fix the problem? How about the missing pdf attachment issue on mac mail clients as reported on this blog



Not applicable

I can't use domain admin to install the patch, It popup "The installer has insufficient privileges to modify this file" C:program FilesMicrosoftExchange ServerRelNotes.htm". I must use local admin to install the patch. Besides, after I complete the installation. I can't access email through OWA.  any help is appreciation.

Not applicable

@Steven - it sounds like you are trying to run the patch on a system with UAC still enabled. The easiest way I have found to run the patch in that scenario is to run a command window via the right mouse click AS AN ADMINISTRATOR (this part is key), and then run the patch from within that admin elevated window.

Not applicable

Any update on the release of a new RU or RU3v3 that addresses the PDF issue described in the comments? We just ecountered it at my work and I would rather deploy an official RU than an IU.

Not applicable

This did not fix the issue for us. We went directly to U3-2 and began having the corruption issues shortly after.  Our end users are also experiencing problems with PDF's.  I am planning to roll pack as soon as possible.

Not applicable

@Ragnott: Have you seen the following post related to attachment rendering?

/Mixed-ing it up: Multipart/Mixed Messages and You

Not applicable

Unfortunately this Exchange 2007 SP3 Rollup Update 3 has introduced problems with PDF attachments in our environment (a single stand-alone server).  Users can access the attachments via webmail, but not via Outlook.  I am going to try removing the update, then re-apply U3-2 manually, and see if that helps any.  If not I will just have to uninstall it.

Not applicable

Following up my previous, uninstalling Exchange 2007 SP3 Rollup 3-v2 has fixed the problem.  The emails with the missing attachments all came from Mac clients.  So Rollup 3-v2 is still Not Quite Right (NQR).  I guess I will wait for Rollup 4 and see if it is fixed in that.

Not applicable

After the installation of Rollup 3v2 my OWA stop to work correctly. I have a blank page when i tried to access to my External OWA URL :( I try to remove Rollup 3v2, Rollup2 and reinstall them with no chance.

After some google search i think that i must remove and re-install the client access role on the Exchange 2007 Server if i want to resolve this issue :(

Not applicable

@Andrea: Have you found a fix for this or did the "remove CAS-server" work for you. I installed this update this weekend and have the same issue from all "other" browsers (firefox, safari...).

Internet Explorer seems to work however we support about 800 MAC's they don't run IE.


Not applicable

After I installed this V2-patch all my e-mails ended up in queue marked as suspicious, removing patch solved that. Affected: SBS2008.

Version history
Last update:
‎Jul 01 2019 03:58 PM
Updated by: