WAC-Active Directory Trust Not Established or Broken. …

Published 12-16-2020 12:00 AM 1,642 Views
Microsoft

 

PROBLEM:

 

I began configuring a Windows Server 2019 Storage Space Direct (S2D) cluster using 3 virtual machines running on a physical Windows 2019 Hyper-V server. I started the installation using Windows Admin Center (v2009 Bld: 1.2.2009.21002) Cluster Creation wizard. I selected the Windows Server Deploy a failover cluster to run VMs or cluster roles and apps on Windows Servers option. I filled in all the screen information until I got to the end of the Networking: Virtual Switch page. When I clicked Next: Clustering it took me to the Validate Cluster page and presented the following error:


Active Directory trust not established or broken.
Please wait a bit for your domain to establish trust and refresh page...

 

  image001.png

The error message leads you to believe there is an Active Directory trust relationship issue with at least one of the nodes. Therefore, I started testing the nodes trust relationships with Active Directory. I confirmed all the nodes were in the domain and had connectivity with each other and the domain. Running the Test-ComputerSecureChannel command confirmed all the connections and did not show any errors. I could not find any issues with the trust relationship between the nodes and Active Directory.

 

 

SOLUTION:

The time zone was off/misconfigured on one of the nodes. I corrected it, the error went away, and I was able to proceed to Validate the cluster.

 

Therefore, confirm that the trust relationship with the nodes in the cluster and Active directory is healthy.

 

If they are all set properly, ensure that the time zone is the same on all S2D nodes. If necessary, set the time zone to the same zone on all the cluster nodes. If it is different on even one of the nodes, you will get the error when entering the Validate Cluster page.

 

 

And that is it. The steps above were successful in resolving the issue I had with the S2D-Active Directory trust not established or broken…  I hope this post saves you time if you ever encounter these errors. 

 

 

 

 

 

 

 

%3CLINGO-SUB%20id%3D%22lingo-sub-1953335%22%20slang%3D%22en-US%22%3EWAC-Active%20Directory%20Trust%20Not%20Established%20or%20Broken.%20%E2%80%A6%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1953335%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSTRONG%20style%3D%22font-family%3A%20inherit%3B%22%3E%3CSPAN%3EPROBLEM%3C%2FSPAN%3E%3C%2FSTRONG%3E%3CSPAN%20style%3D%22mso-ansi-language%3A%20EN-AU%3B%22%3E%3A%3C%2FSPAN%3E%3C%2FP%3E%0A%3CDIV%20class%3D%22WordSection1%22%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3E%3CSPAN%20style%3D%22mso-ansi-language%3A%20EN-AU%3B%22%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3EI%20began%20configuring%20a%20Windows%20Server%202019%20Storage%20Space%20Direct%20(S2D)%20cluster%20using%203%20virtual%20machines%20running%20on%20a%20physical%20Windows%202019%20Hyper-V%20server.%20I%20started%20the%20installation%20using%20Windows%20Admin%20Center%20(%3CSTRONG%3Ev2009%20%3CSPAN%20class%3D%22SpellE%22%3EBld%3C%2FSPAN%3E%3A%201.2.2009.21002%3C%2FSTRONG%3E)%20Cluster%20Creation%20wizard.%20I%20selected%20the%20%3CSTRONG%3EWindows%20Server%20Deploy%20a%20failover%20cluster%20to%20run%20VMs%20or%20cluster%20roles%20and%20apps%20on%20Windows%20Servers%20%3C%2FSTRONG%3Eoption.%20I%20filled%20in%20all%20the%20screen%20information%20until%20I%20got%20to%20the%20end%20of%20the%20%3CSTRONG%3ENetworking%3A%20Virtual%20Switch%3C%2FSTRONG%3E%20page.%20When%20I%20clicked%20%3CSTRONG%3ENext%3A%20Clustering%3C%2FSTRONG%3E%20it%20took%20me%20to%20the%20%3CSTRONG%3EValidate%20Cluster%3C%2FSTRONG%3E%20page%20and%20presented%20the%20following%20error%3A%3C%2FP%3E%0A%3CP%20class%3D%22xmsonormal%22%3E%3CSPAN%20style%3D%22color%3A%20black%3B%20mso-ansi-language%3A%20FR%3B%22%3E%3CBR%20%2F%3E%3CSTRONG%3E%3CI%3EActive%20Directory%20trust%20not%20established%20or%20broken.%20%3C%2FI%3E%3C%2FSTRONG%3E%3C%2FSPAN%3E%3CSTRONG%3E%3CI%3E%3CSPAN%20style%3D%22color%3A%20black%3B%22%3EPlease%3C%2FSPAN%3E%3C%2FI%3E%3C%2FSTRONG%3E%3CSTRONG%3E%3CI%3E%3CSPAN%20style%3D%22color%3A%20black%3B%20mso-ansi-language%3A%20FR%3B%22%3E%20wait%20a%20bit%20for%20your%20domain%20to%20%3C%2FSPAN%3E%3CSPAN%20style%3D%22color%3A%20black%3B%22%3Eestablish%3C%2FSPAN%3E%3C%2FI%3E%3C%2FSTRONG%3E%3CSTRONG%3E%3CI%3E%3CSPAN%20style%3D%22color%3A%20black%3B%20mso-ansi-language%3A%20FR%3B%22%3E%20trust%20and%20refresh%20page...%3C%2FSPAN%3E%3C%2FI%3E%3C%2FSTRONG%3E%3C%2FP%3E%0A%3CP%20class%3D%22xmsonormal%22%3E%3CSPAN%20style%3D%22font-size%3A%2012.0pt%3B%20color%3A%20black%3B%20mso-ansi-language%3A%20FR%3B%22%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%20class%3D%22xmsonormal%22%3E%3CSPAN%20style%3D%22font-size%3A%2012.0pt%3B%20color%3A%20black%3B%20mso-ansi-language%3A%20FR%3B%22%3E%26nbsp%3B%26nbsp%3B%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22image001.png%22%20style%3D%22width%3A%20555px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F237536i41EDE016A9F8B4A8%2Fimage-dimensions%2F555x189%3Fv%3D1.0%22%20width%3D%22555%22%20height%3D%22189%22%20role%3D%22button%22%20title%3D%22image001.png%22%20alt%3D%22image001.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%20class%3D%22xmsonormal%22%3E%3CSPAN%20style%3D%22font-size%3A%2012.0pt%3B%20color%3A%20black%3B%20mso-ansi-language%3A%20FR%3B%22%3EThe%20error%20message%20leads%20you%20to%20believe%20there%20is%20an%20Active%20Directory%20trust%20relationship%20issue%20with%20at%20least%20one%20of%20the%20nodes.%20Therefore%2C%20I%20started%20testing%20the%20nodes%20trust%20relationships%20with%20Active%20Directory.%20I%20confirmed%20all%20the%20nodes%20were%20in%20the%20domain%20and%20had%20connectivity%20with%20each%20other%20and%20the%20domain.%20Running%20the%20%3CSTRONG%3ETest-ComputerSecureChannel%3C%2FSTRONG%3E%20command%20confirmed%20all%20the%20connections%20and%20did%20not%20show%20any%20errors.%20I%20could%20not%20find%20any%20issues%20with%20the%20trust%20relationship%20between%20the%20nodes%20and%20Active%20Directory.%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%20class%3D%22xmsonormal%22%3E%3CSPAN%20style%3D%22font-size%3A%2012.0pt%3B%20color%3A%20black%3B%20mso-ansi-language%3A%20FR%3B%22%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3E%3CSPAN%20style%3D%22mso-ansi-language%3A%20EN-AU%3B%22%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3E%3CSTRONG%3E%3CSPAN%20style%3D%22mso-ansi-language%3A%20EN-AU%3B%22%3ESOLUTION%3C%2FSPAN%3E%3C%2FSTRONG%3E%3CSPAN%20style%3D%22mso-ansi-language%3A%20EN-AU%3B%22%3E%3A%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3EThe%20time%20zone%20was%20off%2Fmisconfigured%20on%20one%20of%20the%20nodes.%20I%20corrected%20it%2C%20the%20error%20went%20away%2C%20and%20I%20was%20able%20to%20proceed%20to%20Validate%20the%20cluster.%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3ETherefore%2C%20confirm%20that%20the%20trust%20relationship%20with%20the%20nodes%20in%20the%20cluster%20and%20Active%20directory%20is%20healthy.%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3EIf%20they%20are%20all%20set%20properly%2C%20ensure%20that%20the%20%3CSTRONG%20style%3D%22mso-bidi-font-weight%3A%20normal%3B%22%3Etime%20zone%3C%2FSTRONG%3E%20is%20the%20same%20on%20all%20S2D%20nodes.%20If%20necessary%2C%20set%20the%20%3CSTRONG%3Etime%20zone%3C%2FSTRONG%3E%20to%20the%20same%20zone%20on%20all%20the%20cluster%20nodes.%20If%20it%20is%20different%20on%20even%20one%20of%20the%20nodes%2C%20you%20will%20get%20the%20error%20when%20entering%20the%20Validate%20Cluster%20page.%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3EAnd%20that%20is%20it.%20The%20steps%20above%20were%20successful%20in%20resolving%20the%20issue%20I%20had%20with%20the%20%3CSTRONG%3E%3CI%3ES2D-Active%20Directory%20trust%20not%20established%20or%20broken%E2%80%A6%3C%2FI%3E%3C%2FSTRONG%3E%20%3CSPAN%20style%3D%22mso-spacerun%3A%20yes%3B%22%3E%26nbsp%3B%3C%2FSPAN%3EI%20hope%20this%20post%20saves%20you%20time%20if%20you%20ever%20encounter%20these%20errors.%E2%80%AF%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3E%3CSPAN%20style%3D%22mso-ansi-language%3A%20EN-AU%3B%22%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3E%3CSPAN%20style%3D%22mso-ansi-language%3A%20EN-AU%3B%22%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%20class%3D%22MsoNormal%22%20style%3D%22margin-bottom%3A%200in%3B%20line-height%3A%20normal%3B%22%3E%26nbsp%3B%3C%2FP%3E%0A%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-TEASER%20id%3D%22lingo-teaser-1953335%22%20slang%3D%22en-US%22%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%3EHello%20everyone%2C%20my%20name%20is%20John%20Clyburn%2C%20and%20I%20am%20a%20Sr.%20consultant%20in%20MCS.%20%3C%2FSPAN%3EI%20have%20recently%20run%20into%20a%20problem%20while%20working%20with%20nested%20virtualization%2C%20Storage%20Space%20Direct%20(S2D)%20and%20Windows%20Admin%20Center%20(WAC)%20that%20is%20quite%20interesting.%20The%20environment%20consisted%20of%20a%20physical%20Windows%202019%20Hyper-V%20server%20with%203%20virtual%20machines%20running%20Windows%202019.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3E%3CSPAN%3EI%20would%20like%20to%20share%20this%20with%20everyone%20in%20hopes%20that%20this%20will%20save%20you%20some%20time%20if%20you%20ever%20run%20into%20it.%3C%2FSPAN%3E%3CSPAN%3E%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-TEASER%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1953335%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EJohnClyburn%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Version history
Last update:
‎Dec 16 2020 03:08 PM
Updated by: