Application Deployment

%3CLINGO-SUB%20id%3D%22lingo-sub-363116%22%20slang%3D%22en-US%22%3EApplication%20Deployment%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-363116%22%20slang%3D%22en-US%22%3E%3CP%3EHi%2C%20I%20am%20a%20newbie%20to%20SCCM.%26nbsp%3B%3C%2FP%3E%3CP%3EI%20would%20like%20to%20deploy%20a%20.msi%20with%20a%20configuration%20file.%20Both%20of%20them%20need%20to%20be%20in%20the%20same%20folder%20so%20that%20when%20the%20client%20installs%20.msi%2C%20it%20also%20needs%20to%20read%20the%20configuration%20file.%3C%2FP%3E%3CP%3EHow%20do%20I%20deploy%20this%20through%20SCCM%3F%3C%2FP%3E%3CP%3EMany%20thanks%20in%20advance%20for%20your%20help.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-363116%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ECM%202012%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-363818%22%20slang%3D%22en-US%22%3ERe%3A%20Application%20Deployment%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-363818%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20mcgees.%3C%2FP%3E%3CP%3EThe%20config%20file%20is%20in%20the%20same%20folder%20as%20the%20application.%20However%20the%20client%20%3CSTRONG%3Eonly%3C%2FSTRONG%3E%20pulls%20down%20the%20app%20file%20(.msi).%20Thus%20the%20installation%20fails.%3C%2FP%3E%3CP%3EAnyone%20has%20a%20different%20idea%3F%20Many%20Thanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-363232%22%20slang%3D%22en-US%22%3ERe%3A%20Application%20Deployment%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-363232%22%20slang%3D%22en-US%22%3E%3CP%3EIf%20the%20config%20file%20is%20in%20the%20same%20folder%20as%20the%20application%20when%20imported%2Fcreated%20in%20CM%20then%20the%20client%20will%20pull%20down%20both%20into%20the%20CCMCACHE%20from%20where%20it%20will%20install%20on%20the%20client.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESee%20this%20post%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsccm%2Fapps%2Fdeploy-use%2Fcreate-applications%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsccm%2Fapps%2Fdeploy-use%2Fcreate-applications%3C%2FA%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hi, I am a newbie to SCCM. 

I would like to deploy a .msi with a configuration file. Both of them need to be in the same folder so that when the client installs .msi, it also needs to read the configuration file.

How do I deploy this through SCCM?

Many thanks in advance for your help.

2 Replies

If the config file is in the same folder as the application when imported/created in CM then the client will pull down both into the CCMCACHE from where it will install on the client.

 

See this post https://docs.microsoft.com/en-us/sccm/apps/deploy-use/create-applications

Thanks mcgees.

The config file is in the same folder as the application. However the client only pulls down the app file (.msi). Thus the installation fails.

Anyone has a different idea? Many Thanks.