Microsoft Azure ADSync doesn't start

Copper Contributor

Dear all,


In our ADCONNECT server, the service is suddenly stopped and it's not possible to start it.

Our synchronization between onpremise & Azure is stopped.

Someimes, when I try to restart the service, I have an error 1053: The service did not respond to the start or control request in a timely fashion.


Any idea? 

4 Replies
Don't know what version it is, but you could try upgrading/reinstalling the same version or higher to keep your configuration?
Yeah a repair - or if it an AD Connect V1, then upgrade to V2 -

Version 1.* of Azure AD Connect goes out of support this year, as it relies on an old version of SQL that won't be supported.'

You could try to increase the timeout threshold temporarily as a test - - to see if the service actually starts after a few minutes, but I would use the opportunity to upgrade it to the latest version, especially V2 if it was previously a V1 release..

@Luke Murray 


what if you are already on v2? i'm having the same problem, just on v2.

i've talked with support at nauseum, their solution was to reinstall, which works for a month or 5-6 weeks, then the the problem starts all over again. 


its been 5 months so far with no real answer. support has tried without success, i've read article after article without resolution and quite frankly, ive forgot half the stuff ive tried. 


so, if you have any other suggestions, i'm all ears. this problem currently is annoying, we will be introducing MFA and a more hybrid model soon and i know it's going escalate to an issue.  



You would almost think that, because it stops working after x weeks, that the sql database is reaching a limit of somekind? Or it's corrupt? (C:\Program Files\Microsoft Azure AD Sync\Data)