Azure App Service deploy task with Task version 4 getting failed

Copper Contributor

Hello all,


Azure App Service Deploy task in CD pipeline getting failed with "

 ##[error]TypeError: Cannot read property 'retrieveSecret' of undefined" i have been facing this issue for all pipelines which has Azure App Service Deploy Task with task version 4.
can any one please help me to trouble shoot this issue if you also facing same ?


19 Replies
I have the exact same issue and have filed a support ticket. I'm waiting to hear back but our deploys are also blocked by this 'retrieveSecret' error. If I find out anything I'll try to update this as well. So far I am just waiting for support to call ... and waiting ... and waiting ... ;)

@advps We are seeing the same this morning.

We are seeing the same



I and my friend in another company are facing the exact same issue. I believe this is not our fault. Wait for Microsoft to fix on their end.



@advps Same problem here, all pipelines are failing after the deploy task has been updated  to 4.223.0. 

Same problem here.  Will keep an eye on this post, was scratching my head trying to pinpoint what was up.

We're seeing the same thing. Hopefully MS sort it out. Glad I found this page.

@advps I can see the same issue on my end.

2023-05-25T12:38:59.3225528Z ##[debug][POST]<...>/resourceGroups/<...>/providers/Microsoft.Web/sites/<...>/publishxml?api-version=2016-08-01
2023-05-25T12:38:59.5884264Z ##[debug]Could not parse response: {}
2023-05-25T12:38:59.5884906Z ##[debug]Response: undefined
2023-05-25T12:38:59.5885423Z ##[debug]Correlation ID from ARM api call response : <Redacted>
2023-05-25T12:38:59.5956220Z ##[debug]Deployment Failed with Error: TypeError: Cannot read property 'retrieveSecret' of undefined
2023-05-25T12:38:59.5956764Z ##[debug]task result: Failed
2023-05-25T12:38:59.5990687Z ##[error]TypeError: Cannot read property 'retrieveSecret' of undefined

@advps Same issue here. I'm using classic pipelines and reverting to version 3 instead of 4 seems to have fixed it, though not ideal. 

@advps I deleted the Service Connection used and created a new one. It solved the problem for me

for temporary solution, downgraded to Task version 3 and working fine
Yes, this also worked for me.
I have the same issue, after I temporarily changed version from 4 to 3 task start working
Would like to add for visibility, we also began to see this error this morning with v4 tasks. Will try and report back if the v3 workaround works for us.
Seems issue fixed now , Task version 4 working fine

@kraken194 for now if you downgrade you app service deploy task version to 3 it will work.

for now if you downgrade you app service deploy task version to 3 it will work.

The issue has been fixed :

(by reverting back the change)


Happy deploying everyone! :cool: